[Solved] Cannot install OpenWrt on Velica (gl-inet b2200) [Solved]

Recently I installed the newest openwrt on a b1300 using the normal firmware web local upgrade. That went fine.

I tried to do the same on my b2200 and I could not - I get this message. I have searched the forums and could not find anything useful for me. Has anyone does this? My b2200 is running 3.215.

Anyway, thanks for looking.



I did see this at some point in my search, but don't actually understand it. Would you mind explaining this to me?

The installation instructions are in the last entry, what part need do you need help with ?

1 Like

Awesome, that did the trick thank you.. now, for some reason the Qualcomm Atheros IPQ4019 802.11nac radio will not turn on.

That should be handled in its own topic, but from what I see, the interface is up (just with no clients connected at this point); luci can be a bit confusing in this regard (signal and wireless rate can only be established if there are connected clients to this radio).

1 Like

The install instructions from the git link need to be added to the device page. I copied them below for anyone else that finds this article.

Update firmware instructions:
Please update the firmware via U-Boot web UI (by default at, following instructions found at
Normal sysupgrade, either via CLI or LuCI, is not possible from stock firmware.
Please do use the *gl-b2200-squashfs-emmc.img file, gunzipping the produced *gl-b2200-squashfs-emmc.img.gz one first.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.