[Solved] Cannot connect to internet

hi,
i have installed openwrt on my hg556a router and tried connect to internet but failed i have no experience how to deal with commands though i read alot of posts but no success i want to receive data from my adsl router to hg556a and then redistribute it through lan and wifi making hg556a act as arouer with separate ip address ...

root@PULPSTONE-LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd4:a64d:d128::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '3 5t'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option ipaddr '192.168.1.200'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option dns '8.8.8.8 8.8.4.4'

root@PULPSTONE-LEDE:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network ' '

config zone
        option name 'wan'
        option output 'ACCEPT'
        option masq '1'
        option mtu_fix '1'
        option input 'ACCEPT'
        option network 'wan6 3g hilink tethering 4g'
        option forward 'REJECT'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone
        option input 'ACCEPT'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option name 'WtoL'
        option network 'lan wan'

config forwarding
        option dest 'lan'
        option src 'WtoL'

config forwarding
        option dest 'WtoL'
        option src 'wan'

root@PULPSTONE-LEDE:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:01.0'
        option htmode 'HT20'
        option channel '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'PULPSTONE'
        option encryption 'psk2+ccmp'
        option key 'internet'

root@PULPSTONE-LEDE:~# 

thanks

This will probably work if you rm /overlay/upper/etc/config/firewall to restore the firewall to default. The changes you made there are all messed up. The default firewall has two zones for the networks lan and wan and proper forwarding out to wan. So if you don't by default get a wan network in /etc/config/network, create one named exactly 'wan' and it will match the firewall.

Also check that port 3 on the switch is the one that you are plugging into the modem/router. The numbers on the case may not match the numbers in the config.

Can you ping 8.8.8.8 from lan device?

thanks problem is resolved

What's the solution?

i was using lan3 port i found lan4 port is the wan port i reconfigured settings as basic toturial setting wan ip as client to adsl router 192.168.1.200 /255.255.255.0/192.168.1.1/dns servsers and making lan ip as 192.168.2.1/255.255.255.0/192.168.2.1 enabled dhcp for lan only and connected cables the right way . now i am connected to internet but not briged

note : i use pulpstone lede 17.1.4 which has lan4 port is wan by default

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.