[SOLVED] Building OpenWrt on debian 11 / bullseye fails

Checkout to branch origin/openwrt-21.02. All prerequisites installed, script feeds/install, make menuconfig.


  • several warnings: "has a dependency on 'libcap'"
 make[3] -C toolchain/binutils compile
    ERROR: toolchain/gcc/initial failed to build.
make -r world: build failed. Please re-run make with -j1 V=s or V=sc for a higher verbosity level to see what's going on
make: *** [/root/openwrt-sources-git/include/toplevel.mk:230: world] Error 1

I re-runned with these options, also with "-d" option - there is no "toolchain/gcc/initial" directory, and make stops. toplevel.mk at line 230 gives me no idea whats going on.

Anybody else had those problems and could solve it - or any ideas?

Thank you.

What are the actual error messages before that summary in the end?
In the verbose mode V=s you should get pretty detailed errors.
Please provide longer context.

Possibly something has changed in Debian default packages, and the toolchain compilation reacts to that.

You might also verify if Debian is able to build master (which has GCC 11 etc.).
That would indicate that something in 21.02 is the reason.

Thank you.

Problem solved. I was NOT on a branch, only did checkout a tag and had a "detached head". Why this gave me the described problem remains unsolved.

Compilation is ongoing, but beyond the point i had the error.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.