[Solved] Buffalo WZR-600dhp: Cannot replace DD-WRT IDEXX firmware

I've had a Buffalo WZR-600dhp that I've used OpenWRT on for years. No problems with it. Recently I thought I should have a spare that I could keep configured for a quick replacement if needed. Since this model is no longer made, off to eBay I went and found one in original packaging that was basically new.

Once I got it powered up and connected to it, I found that it has DD-WRT firmware that is branded with IDEXX (actually this is supported directly in the DD-WRT repository I found). No problem, thought I, I'll just upload OpenWRT and be up and running. No such luck.

Whatever image I try from the Web interface--OpenWRT or DD-WRT factory version--the router always reboots back into the IDEXX image. I tried the tftp image but always got a transfer timed out error. I tried and as tftp host addresses, the latter being the default address of the IDEXX image, but neither worked.

As a result I'm stuck. I know the hardware will work with OpenWRT but the current DD-WRT won't allow flashing in another image. What is my next step, if any?


Go to the dd-wrt forum and ask how to get back to stock firmware.
Once you are back to stock, you can try to install OpenWrt.


Also once you have stock firmware on this new to you router, set it up and test as a basic router / AP to make sure all the ports and the wifi radios work.

Finally got rid of the IDEXX firmware and have OpenWRt installed on it and loaded the latest configuration from my running router.

It did require soldering a header to the board and using the serial port to get an older OpenWRT installed and then upgrade to the latest. It was a learning experience...

For those that come across one of these routers with this firmware, the following DD-WRT forum thread should be of help: https://forum.dd-wrt.com/phpBB2/viewtopic.php?p=1183095#1183095

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.