[Solved] BT HomeHub 5 not working on Fibre


#1

Has anyone else had problems with their HH5 running LEDE after having changed over from standard BT broadband to fibre broadband?

I have had the HH5 running LEDE, installed and working very sucessfully for more than a year. I then was offered an improved higher speed service by changing over to fibre. This is not fibre right into my office, but fibre to the cabinet out in the street. The connection into the office and the BT master socket are the same as before and still copper.
So it works okay with the new router sent out by Daisy, my ISP. But when I put the HH5 LEDE on the line, it won't connect. The BT engineer says the system reports an 'out of sync' error. The blue broadband light comes on but doesn't stay on and on the status page you can see that it keeps trying to handshake but unsuccesfully.
The BT enginner said that roughly 50% of the time when he changes connectons over to the fibre system, the HH5 won't work. However the HH6 will work.
So I'm wondering if anyone else has had this problema and if there is a solution. Is there a HH6 available with LEDE blown in, or would it be possible to use the provided router just as a modem and then use the HH5 LEDE to do everything else?

Any thoughts or help much appreciated. Thank you.


#2

As far as the router/ modem is concerned, this has nothing to do with fibre, but is actually just an ordinary VDSL link to the cabinet. There are (foremost) two potential problems here, either you haven't selected the correct VLAN ID to get a connection (most modern VDSL even ADSL links require custom VLAN tagging) or you need to supply a vectoring enabled firmware blob for the modem - possibly both.


#3

Thank you for the reply. I’m not sure I understand what you’re saying tho. Are you saying that my connection is now VDSL, whereas before it was ADSL? And therefore I need different authentication? As far as I’ve been led to believe from Daisy, the username, password and all other settings are supppsedly the same as before. The HH5 just doesn’t seem able to handshake now it’s on the faster connection.


#4

I'm merely saying that unless the fibre optics cable actually ends up on your premises, with the ONT and everything else that involves - it'll just be clever marketing to call it fibre (fftc). The relevant technology, both on the hardware and protocol level that matters for you will still be xDSL. Technically both ADSL1/ ADSL2/ ADSL2+ or VDSL/ VDSL2 would fit the bill, in practice one can assume VDSL2 ("everything" above 20 MBit/s), usually with vectoring ("everything" above 50 MBit/s), though.

So for the sake of an argument, I'll take the most common example for something marketed as "fibre/ fttc" - namely VDSL2 with vectoring. In order to use this, you usually need:

  • a vectoring enabled firmware blob for the modem, while this is readily available, OpenWrt is not allowed to ship it for licensing reasons (so you'll have to supply it yourself and need to configure OpenWrt to use this blob)
  • in most (but not necessarily all) cases modern xDSL implementations (virtually all VDSL ones, but also ADSL on the BNG platform) you also need to use VLAN tagging on your WAN interface (dsl0) - which VLAN tag depends on the ISP in question, in germany most ISPs pick VLAN tag 7 (dsl0.7), in the UK ISPs relying on a BT backend seem to prefer VLAN tag 101 (dsl0.101), but there seems to be a bigger variation among ISPs there.

I have no idea what values are needed for Daisy, but if your wires are provided by BT, chances are that VLAN tag 101 might do.


#5

Yes, I agree it is partially marketing, but at the end of the day I'm geting much faster download, and more importantly for my business, much faster upload speeds. It's just a headache having changed over to find that my HH5 LEDE no longer connects, and the BT guy telling me that in roughly half of the cases where he has done that change over and a HH5 is involved, the HH5 will no longer connect.

My technical knowledge of these systems has a limit and it took me quite a while to get the LEDE hub set up in the first place, but it has been brilliant once working. I have no idea what the firmware blob is that you have mentioned or how to get it or configure it. I will have to Google it unless you are able to help further. As for the VLAN tag setting, is that something I can see in the GUI?

Many thanks :slight_smile:


#6

@LemonAde if I understand your situation correctly, your standard broadband was upgraded to 'fibre' broadband (by a BT Openreach Engineer) meaning, you went from ADSL to VDSL. Yah. But still you have a copper (wire) DSL-Telephone connection. Boo. Your Daisy Group Ltd router works okay but your HH5A does not. Although your logon passwords etc remain the same, you need to change the HH5A to use VDSL settings. According to Daisy's router guide the VLAN is the same 101 as for BT Infinity - actually you're using the BT network just under a different operator name.

The new VDSL settings are in section 7.5 of @bill888's legendary Installation Guide for the BT Home Hub 5A : https://www.dropbox.com/sh/c8cqmpc6cacs5n8/AAA2f8htk1uMitBckDW8Jq88a?dl=0

Daisy's settings are on page 6 of the The Daisy TECHNOCOLOR TG589/TG588 Configuration Guide PDF FYI from this:

Connection Type:VDSL
Enabled:On
IPv6:Off
Routed Type:PPPoE
Username:telephone-number@daisybb.co.uk
Password:YOUKNOWTHAT
MTU:1500
VLAN Enabled: On
VLAN ID: 101

btw In the UK, use of the term "fibre broadband" is misleading but allowed by the Advertising Standards Authority. You can read their dumbfounding reasoning behind what constitutes a part-fibre service here : https://www.asa.org.uk/news/asa-concludes-review-of-fibre-broadband.html


#7

Hello. And thank you for replying.
Yes you’re spot on with what you have said about the setup I have.
Thank you for the info on settings... I will have a look at that and see if there is anything that needs to be changed.
Many thanks, much appreciated.
Adrian


#8

@Geekuino
I've had some success today following your suggesrions, thank you....

I discovered that the router was set to ADSL only which is why it wouldn't connect. I changed it to VDSL along with the annex and tone settings as in the guide, and the DSL status is now 'UP' and shows the expected 40Mb connection speed.

However I can't get the network connection to work. I followed the instructions in the installation guide... namely editing the WLAN settings...PPoE instead of PPoATM, set the VLAN tag to 101 using the (ptm0.101 in the 'physical settings>interface' tab). I haven't changed anything else. I did a power cycle on the router but no luck...

If you have any further thoughts or ideas then I'd be very grateful to hear them.
Many thanks :slight_smile:31 49 26


#9

@LemonAde Good news that your HH5A has a healthy set of DSL stats. However the WAN is showing pppoa-wan. What you need to do is on the 'Interfaces - WAN' panel under 'General Setup', change the protocol to PPPoE [click yes to any nag message] and then 'Save & Apply'. The WAN should then read pppoe-wan. Also make sure under 'Advanced Settings' that 'bring up on boot' is checked. And then reboot, just to make sure it's stuck!


#10

Change the Encapsulation Mode to PTM, change Annex to B, and in the WAN area change the protocol to PPPoE.


#11

@savostyanov @Geekuino
I was just about to write a post to say that I had solved it... and you beat me to it... yes, it was the encapsualtion mode I had wrong. I'd done everythig else. It's now all working.
Many many thanks for your help and for taking the time to reply.
Much appreciated.


#12

@LemonAde If your problem is solved, please consider marking the topic as [Solved] (Click the pencil behind the topic...).