[Solved] Broken install on Netgear_7800

Installed over a year ago, but just got into deep trouble. I use OpenWrt as a router connecting my home LAN to the internet thru a true modem. Everything worked OK, and I made a backup. Later I added a DDNS -- Dynu.dns. It worked, but I didn't do a backup after that. I probably made some other changes too that I don't remember. Yesterday, I made some changes and bricked the router. I got back in by doing a hard reset on the router. The configuration had changed--maybe reverted to basic v.19.07. I tried restoring the saved img, but that didn't help. I lost the DDNS page. I tried to install ddns-scripts, but got errors. I think I need to revert to a "clean" configuration and redo things, but not sure how.

Also, I see now that my connection is "insecure" (http instead of https) -- not sure how to change that.

For a fresh start GUI SYSTEM/FLASH BACKUP FIRMWARE/PERFORM RESET, for https install package luci-ssl-openssl

1 Like

OK, thx for the quick reply. Did the Reset, seemed to work OK. Went to Software > Upgrade and upgraded all the pkgs shown with one "Error"

Upgrading dnsmasq on root from 2.80-15 to 2.80-16.1.

Errors

udhcpc: started, v1.30.1
udhcpc: sending discover
udhcpc: no lease, failing
Collected errors:

  • resolve_conffiles: Existing conffile /etc/config/dhcp is different from the conffile in the new package. The new conffile will be placed at /etc/config/dhcp-opkg.
    I'm guessing not a problem--just leave as is?

Next I tried installing luci-ssl-openssl as suggested. There were 4 dependencies which were able to be installed, then luci-ssl-openssl installed properly. Exited the web interface and tried to re-enter with "https://192.168.1.1" and the browser complained about lack of a Certificate. Found docs about this issue, so marking my original post solved. thx!