[SOLVED] Bricked tplink wr1043nd v1


After unsuccessfully upgrading from 15.01 to 18.06.02, my router ended up bricked. Power LED is the only one shining in addition to LAN port, when it is plugged to a PC. I tried various methods that involved holding reset button such as 30 30 30, but with no results.

After that I found this -> https://crosp.net/blog/hardware/unbrick-tp-link-wifi-router-wr841nd-with-tftp-wireshark/ guide, however I can't seem to get tftpd32 to upload recovery file. Up to that point, everything is going fine, tftp packets with read request appear in wireshark, but even with holding reset/wps button, nothing appears in tftpd, no matter how long the button is held. I tried various similar guides that recommended adding tftpd to firewall exceptions, disabling firewall, disabling wireless connections, also with no success. Am I missing something? Cheers!

It must be a problem with your server if you are seeing the router send TFTP requests but no replies from the PC.

So yes have your PC connected only to the router, no other network, set up static IP, use an unmanaged switch between the router and the PC so the PC stays happy with a steady Ethernet carrier while the router reboots. And completely turn off all firewalls. There's no security risk of doing that while you're not connected to any live network.

Thanks, turns out that anti virus was at fault and disabling it did the trick!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.