[SOLVED] Bricked Router (archer c6 v2)

I've installed openwrt on my archer c6 v2 router and accidentally ran command

opkg remove --autoremove '*'

when i list
df -h
there is no /rom

Filesystem                Size      Used Available Use% Mounted on
tmpfs                    59.6M      1.1M     58.5M   2% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
overlayfs:/overlay        1.3M    920.0K    424.0K  68% /

I haven't rebooted and I'm still sshed into the router.
How do i recover?

The easiest way to recover is to reset to defaults:

firstboot -y && reboot

Theoretically, you should be able to make a backup before you reset (assuming you hadn't done that already), and then you can restore your backup after.

firstboot isn't available because it's stored in /rom which is not available

Good point.

reboot into failsafe mode and then run the firstboot command.
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

 Caveat: Failsafe mode is only available if you have installed firmware from a Squashfs image, that includes the required read-only root partition. To verify whether your device has the SquashFS root partition, check for “squashfs” either in the OpenWrt image name or perform the following check on your device:

grep squash /proc/mounts

grep squash /proc/mounts
doesn't output anything so i guess failsafe isn't an option

Have you tried it? Your router should be using squashfs.

If i reboot i'm not going to have an option to ssh

You said this is an archer c6 v2. These only have squashfs images. Failsafe should work as described.

Further, if you really get into trouble, you can use the tftp recovery which should still work as that is bootloader based, and not dependent on OpenWrt.

2 Likes

So I've got into failsafe but when i try to 'mount_root' is says jffs2 not ready yet, using temporary tmpfs overlay
And i don't know how to mount it otherwise

I don’t think you need to mount root before doing the firstboot command.

then i got another problem when i run firstboot it outputs

/dev/mtdblock5 is not mounted
/dev/mtdblock5 will be erased on next mount

This is fine.

If you ran the command I provided earlier, it should reboot automatically and come back with the default configuration.

THANK YOU SO MUCH FOR SAVING ME :smiley: (it works)

1 Like

Glad it worked!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.