[Solved] AVM 4040 - Bricked on upgrade to 19

Had my 4040 successfully flashed to OpenWrt 18.06. While playing with the configurations over time I seemed to have messed up something. So I decided to upgrade to the new version and it seems, that I took the wrong image to flash - the complete one instead of the sysupgrade one.

Here my steps

After that the device rebooted and went dead.

  • All LEDs blink once
  • Only the Power LED comes up, blinks
  • After a pause the power LED blinks again and stays on
  • All other LEDs are off

Pressing any buttons (WPS or WLAN) on boot seems to have no effect.
No results can be monitored with tcpdump on the LAN or the WAN port.

Is there anything I can do to get the device back to life?
(I am a little bit into electronics, but never had any practise with JTAG & Co ... If there is a chance, I would give this a try but would have to be pointed into the right direction :wink: )


AFAIK as long as you didn't kill the bootloader, the AVM recovery should work:

I currently use only Linux - so *.exe is a little bit difficult.
I would expect that a LED is lighting up when I connect to any ethernet-port - or does the recovery software work on event that condition?
Will have to set up a VM in order to be able to try this out ... will take some time ...

Have you tried fritzflash already?


Nice tool. Unfortunately it did not work.

  • Changed my ethernet to the Fritz-range
  • default-parameter were not successful
  • also tried --ip --image

I also watched the traffic with tcpdump after the boot of the device on the ethernet-interface but no resonse from the box there. Ping to triggered the ARP requests, but no response.
Seems that the ethernet-interfaces of the box are not active.

So I think that the recovery-tool from AVM uses the same technique. So flashing over ethernet currently seems to be no option?

One more finding:
I once more tried the default-settings from OpenWrt on the LAN-Interface and there the box responds to ping requests (with the correct-mac address in the arp cache).

So the box is halfways configured to OpenWrt ...

Tried to connect with ssh, telnet or ftp but no response whatsoever.

As the device seemed not to be completely dead I tried the initial manual flash process which I used to flash from the fritz-firmware to OpenWrt again. (As described at https://openwrt.org/toh/avm/avm_fritz_box_4040)
To my surprise that worked. :-))
Flashed the complete image there and now the device is live again. :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.