[Solved] Attended Sysupgrade missing latest version and packages?

. .
Model GL.iNet GL-B1300
Architecture ARMv7 Processor rev 5 (v7l)
Target Platform ipq40xx/generic
Firmware Version OpenWrt 22.03.3 r20028-43d71ad93e / LuCI openwrt-22.03 branch git-22.361.69894-438c598

When attempting to generate an image via attended sysupgrade, I notice that:

  1. I can only see 22.03.5 unless I turn on Advanced Mode.
  2. If I turn on Advanced Mode, I can select 23.05.3, but many packages are missing in the list including, funnily enough, attendedsysupgrade-common. Others include coreutils.

I checked and at least attendedsysupgrade-common isn't installed by default in the prebuilt image. Am I missing something in how Attended Sysupgrade is supposed to work?

Seems that the missing version is by design - without Advanced the jump in version is deemed too much of a leap.

Still no idea why packages are missing but I've decided to do things the old way now anyway.

In what sense "missing", do you get an error from the build server when selecting those packages? They're available on my x86 machine running 23.05.3 (and my ipq806x running 23.05.2).

At least for attendedsysupgrade-common, if youinstalled luci-app-attendedsysupgrade it will automatically be included since luci-app-attendedsysupgrade has that one as a dependency, so it doesn't show up by itself in the package list.

In that it was missing from the list. But if it omits things that would be pulled in anyway I guess that makes sense.

I had to do a fresh install because of DSA but will note this for next time. Thanks!

1 Like

It could be interesting to know that Attended Sysupgrade doesn't do any of this logic itself, it invokes ubus call rpc-sys packagelist to get the user-installed packages, if you run that yourself in a SSH session you should get the same output.

Looking at rpc_sys_packagelist, which is what gets invoked by ubus call rpc-sys packagelist, it by default skips all packages with the Auto-Installed flag, unless you provide the all flag set to true (as in ubus call rpc-sys packagelist '{ "all": true }'), then you get all the packages.

I don't at all know the intricacies of what this difference will mean under the hood, but there's probably a good reason why user-installed and auto-installed packages are separated in this way.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.