[SOLVED] Asus RT-AC88U slow WAN 600Mb instead of 940Mb OpenWrt 22.03.0 r19685

My internet connection is asymmetrical 940Mb/60Mb I use it with Asus RT-AC88U.

The problem is that OpenWrt 22.03.0 r19685-512e76967f clean installation limits wired LAN/WAN speed to 600Mb/60Mb instead of 940Mb/60Mb (I try external speed test).

I tried original Asus software FW_RT_AC88U_300438648260.trx and AsusWRT-merlin version RT-AC88U_386.7_2.trx and on both of them I have 940Mb/60Mb external transfer, so this is only OpenWRT 22.03 problem.

I also tried another router Linksys WRT1200AC with older version of OpenLEDE and it has 940Mb/60Mb as well.

what can cause this kind of problem?

g

The almost 10 year old BCM4709 (2*1.4 GHz cortex A9/ ARMv7) does not have the physical performance you expect it to have. Broadcom OEM firmwares (and its derivatives) leverages proprietary "cut-through forwarding" (ctf.ko), which isn't available to OpenWrt.

1 Like

ok thx for explanation,
I am really surprised that my quite old router Linksys WRT1200AC works better then 'new' Asus RT-AC88U,
RT-AC88U has better wifi (coverage) and build in switch with total 8 LAN ports witch is really useful.
I don't want to use original firmware - vpnc to cisco is not supported there

g

agree with @slh rt-ac88u is too old, 5 years out of all sales, at least in my country.
But there is a good news for you, you can always buy x86 router from aliexpress and use both asus and linksys as AP and you will got outstanding performance with cable and wireless at the same time!

p.s. you can also use linksys for wire connections and asus as dumb ap, if as you mentioned first good for wired and asus better for wireles..

That's not really surprising either, yes it's also cortex A9 (2*1.33 GHz, so not thaaat different on paper), but combined with very performant I/O and well optimized networking/ switch drivers. What Broadcom hides behind their proprietary ctf.ko can be unleashed by OpenWrt for mvebu, as full driver support is available in mainline linux - just the wireless side (mwlwifi) is a sad and bugridden story (driver support abandoned by Marvell/ NXP, despite serious interoperability issue, totally broken 802.11w/ WPA3, broken AMPDU support and many more issues). It's a great wired-only platform, as long as you don't touch its wifi.

Try enabling packet steering
see https://git.openwrt.org/?p=openwrt/openwrt.git;a=commitdiff;h=e291e49da3e04bd1cd707958512e1834c18c54cd

ok, thanks, I found solution wich works for me with RT-AC88U,
Now I use htop to check CPU and when I use wired WAN/LAN I have 100% of both cores
but when I check two options in the firewall Experimental feature: "Routing/NAT Offloading" : "Software flow offloading" and "Hardware flow offloading" I have 100% of one core and another is almost not used and I have 940Mb/60Mb on wire

for now everything works as I expected, I will try to enable packet steering and compare results.

thanks
g

For 940/60 I would prefer losing some hundreds on mbps to enable sqm for reducing bufferbloat. I'm glad that openwrt works for you though

Packet Steering was enabled by default btw. thanks for help

1 Like

Maube try installing irqbalace to help with cpu load ...