[SOLVED] Asking for help to configure DSL on OpenWrt

[NOOB ALERT!!!]

Good morning everyone,
I'll briefly describe my use case:
I have an Italian Vodafone connection and I bought a Fitz!Box 7520 and fleshed OpenWrt 23.05 successfully in order to completely replace my Vodafone PowerStation.

I'm having a lot of troubles configuring DSL in order to make it work with my ISP (this specific ISP is not listed in the OpenWrt ISP guide), my main issue is making working the DSL port.

I've followed the guide for this device and installed the DSL firmware correctly (I mean, the disconnected port shows up as grey and "disconnected" with 0 traffic...).

Now the real problem comes when it's time to configure the DSL settings for my ISP, I'll list them below (they are public):

  • standard fisico: VDSL2
  • ecapsulation: PTM
  • VPI/VCI: -
  • VLAN: 1036
  • username: vodafoneadsl
  • password: vodafoneadsl
  • NAT: attivo

From my understanding I should configure the VLAN dsl0.1036 but I tried some configs and every time (even with only dsl0 device selected) it always shows up as "network device not connected" (I even tried to connect the DSL cable to a LAN port using an adapter and using that as device for the WAN but same result).

I think I'm clearly getting something wrong here, could someone help me understand the steps necessary to configure my router?

Thanks everyone in advance, I'll come back later to this thread in some hours, my configs right now are literally the stock config, I made a reset of the router.

Hi,

I am a non-expert who has dsl at home. My isp is sky ( uk ). I found a post for you :

Not sure how much is applicable to you. What I noticed is the vlan id. You said 1036, but the post above says 1063. Have a look and see if it useful. Thanks.

-Gamma

Thank you very much,
later on I will try this procedure from the post you mentioned:

The VLAN functionality in the "switch" area has nothing to do with the VLAN-ID you need for the VDSL connection.
In LuCI->Network->Interfaces->Devices you need to "Add device configuration" with "Device type" VLAN (802.1q), "base device" dsl0 and "VLAN ID" 1063. This will give you a "device name" dsl0.1063. After this, in Interfaces->WAN you just select PPPOE, your dsl0.1063 as device and you need to enter your credentials.

I really think it is just me that I hadn't configured VLAN correctly (since I never tried the method described above) but I'll also try the port.

I will update this in some hours but for now thanks a lot!

Share your /etc/config/networkplease, so people can have a look, easier than you saying what you set (and possibly overlooking things).

The DSL cable from the wall must be connected to the "DSL" port on the 7520 since that is the only port which has hardware to receive DSL signals.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.