[Solved] Aria2 [ERROR] SSL_CTX_new() failed


I've been having this problem with aria2 since the last upgrade :

root@OpenWrt:~# aria2c https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-

01/22 08:54:35 [NOTICE] Downloading 1 item(s)

01/22 08:54:35 [ERROR] SSL_CTX_new() failed. Cause: error:140A90A1:lib(20):func(169):reason(161)
Segmentation fault
Tue Jan 22 09:11:07 2019 kern.info kernel: [ 7019.097673] do_page_fault(): sending SIGSEGV to aria2c for invalid read access from 0000000c
Tue Jan 22 09:11:07 2019 kern.info kernel: [ 7019.106100] epc = 77db2cbc in libssl.so.1.0.0[77d7e000+59000]
Tue Jan 22 09:11:07 2019 kern.info kernel: [ 7019.111928] ra  = 00471168 in aria2c[400000+151000]

Thank you in advance for your help.

you can try enabling logging with this command
aria2c --log=- "https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-mir3g-squashfs-sysupgrade.bin"

or use wget instead of aria2c if want to work around it

wget "https://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-mir3g-squashfs-sysupgrade.bin"

It was just an example, to show the error, I really need aria2.
Nothing more with this order aria2c --log=- , the same error.

This fixes the error? I upgrade to latest snapshot, the problem is still present.


It's a patch. Need to wait for it to be merged (takes forever).

1 Like

I will wait patiently, thank you for your answers.

Edit : Problem solved with the lastest snapshot.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.