[SOLVED] Archer C7 refuses to install OpenWrt

My apologies if this has been done to death, but I think this needs to be documented, and here is as good a place as any...

Occasionally, TP-Link Archer C7 devices running stock firmware refuse to install OpenWrt via the browser-based firmware upgrade facillity. Sometimes, this is due to the fact that the device requires a region-specific version of firmware. So if this happens to you, check if there are region-specific versions of OpenWrt for your model and version.

For example, here's a fragment of the 22.03.4/targets/ath79/generic/ download page:

Note that for Archer C7 v2, there is a non-region-specific firmware and region-specific versions for the EU and the U.S. So if your router is the EU model, you will need the EU firmware; if it is the U.S. model, you will need the U.S. firmware.

And one more thing... If your Archer tells you to select a file for upload despite the fact that you have already selected one, it may be because it doesn't like the long name of the .bin file you have selected. So rename your .bin file into something like firmware.bin and try again...

Hope this helps someone... :smile:


I know I've mentioned it before, but it would really help if you just added these 2 simple lines to the Wiki.

In the past, I've tried to make a note of the posts you've made to see if I can find them again, I usually can't.

You provide really good points, and it's sad they get lost in the forum.


Here's what I ended up adding to the Archer C7 device page:

Archer C7 v2 may require region-specific firmware. For example, OpenWrt 22.03.4 exists in non-region-specific version (factory.bin), EU version (factory-eu.bin), and U.S. version (factory-us.bin). When installing via Web-based interface, the device will refuse to install the incorrect version and display a generic error message along the lines of “there's something wrong with this firmware, but I can't tell you what”. The solution is to use the region-specific firmware matching the region-specific hardware. Renaming the firmware image to firmware.bin before upload (see previous paragraph) is still a good idea.

Once again, I hope it helps someone... :smile:


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.