[Solved] Archer C7 - Cannot restore configuration

I have an Archer C7 with Lede 17.01.4
Made an backup of the settings through Luci.

Now when I want to restore the settings on this same Archer C7 (with same Lede version) it does not work.
I go to System --> Backup / Flash Firmware --> Restore backup and press the Choose file button.
Once I select my backup archive and press Upload Archive the device reboots and after a short while it's back online but none of my settings are restored.

Anyone have a clue what's going on?

I just tried a manual restore of my backup file.
scp the file to the /tmp dir and than:
tar xzvf /path/to/your/backup-xxx.tar.gz -C /

I see the files are "transferred" from the restore file but after a reboot everything is back to default again.

I have the same router and have not had issues restoring configs from backup.

The file may be corrupt.

To test, make a single change, backup the config, and restore it to see if it worked.

I don't what was wrong, but no change in the config survived a reboot.
That's why my restore did not stick as well.

I re-flashed the latest Lede stable (17.01.4) and after that I was able to make change and restore my config.
Now when I reboot the config sticks.

You might mark your topic as solved.

If I knew how to... :grimacing: