SOLVED: Archer C7 AC1750 v2 LEDE Install problem

I’m having some issues installing LEDE 17.01.4 on my Archer C7 v2.0 device. The serial number stars with 216A so I believe I have the 2nd revision of version 2.0.

Using the tftp method I can upload any TP-link version of the firmware and it works as expected. I originally tried LEDE version 17.01.4 from but it doesn’t seem to work (completely). No SSH (Connection refused) and port 80/443 both time-out, but DHCP requests work (192.168.1.x scheme). I also tried LEDE 17.01.0 - 17.01.3 with the same lack of complete success. I even reverted the firmware back to ArcherC7v2_en_us_3_14_3_up_boot(150427) and tried using the update firmware web option to install LEDE 17.01.4. It gave the same results. Then I installed the Tp-Link ‘Archer C7(EU)_V2_170803’ version via TFTP and installed the EU version of LEDE via the web UI. It looked like it installed (green bar across the screen and ‘Software Upgraded Successfully’), but I got the same results as before.

Then I tried openwrt 15.05.1 and 14.07 with the same results. Each time I update the router it reboots as expected and if I use a TP-Link firmware I can get to and everything works as expected, but on any other firmware I can’t get to (timeout). (NOTE: as expected doesn’t work on non TP-Link firmwares) The odd part is that I get a DHCP address on my physical connection (LAN 1) in the 192.168.1.x scheme when I flash a non TP-link firmware, so I know it’s partially up? (192.168.0.x DHCP IP scheme with TP-link firmware.)

My end goal is to setup 3 SSIDs each with their own VLAN ID. I just feel like I’m missing something obvious. Any suggestions?

nmap of device running LEDE 17.01.4 through LAN 1:
$: nmap -Pn -sV

Starting Nmap 7.60 ( ) at 2017-11-19 14:02 CST
Nmap scan report for
Host is up (0.014s latency).
Not shown: 993 closed ports
53/tcp    open     domain      dnsmasq 2.55
80/tcp    filtered http
139/tcp   open     netbios-ssn Samba smbd 3.X - 4.X (workgroup: WORKGROUP)
443/tcp   filtered https
445/tcp   open     netbios-ssn Samba smbd 3.X - 4.X (workgroup: WORKGROUP)
10000/tcp open     http        lighttpd 1.4.34
49152/tcp open     upnp        Cisco-Linksys E4200 WAP upnpd (UPnP 1.0)
Service Info: CPE: cpe:/h:cisco:e4200

Service detection performed. Please report any incorrect results at .
Nmap done: 1 IP address (1 host up) scanned in 121.59 seconds

Do you have any other device in your network which has the IP

1 Like

@tmomas You are correct. I new it was something simple. I was originally on a 10.x network, but had to move to a different access point/ssid to work on the device at its location. the new ssid is a 192.168.1.x network.

All is right with the world again. Thanks.

Sorry if I'm writing in the wrong topic. I have a question about Archer C7 AC1750.
I could not find LEDE version for that router, only OpenWRT. But I have found this topic and I'm a bit confused.
So can I install LEDE for a TP-Link Archer C7 AC1750 ?

The short answer is yes. Just be sure and look at the tag on the bottom to see what revision of the AC1750 you have. Also LEDE was/is a fork from OpenWRT and now seems to be in the process of merging back in.

I know there was some issues with the AC1750 version 1.x being fully supported at some point. I don't know if that has been solved. (mine is version 2.0)

In any case if you go to the "Table of hardware" page and set the filters below you will see the available versions.:
Brand: TP-Link
Model: AC1750

In theory this link should have the filters applied. Good luck.

Thanks! It's clear now.
This page is new for me, however, I'm using OpenWRT for a few years. The firmware available on the download side, but I checked it on the ToH page where only the OpenWRT link was available.