[Solved] After router reboot have to move RJ45 to new port

It's another weird question.
I'm in the process of moving to a new OpenWRT Router a Linksys EA7300 V1.
During that process I clicked "reboot" in the LuCI menu. After reboot it would not connect to the computer.
Ping and SSH do not work. The "Network Connections" window shows that "Ethernet" is "Network cable unplugged".
I manually power cycled it several times with no Joy and finally I moved the RJ45 to a new port and suddenly it worked again.
So I rebooted again with the same result then I just re-plugged in the connector in to the same hole and it did not work. Moved it to a new port and Bam! connection.
I have this Router connected to my Laptop running Windows 10 and it is set to Automatic (DHCP) mode but I also tried Static IP and it did not work. If it matters the Laptop is a Dell "Inspiron 5559 Signature Edition" (SE just meant less crapware).
I rebooted my PC into Manjaro LInux and the connection stayed. I rebooted the router in LuCI and the laptop stayed connected.
Same result for soft and hard reboots.

Generic info on the port map wiki for your device.

Let's have a look at

cat /etc/board.json

Since I may have misuderstood the Bam! "connection" as meaning you are getting an IP from the router and your only getting the 169.254.X.X range, you may consider the Back to OEM/Stock Firmware.

Back to OEM/stock firmware

Hard-reset the router three times to force it to boot from 'B.' This is where the stock firmware resides. To remove any traces of OpenWrt from your router simply flash the OEM image at this point.

You can also try to remove the DC power connector. Plug it back and the Linksys logo turns on. Then it turns off. Count 4 times “Logo turns on” and disconnect the DC power connector.

Whether static or DHCP I have a valid IP address.

	"model": {
		"id": "linksys,ea7300-v1",
		"name": "Linksys EA7300 v1"
	"led": {
		"lan1": {
			"name": "lan1 link",
			"sysfs": "green:lan1",
			"type": "netdev",
			"device": "lan1",
			"mode": "link"
		"lan2": {
			"name": "lan2 link",
			"sysfs": "green:lan2",
			"type": "netdev",
			"device": "lan2",
			"mode": "link"
		"lan3": {
			"name": "lan3 link",
			"sysfs": "green:lan3",
			"type": "netdev",
			"device": "lan3",
			"mode": "link"
		"lan4": {
			"name": "lan4 link",
			"sysfs": "green:lan4",
			"type": "netdev",
			"device": "lan4",
			"mode": "link"
		"wan": {
			"name": "wan link",
			"sysfs": "green:wan",
			"type": "netdev",
			"device": "wan",
			"mode": "link"
	"network": {
		"lan": {
			"ports": [
			"protocol": "static",
			"macaddr": "60:38:e0:d2:e9:**"
		"wan": {
			"device": "wan",
			"protocol": "dhcp",
			"macaddr": "60:38:e0:d2:e9:**"
	"system": {
		"label_macaddr": "60:38:e0:d2:e9:**",
		"compat_version": "1.1"

What are your expectation, intent, or use case with the newly flashed device?

Seems to have a DSA board w/ the recent build.

We haven't had need to explore any further.

Do you think the ports are mapped wrong?
Can we put this device on the internet and pull in
Opkg update

What if you unplug the cable, wait a minute then plug it back into the same port?

I was hoping to replace my slightly less powerful Netgear R6220 with this router that was free to me. But if I have to ask my family to swap Ethernet cables every time the power blinks out, this 7300 might just end up being a dumb Access point.
It is currently hooked up through my primary router (WAN to LAN) and has an internet connection. I updated all the packages before I rebooted for the first time and noticed the problem. According to the LuCI update window there is nothing to update (yes I did the "update list")
There is something in the wiki about the ports being labeled backwards but I didn't think that would matter.

Thank you, but what is the question. You only make statements.

I'm I to assume you want help ditching the static IP?

Make sure it's all Clear

Ah I see what you are getting at I called it a question but I never actually asked a question, how pedantically wrong of me.
How can I fix my router so that it will reconnect to my PC after the router has been rebooted?
The problem is that it fails to reconnect with my Windows PC after the router Reboots (soft or physical reboot)
It does however reconnect after a reboot on the same PC running Linux (Manjaro).
This seems like a major flaw and of the 4 OpenWRT routers I've owned this is the first time I've run into this problem.

OK Works with Linux!
IP retention on Windows SE

I don't know too much about Windows SE. Have to confirm your settings are correct, if they are: you've cooked my brain. :brain:

Also after confirmation that you set as pictured... run command prompt

ipconfig /release
wait for it
ipconfig /renew

If this seems to be a Windows only issue, Let's let @mk24 and other's make suggestions.

Might want to move this thread too.

Is there a virtual network adapter on the Windows PC assigned to the Linux distro VM.? Make sure it's disabled and perhaps Windows will reboot up on the Router??

No worries Signature Edition is just more "pure" Windows 10 where Dell didn't install it's crap.

Nope No VMs on this PC.

Beyond me. How do you run this Manjaro Linux on the same PC?

  • Dual Boot
  • Live CD


Test this..

From Command Prompt:

ipconfig /all

Check the adaptors listed do not share the same mac address from the Windows SE and the Window Linux (Manjaro)


Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe GbE Family Controller 
   Physical Address................: Does this mac address match the Linux (Manjaro)

Just wanted to park a search here in case this gets to bug status

I found a new wrinkle.
I really appreciate the help from volunteers like you, but I decided to set EA7300 up as a dumb AP.
By doing that the problem went away. Why? I have no idea. I guess if another device is handing out the IPs maybe but it didn't work with static IPs either so I'm lost.
So I changed all the settings back to make it a main router and the problem came back.
Since I don't have unlimited time I decided to make it a dumb AP for the backside of my house which is a waste.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.