[Solved] Advice to remove overlay/upper files corrupted my device

Hello, I am a new user of openwrt. I have installed image on TP-LINK WPA8631P. After a few moments of trying to configure it, I received a message that /rom is Read-Only.

When logging into SSH, there was a message to remove files from /overlay/upper. I went into /overlay/upper and performed a delete of everything.

Then reboot.

The router now won't boot with openwrt, and when I connect lan to it it pops up the network name TPLINK. I tried using the reset button, but it doesn't help. Is it possible to do something about this?

Try booting into failsafe mode and resetting your device to defaults.


Since it is only 8 MB flash you will need to be very careful installing packages and likely will need to resort to custom images (firmware-selector.openwrt.org) to run anything of size e.g. OpenVPN.

The best way to recover from overfilling the flash usually is to reset to default and start over.


I took the hint and put the device in failsafe mode. I then used the command

jffs2reset && reboot now

by which I restored the OpenWrt baseline version.

Thank you for the hint.

You’re welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.