[Solved] ADSL not working on ARV752DPW22 Easybox 803A LEDE 17.01.4

Thank you. I will try it the next days. But for now I can try removing them by opkg. It should come out the same, does it?

Yes, but i'm living in a small village in Germany. I am happy that I have DSL at all :see_no_evil: We don't get more rates


Now I removed all packages with opkg and the dsl modem still doesn't work.

practical yes, but it do not remove the packages it disable the packages only

I fear the kernel makes the different.

All the UCI config entrys and the initscrips aka /etc/init.d/dsl_control end up in a executable called /sbin/vdsl_cpe_control (not shure if it the same on a adsl router)

ps | grep "cpe_control"

You can equal from both Firmware. It is very cryptic and i have no idea what the meaning are exactly.

These Deamon create 3 pipes: /var/pipe/dsl_cpe0_event /var/pipe/dsl_cpe0_ack /var/pipe/dsl_cpe0_cmd
You can get the output from event via:

while true; do while read event < /var/pipe/dsl_cpe0_event; do echo "event>$event"; done; done

again here a lot of cryptic thinks where i do not know the meaning, but if it is the right firmware image you should get:


I am not shure, I am not an DSL expert enought but it is really import that your discovery can be veryfied.
It is a great mistery of Lantiq DSL chips why Annex-X works on a modell 1 and not on Modell 2, because the you can change the DSL-Firmware and the Chipsets are the same

see this dialog:

I would be interested: How can I test a modem if Annex J works without an Annex J connection ?

Hi. I flashed an other easybox 803a and it's the same here. Everything works except the dsl.

Would you have expected something different?

Try too change the Kernel:

wget -c https://downloads.lede-project.org/releases/17.01.4/targets/lantiq/xway/lede-imagebuilder-17.01.4-lantiq-xway.Linux-x86_64.tar.xz
tar -xf lede-imagebuilder-17.01.4-lantiq-xway.Linux-x86_64.tar.xz
cd ./lede-imagebuilder-17.01.4-lantiq-xway.Linux-x86_64

rm ./build_dir/target-mips_24kc_musl-1.1.16/linux-lantiq_xway/ARV752DPW22.bin
cp ./build_dir/target-mips_24kc_musl-1.1.16/linux-lantiq_xway/ARV8539PW22-kernel.bin ./build_dir/target-mips_24kc_musl-1.1.16/linux-lantiq_xway/ARV752DPW22.bin
rm ./build_dir/target-mips_24kc_musl-1.1.16/linux-lantiq_xway/ARV752DPW22.bin.dtb
cp ./build_dir/target-mips_24kc_musl-1.1.16/linux-lantiq_xway/ARV8539PW22-kernel.bin.dtb ./build_dir/target-mips_24kc_musl-1.1.16/linux-lantiq_xway/ARV752DPW22.bin.dtb

make image PROFILE=ARV752DPW22

and install the result image.

Thank you. I will try it the next days.

I got a w504v and flashed it with lede today with its correct firmware. On this router the DSL works as exprected. The DSL speed is also OK.


i tried it and i got a kernel panic:

[   12.935226] $ 0   : 00000000 7fe1c505 000395b0 000192a4
[   12.940293] $ 4   : c0007000 00000000 4403954a 00000000
[   12.945362] $ 8   : c00079e0 00000a82 00000008 00000009
[   12.950431] $12   : 83d08a6b 83d08a82 00002001 00000a82
[   12.955499] $16   : 00000024 00000070 00000024 0000001b
[   12.960568] $20   : 00000009 00000000 c00079e0 83d08a6b
[   12.965637] $24   : 00000009 00000111                  
[   12.970706] $28   : 830f4000 830f5ad8 c0007000 801d4bf4
[   12.975775] Hi    : 00014139
[   12.978564] Lo    : 999ab2ac
[   12.981359] epc   : 801d298c 0x801d298c
[   12.985074] ra    : 801d4bf4 0x801d4bf4
[   12.988786] Status: 1100fc03 KERNEL EXL IE 
[   12.992843] Cause : 00800008 (ExcCode 02)
[   12.996727] BadVA : 000395b0
[   12.999517] PrId  : 00019641 (MIPS 24KEc)
[   13.003399] Modules linked in: dwc2 uhci_hcd ehci_pci ehci_platform ehci_hcd gpio_button_hotplug
[   13.011945] Process tar (pid: 400, threadinfo=830f4000, task=838c4508, tls=77278d48)
[   13.019450] Stack : 00000001 830dec00 00000000 000e220c 00000001 c0037ca0 830ae2d8 c0037ea0
          00000009 0000001b 00000111 0000001a 83d08a83 00000000 00000147 83d08a82
          c0037ca0 00000000 00000215 00000111 830f5bb8 00000000 c0007004 00000a67
          80410000 c0047000 00000a81 c00079e0 00000002 00000000 80413adc 00000fe4
          00000a82 80413b0c 80410000 00000002 c011e000 00000000 00000000 00000008
[   13.053917] Call Trace:[<801d213c>] 0x801d213c
[   13.058242] [<8013a584>] 0x8013a584
[   13.061617] [<800beb98>] 0x800beb98
[   13.064995] [<801264f0>] 0x801264f0
[   13.068372] [<800832a8>] 0x800832a8
[   13.071757] [<80126618>] 0x80126618
[   13.075134] [<800837b4>] 0x800837b4
[   13.078514] [<8012dcac>] 0x8012dcac
[   13.081889] [<801286ec>] 0x801286ec
[   13.085274] [<801284c0>] 0x801284c0
[   13.088653] [<8008309c>] 0x8008309c
[   13.092026] [<800dc864>] 0x800dc864
[   13.095412] [<80085244>] 0x80085244
[   13.098785] [<8004f89c>] 0x8004f89c
[   13.102168] [<800854d8>] 0x800854d8
[   13.105549] [<800c28b4>] 0x800c28b4
[   13.108929] [<800c317c>] 0x800c317c
[   13.112302] [<800c21e4>] 0x800c21e4
[   13.115681] [<800df9d8>] 0x800df9d8
[   13.119061] [<800c3b0c>] 0x800c3b0c
[   13.122441] [<8000486c>] 0x8000486c
[   13.125822] 
[   13.127246] 
Code: 00821021  00063040  00863021 <94420000> 94c30000  384207ff  3405c328  00021102  00031902 
[   13.137033] ---[ end trace bc66acf5988edd85 ]---
[   13.144435] Fatal exception: panic in 5 seconds

Have you an full log espessialy the begin of Kernel Panic ?

I really wodering because it is the same like W504v Firmware with more packets.
I expected that it works but without WLAN.
If it works the DTS file must be modyfied step by step get the old back with testing, In the hope to find the right codeline with the reson for not working Annex J.
I can do it (not yet but next week) i have an 803a too, but no ADSL Annex J. You must test them.
But before i want to have an test if it work in generall.

try again with:

make image PROFILE=arcadyan_arv752dpw22 "PACKAGES=-kmod-eeprom-93cx6 -kmod-lib-crc-itu-t -kmod-ltq-ifxos -kmod-ltq-tapi -kmod-ltq-vmmc -kmod-rt2800-lib -kmod-rt2800-mmio -kmod-rt2800-pci -kmod-rt2x00-lib -kmod-rt2x00-mmio -kmod-rt2x00-pci -kmod-usb-ledtrig-usbport -kmod-usb-uhci -kmod-usb2 -kmod-usb2-pci -rt2800-pci-firmware"

Thank you. I did the test and annex j works. WLAN doesn't work as you expected.

Test if ADSL Annex J are working (i have no ADSL)
try0 = ARV8539PW22.dts - some packages
try1 = ARV8539PW22.dts + WLAN support (image works, WLAN is working too)
try2 - 4 = more and more elements from ARV752DPW22 (complett untested)
try5 = ARV752DPW22.dts
Buildscrips are inside

most interresting are try1

I would recommend to just get an xrx200 based device when you are already buying some used router. For example the Easybox 904xdsl works fine and have a build in screen. It also have build in telephone connectors (TAE connectors) that also work. The o2 box 6431 also works fine and have phone connector build in. If you dont need build in phone connector, then take a look into tp-link 8970, 8980, 9980. Those 3 have xrx200 build in and all 3 support vectoring with openwrt.

The xrx200 devices support following DSL-Lines: Annex b, Annex j, VDSL, VDSL Vectoring, profile 17a (the typical one), profile 30a, ...
And the xrx200 chipsets are known to be rock stable at DSL and to bring out the max speed. They are for example build into the AVM Fritzbox 7360/3370 (also supported by openwrt) and the AVM Fritzbox 7490 (not supported recently by openwrt as far as i know).