[Solved] ADSL not working on ARV752DPW22 Easybox 803A LEDE 17.01.4

Hello,

I installed LEDE 17.01.4 on my EasyBox 803A (ARV752DPW22).
Everything works including wireless except ADSL with T-Online (annex j)
If I use the firmware of the Speedport W504V (ARV8539PW22) then it works but wlan doesnt work (beacause the Speedport has different wifi hardware than Easybox).

Here is my dsl configuration:

config atm-bridge 'atm'                                            
        option vpi '1'                          
        option vci '32'       
        option encaps 'llc'                                               
        option payload 'bridged'                
                                                                          
config dsl 'dsl'                                
        option annex 'j'      
        option xfer_mode 'atm'

config interface 'wan'                          
        option ifname 'nas0.7'
        option proto 'pppoe'                    
        option ipv6 '1'                         
        option username 'xxxxx#0001@t-online.de'
        option password 'xxxxx'              
                                                                   
config device 'wan_dev'                         
        option name 'nas0'                      
        option macaddr 'xxxxxxx' #your mac address or choose one
                                                
config interface 'wan6'                                                   
        option ifname '@wan'                    
        option proto 'dhcpv6'                   
        option reqaddress 'none'                                          
        option reqprefix 'auto'

Can you help me what I can do make it work?

As @moeller0 mentions in this thread, you may need to use VLAN tag 7 on the WAN interface for PPPoE traffic...

LEDE User Guide section VLAN

Thank you for your answer.

I already use vlan tag 7 for wan interface as you see in my configuration:
config interface 'wan'
option ifname 'nas0.7'
I tried to adjust the network configuration like in the thread you mentioned but it didnt work.
If I use wrong firmware for this router (for w504v) then it works with the configuration above. But with the correct firmware it doesnt work. Maybe it's a driver problem?

Does the Modem syncing ?

if yes:
forgett my post

else:
you can try to add the right DSL firmware:
extrac them from Speedport W504V and put them on your router (USB-Stick)

them you can use:

...
config dsl 'dsl'                                
        option annex 'j'      
        option xfer_mode 'atm'
        option firmware '/path-to/dslfirmware'
...

But the problem at some Lantiq devices are: Although the chipset supports all of ADSL Annexes, but there have extra limits "Filter ?" that prevent to use some Annexes.
I am really interessted to it, but no one knows somthing concret things.

I fear your Router can without soldering Annex B only.
My source a this post

How can I see if it is syncing?

I compared the the file ltq-dsl-fw-b-danube.bin from lede firmware of easybox and w504v. They are exact the same.

I checked the performance of the dsl connection with firmware from w504v. And the perfomance was like on fritzbox. So I think the modem works without soldering.
And this page shows that the box can handle ANNEX J https://www.dslweb.de/news/dsl/dank-annex-j-kostenloses-speed-upgrade-fuer-vodafone-dsl-kunden-15051501.html
and if I use option annex 'b' it doesn't work, too.

run:

/etc/init.d/dsl_control status

It says Line State DOWN

OK you are not syncing
Whish Firmware is installed ?
try:

opkg list-installed | grep dsl

Background: Normally it exist 2 variants of DSL binary firmware Annex-A and Annex-B (i am not shure but the Annex-A is normally used for M, L J too)
These Packages have one sort of the firmware (for example annex-b) + binary patch to build the other annex (patch to build annex-a variant).
If you install the B variant (https://downloads.openwrt.org/releases/17.01.4/targets/lantiq/xway/packages/kmod-ltq-adsl-danube-fw-b_0.1-1_mips_24kc.ipk)
And use option annex 'a'
then the LEDE scripts build automaticly the annex a variant from the B-firmware + A-Patch and use them.
With the parameter "option firmware 'PATH'" you can override the procedure and use exact this firmware what you have specified.

For create the counterpart per Hand use the bpatch utility of your router.

You can try to install the other annex of your Firmware and try use them, or with other words test so much firmwares if it works.

Hi,

here the output:
root@LEDE:~# opkg list-installed | grep dsl
kmod-ltq-adsl-danube - 4.4.92+3.24.4.4-1
kmod-ltq-adsl-danube-fw-b - 0.1-1
kmod-ltq-adsl-danube-mei - 4.4.92-1
ltq-adsl-app - 3.24.4.4-2

On the firmware of the w504v the same files are installed

i will test it and install fw-a

Firmware annex a doesn't work also
lrwxrwxrwx 1 root root 38 Oct 17 18:32 /lib/firmware/adsl.bin -> /lib/firmware//ltq-dsl-fw-a-danube.bin

As I mentioned, the lede image of the 504V has also firmware fw-b (same file as on easybox) and the modem works with this image

note: for shure testing, it is required to restart the router with the new parameters.
Did everbody know an other method, it will really helpfull in generall ?

This what you are post @xxdanix91xx, makes me fear that it not possible without desoldering the "Filter" on Easybox 803A
It can be happen that Annex J will work but them it will be slow and unstable because it will be miss the down bands, because filter.

Yes, I did a /etc/init.d/network restart and a reboot after all changes for safety, it's one of my habits :slight_smile:

But I don't understand why the modem works with the firmware of w504V.

Where is the w504V in the wiki i can not find them ?
Whish firmware is used for the w504V ?

yep this is strange, possible reasons:
It does not really works the downbands will not used and the line is very unstable.
are the down and uploadrates are same as before ?

If you use the Firmware from w504V can you exact spezifie the firmware file via "option firmware 'Path'"
Can it happens that the firmware was created via bpatch as i descripe ?

This is the wiki page: https://wiki.openwrt.org/toh/t-com/spw504v

I used this firmware: lede-17.01.4-lantiq-xway-ARV8539PW22-squashfs-sysupgrade.bin

yes, they are about the same

In both cases the firmware was specified with option firmware path. But the image of w504v also works without this line

I flashed the w504 again now with preserving the configuration. And after the reboot the dsl works fine and I get a pppoe-wan interface with a public IP address.

root@LEDE:~# /etc/init.d/dsl_control status
ATU-C Vendor ID:                          Broadcom 177.140
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Ifx-Danube 1.3
Firmware Version:                         2.4.1.7.0.2
API Version:                              3.24.4.4
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x1, 0x0
Annex:                                    J
Line Mode:                                G.992.5 (ADSL2+)
Profile:                                  
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 210 / Far: 3695
Errored seconds (ES):                     Near: 0 / Far: 1
Severely Errored Seconds (SES):           Near: 0 / Far: 0
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 69 / Far: 69
Header Error Code Errors (HEC):           Near: 0 / Far: 291
Non Pre-emtive CRC errors (CRC_P):        Near:  / Far: 
Pre-emtive CRC errors (CRCP_P):           Near:  / Far: 
Power Management Mode:                    L0 - Synchronized
Latency / Interleave Delay:               Down: Interleave (8.0 ms) / Up: Interleave (7.50 ms)
Data Rate:                                Down: 8.192 Mb/s / Up: 1.888 Mb/s
Line Attenuation (LATN):                  Down: 23.8dB / Up: 13.7dB
Signal Attenuation (SATN):                Down: 38.7dB / Up: 15.3dB
Noise Margin (SNR):                       Down: 6.0dB / Up: 13.7dB
Aggregate Transmit Power (ACTATP):        Down: 9.9dB / Up: 13.0dB
Max. Attainable Data Rate (ATTNDR):       Down: 8.400 Mb/s / Up: 1.888 Mb/s
Line Uptime Seconds:                      333
Line Uptime:                              5m 33s

This what you say is very interesting and can normally not happen, the only explanetation is:
It does not really working on the speedport W504v too, but i thing you have check it and the datarates are the same as they should be ?

The other theory the opinium that it must be desolder somethings are wrong and it works with an differ config.
I guess something inside the *.dts files. it is possible to replace the kernel only ?
(put the 803A Firmware to the 803A Router and them replace the kernel with the kernel from 504v.

Other explanetations are Voodo and conspiracy.

Can you make a list in which packets the router differ ?

It is a great mistery on lantiq devices why annex-X works on a routermodell-1 and why it does not work on the routermodell-2 with same modemchip with the same firmware in general.

Thank you for your time :slight_smile:
I dont't have a speedport w504v. I only used the firmware image of it and flashed it on the easybox. But I will buy one the next days. They cost less than 10€.

Yes, the rates are ok, they are about the same like on my fritzbox.

I will make a list of the packets that differ. I dont't know how I can flash the kernel. But I think the problem is the kernel. What is the difference in modem drivers of the lede image of the easybox 803a and the speedport 504v?
If wifi drivers of the speedport image would work on my easybox then i could use the speedport firmware. :slightly_smiling_face:

Here is the comparison of the packages from the two firmwares:

dani@dani-eeepc:~$ diff opkg-w504v opkg-easybox803A 
16,18d15
< kmod-ath - 4.4.92+2017-01-31-3
< kmod-ath9k - 4.4.92+2017-01-31-3
< kmod-ath9k-common - 4.4.92+2017-01-31-3
20a18
> kmod-eeprom-93cx6 - 4.4.92-1
27a26
> kmod-lib-crc-itu-t - 4.4.92-1
31a31,33
> kmod-ltq-ifxos - 4.4.92+1.5.19-2
> kmod-ltq-tapi - 4.4.92+3.13.0-3
> kmod-ltq-vmmc - 4.4.92+1.9.0-2
39d40
< kmod-owl-loader - 4.4.92-1
43a45,50
> kmod-rt2800-lib - 4.4.92+2017-01-31-3
> kmod-rt2800-mmio - 4.4.92+2017-01-31-3
> kmod-rt2800-pci - 4.4.92+2017-01-31-3
> kmod-rt2x00-lib - 4.4.92+2017-01-31-3
> kmod-rt2x00-mmio - 4.4.92+2017-01-31-3
> kmod-rt2x00-pci - 4.4.92+2017-01-31-3
46a54,57
> kmod-usb-ledtrig-usbport - 4.4.92-1
> kmod-usb-uhci - 4.4.92-1
> kmod-usb2 - 4.4.92-1
> kmod-usb2-pci - 4.4.92-1
91a103
> rt2800-pci-firmware - 2016-09-21-42ad5367-1

They are 100% equal.

The only kmods that are differ and have to do with the lantiq chipsets are this modules:
kmod-ltq-ifxos
kmod-ltq-tapi
kmod-ltq-vmmc

Hmm you can build an 803A Firmware by the imagebuilder without theese packages:
by adding

make image PROFILE=arcadyan_arv752dpw22 "PACKAGES=-kmod-eeprom-93cx6 -kmod-lib-crc-itu-t -kmod-ltq-ifxos -kmod-ltq-tapi -kmod-ltq-vmmc -kmod-rt2800-lib -kmod-rt2800-mmio -kmod-rt2800-pci -kmod-rt2x00-lib -kmod-rt2x00-mmio -kmod-rt2x00-pci -kmod-usb-ledtrig-usbport -kmod-usb-uhci -kmod-usb2 -kmod-usb2-pci -rt2800-pci-firmware"

And after them you should save the sysupdrade-image and rename the W504v kernel to 803A kernel and do again

But do Install only if you have serial access and if you can start from beginnig.

If Annex J work you can install the packages step by step.
But i am skeptik wikipedia says Annex J should have an Upload rate from 3,5Mbit/s