[Solved] 802.11ax worse than 802.11ac with mt76 driver?

Bringing the TX power down a bit or moving the band from 80Mhz to 40Mhz does bring the upload speeds closer to 802.11ac (about 280 Mbps), but at the cost of lowering download speeds and still nowhere near enough not to just drop AX in favor of AC like @dsouza.

It also, TBH, just doesn't make sense - isn't 802.11ax supposed to increase throughput, theoretically?


Thank you @jkdf2 for confirming this issue. Since these devices have the same SoC (mt7622) and the similar radio chips (mt7911an/mt7915an) I believe a logical conclusion is that the m76 drivers are not mature enough to handle 802.11ax in the conditions we are experiencing.

I tested with the original firmware and on the same conditions 802.11ax performs at least as well as 802.11ac when not better, which is not the case with mt76 drivers in OpenWrt.

A next step should be opening a bug report here to grab mt76 developers attention (@nbd). At this moment I will not be able to create the issue, so please feel free to open the issue pointing to this topic. Otherwise I should do this by next weekend.

Thanks! :+1:


@dsouza were you able to make an issue on GH?

1 Like

@dsouza I wonder if this is related: https://github.com/openwrt/mt76/issues/676

I see from your config that you are using a channel 149, so most likely not, idk.

Sorry, I’ve not had a chance to open the issue yet.

any progress?

can we get folk testing head?

Sorry, I did not have time to make additional tests. I was testing with 22.03 builds (I’ve upgraded to 22.03-rc4 but I have not tested ax after the upgrade).

I noticed that 22.03 branch (post rc4) has been updated with a newer mt76 driver (there is a long list of changes in this newer Wi-Fi driver, see details here).

So I believe it is worth testing with 22.03-snapshot to check if any of various m76 changes somehow solved this issue.

I just updated one of my access points to a 22.03 snapshot build (OpenWrt 22.03-SNAPSHOT r19464-a4390ea283) which includes the updated mt76 driver (5.10.120+2022-06-24-b6e865e2-4).

I did a very quick test - I reenabled 802.11ax, rebooted to be sure and retested WiFi performance with an iPhone 13 Pro connected via ax.

Unfortunately things did not improve. The results are the same as my original post. It takes one brick wall to enormously degrade 802.11ax performance. Upload speed goes from 800Mbps on the same room close to the access point down to a sluggish 10Mbps. And this only happens with 802.11ax (80Mhz). I am going back to 802.11ac (80Mhz), which in the same conditions (across the wall) is able to deliver around 500Mbps up/downstream.

1 Like

@dsouza @dtaht @MaxwellZX Exact same results, I just tried updated to the same version and tried a speedtest today as well. Much better speeds with 802.11ac than 802.11ax


What about the very new airtime fairness commits on 22.03?

I just did a new build to pick-up the latest 22.03 commits (OpenWrt 22.03-SNAPSHOT r19482-2b8021d614).

I did a very quick test, and unfortunately the 802.11ax issue remains.

1 Like

Sometimes internet speeds slow down to less than 50mbps on my Galaxy S10e when the RT3200 is working at 802.11ax mode, switching back to 802.11ac mode fixes this for me.

My Belkin RT3200 is running OpenWrt SNAPSHOT r20255-0582acf429.

PD: going next to where the router is located doesn't help when the issue occurs.

PD2: the issue seems to happen only when I'm using my laptop with Windows (QCA61X4A 802.11ac card).

Yes I can confirm that aswell in quite old snapshot r18809-5a0975f7ef
Router (MR1800X/MR70X) mt7915d in DBDC mode .
single AX200 client in SNR -65 range iperf -P 3
AX upload 330Mbit
AX download 240Mbit
AC upload 350Mbit
AC download 285Mbit
Upload fluctuate most but download speed is quite repetitive
I'm keeping VHT80 @5Ghz for longer tests .

1 Like

Copying my experience from the RT3200/E8450 thread:

AP: RT3200 on 22.03 RC6
Client (WDS): E8450 on 22.03 RC6
Client: 2021 MacBook Pro M1, macOS 12.5
Client: 2022 MacBook Air M2, macOS 12.5

When setting the AP to 802.11ax mode on 5GHz, uplink speeds from the Macs are HORRIBLE. I'm talking a few hundred kbit/s to ~70 mbit/s. The link rate between them and the router is supposedly ~1gbit/s. Downlink speeds from router to Macs is fine. Checked DFS channel 100 and 161, only at 80MHz channel width. No interference where I am. Same behavior on both.

I tested the same config between the E8450 client and RT3200 AP in 802.11ax mode on 5GHz with 0 issues.

Now, when I set the AP to 802.11ac the speeds on the Macs are normal: ~400-500mbit/s both ways. All the tests were run with iperf3 on both the router and the client devices. ONLY in 802.11ax mode does the uplink from Mac to AP suffer tremendously. I'll be leaving mine in 802.11ac mode for now. It's quite hard to tell if it's an issue with macOS or OpenWrt, but looking for any more insight from others.

1 Like

Also copying my results from Belkin RT3200 thread:

I've noticed similar performance issues with AX. I tested several clients using iperf3 to a local server

With RT3200 set to AX, 80Mhz width, Channel 52:
MacBook Pro, Broadcom BCM43xx, AC - 500-600Mbps
Desktop, Intel AX200 - AX - 200-300Mbps
Laptop, Intel AX210 - AX - 200-300Mbps
iPhone 13 Pro Max - AX - 200-300Mbps

With RT3200 set to AC, 80Mhz width, Channel 52:
MacBook Pro, Broadcom BCM43xx, AC - 500-600Mbps
Desktop, Intel AX200 - AC - 480Mbps
Laptop, Intel AX210 - AC - 480Mbps
iPhone 13 Pro Max - AC - 551Mbps


Try a non dfs channel - below channel 48. I'm set to 48 80hz wide, and I'm seing 800Mbps on both mac hardware and ax200.

1 Like

At least for the AX6S the anomaly with 802.11ax it happens on any channel (DFS or non-DFS). Changing channel did not help.

This is on Xiaomi ax3200 global aka ax6s

Where are you testing @dekomote ? AX speeds seem fine when really close to the AP, but AX only starts dropping off compared to AC when you increase the distance or have things in between the client and AP.

1 Like