[SOLVED] 22.03 with mesh doesn't work on Archer C7v2?

I have installed the new release version with custom image:

ath10k-firmware-qca988x base-files busybox ca-bundle dnsmasq dropbear firewall4 fstools kmod-ath10k kmod-ath9k kmod-gpio-button-hotplug kmod-nft-offload kmod-usb-ledtrig-usbport kmod-usb2 libc libgcc libustream-wolfssl logd mtd netifd nftables odhcp6c odhcpd-ipv6only opkg procd procd-seccomp procd-ujail swconfig uboot-envtools uci uclient-fetch urandom-seed urngd luci-app-wireguard wireguard-tools kmod-wireguard wpad-mesh-wolfssl iperf3 snmpd openssh-sftp-server luci

It looks like 802.11s mesh doesn't work because the WPA3 encryption is not active.
I use it with 2.4 GHz only.
The mesh point shows "Encryption: None".
It worked with version 21.02

What can I do?

Uwe

might need hostapd ....

Thanks, but hostapd-common is installed (part of wpad-mesh-wolfssl?)

Uwe

It works! - But only without Encryption?

Uwe

You might also like to add mesh11sd to your custom image. It allows you to do all sorts of dynamic tuning to the mesh and fixes startup problems/errors/crashes that occur with many mesh parameters that can/should only be set after the mesh interface is up.

It looks like the encryption (WPA3 SAE) is still working but "luci" display is wrong!
The second mesh point with OpenWrt 21.02 shows "Encryption: WPA3 SAE (CCMP)"

Uwe

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.