[Solved] 19.07 regression - LuCI not showing the 2nd IPv6 addresses?

What further information is needed to confirm or complete this report?
In 18.06, each network device received a public IPv6 address starting 2401: (I understand that is part of the allocation to my ISP) and also an address starting fda6: (from the 'IPv6 ULA-Prefix'). With 19.07, I no longer get the addresses starting fda6:
Here's a hacked up screenshot from LUCI

  • What's the regression?
  • What's the problem you're experiencing?
  • Can you post the configuration /etc/config/dhcp and /etc/config/network - showing how you issued IPs and setup leases from your WAN6 and ULA?

The regression is that the IPv6 addresses starting with fda6: are no longer issued (I've edited this into the original post).

Below are the important parts of the two config files, with information that I think I should keep private xxed out.


config dnsmasq
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'
        option domainneeded '1'
        option strictorder '1'
        option authoritative '1'
        option filterwin2k '1'
        option domain 'xxxx.home'
        list rebind_domain 'xxxx.home'
        option nonwildcard '1'

config dhcp 'lan'
        option interface 'lan'
        option force '1'
        option start '20'
        option limit '233'
        option leasetime '14d'
        option ra 'hybrid'
        option ra_default '1'
        option dhcpv6 'hybrid'
        option ndp 'hybrid'
        option ra_management '1'
        list dhcp_option '6,,'
        list domain 'xxxx.home'
        list dns 'fda6:xxxx:xxxx::xxxx:253'
        list dns 'fda6:xxxx:xxxx::1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config host
        option name 'xxxxxx'
        option dns '1'
        option mac '00:15:xx:xx:xx:xx'
        option ip ''
        option leasetime '14d'
        option duid '00020000ab113ccaxxxxxxxxxxxxxxx'
        option hostid 'xxxx0253'


config globals 'globals'
        option ula_prefix 'fda6:xxxx:xxxx::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr ''
        option netmask ''
        option ifname 'eth1'
        option igmp_snooping '1'
        option ip6assign '64'
        option force_link '0'

config interface 'wan6'
        option proto 'dhcpv6'
        option ifname 'eth0'
        option reqprefix 'auto'
        option reqaddress 'try'

What does ip -6 addr show (or the equivalent command on the client machines)?

That will help determine if it is a rendering change in LuCI, or if the addresses truly aren't being assigned.

the fda6: address is allocated - I checked on both a Linux and on a Windows client.

It looks as if my regression is here...


This works for me, thank-you @jow

@CharlesJC If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.