[solved]18.06.1 / targets / x86 / generic / combined-ext4.img.gz installed on EEEPC can't find NIC


Tried to install Index of (root) / releases / 18.06.1 / targets / x86 / generic / combined-ext4.img.gz
on EEEPC 701SD which has Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller
and Realtek RTL8187SE 802.11b/g PCIE.

However after reboot, ifconfig only shown "l0". No eth0 nor wan0 shown.

I think it maybe the driver issue.

I tried to manually install them. It's hard to find those NIC drivers for linux. So I plan to use ndiswrapper to wrap those windows drivers. But there is no "make" command in the system. No chance to compile and install ndiswrapper.

How to solve it?

Thanks in advance!


kmod-atl1e, which is available prebuilt in the OpenWrt x86 repository, should drive the Ethernet. You can use Image Builder to install it into a new image, or mount the card on another machine (ext4 format), leave the .ipk file somewhere in the file system, then boot up Openwrt and opkg install from the file.

Replace that Realtek wifi rather than try to use it. It will never operate in AP mode, which is what you would want when building a router. If the BIOS isn't locked to certain cards, try to find an ath9k model. Or use a USB adapter.

1 Like


the only kmod-atl1e I found is from:
Attitude Adjustment releases and ar71xx platforms are here: http://downloads.openwrt.org/attitude_adjustment/12.09/ar71xx/generic/packages/

It is kmod-atl1e_3.3.8-1_ar71xx.ipk.

Not sure if it is the right one but when I tried to use "opkg install kmod-atl1e_3.3.8-1_ar71xx.ipk" after reboot the EEEPC with the usb, it said:

unknown package 'kmod-atl1e'
collected errors:
* pkg_hash_fetch_best_installation_candidate: Packages for kmod-atl1e found, but incompatible with the architectures configured
* opkg_install_cmd: cannot install package kmod-atl1e.

Any idea?


What happens if you do

opkg update
opkg install kmod-atl1e


kmod packages will not install or run unless they exactly match the version of OpenWrt. In this case it would be
I'm assuming that without Ethernet or wifi drivers, the OpenWrt Eeepc is not yet able to connect to the Internet, so you couldn't do an online install. You will have to download the file using another machine then transfer it.

Thanks tmomas.

Thanks mk24. Following your instruction solved my problem!

Marked this topic as solved

How to mark solved?

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.