SOLVED: [18.06.1] No tun0 device after upgrading netifd tp netifd_2018-11-19-4b83102d-2_arm_cortex-a9_vfpv3.ipk

#1

Hi all,
after the upgrade of the netifd-package to the version netifdI_2018-11-19-4b83102d-2_arm_cortex-a9_vfpv3.ipk, my openvpn interface tun0 is not available any more.

In LuCi, i can see the following error message: Error: Network device is not present.

The device /etc/net/tun is present.

While using the previous netifd-package the were no issues ... I have a WRT1900ACS.

Any hints?

Regards,
Andreas

0 Likes

Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds
#2

It is not suggested that you upgrade packages included in the default firmware.

  • Did you build the firmware with the upgraded package included?
0 Likes

#3

Uh, are you really sure?

I installed version 18.0.6.1 on my mvebu-device WRT1900ACSv2 and i have a cronjob running, which shows me available updates for this openwrt-release:

opkg update && opkg list-upgradable

There you can see the available upates of this repo. .. the same files as in ...

http://downloads.openwrt.org/releases/packages-18.06/arm_cortex-a9_vfpv3/

I had never any problems with this kind of updates ... only with the netifd-package mentioned above.

Regards,
Andreas

0 Likes

#4

Solved with this workaraound:

root@wrt1900acs:~# cat /etc/rc.local

/usr/sbin/openvpn --mktun --dev tun0
exit 0

0 Likes

closed #5

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

0 Likes