SoftEther Connected but Public IP Address didn't change

Hi I'm new to OpenWRT and trying to connect my traffic to SoftEther VPN

Tried the tutorial from https://openwrt.org/docs/guide-user/services/vpn/softethervpn/client and now I'm on step 3.3 and when I did the 3.4 step the Public IP Address still using the one from eth1

My Network Configuration:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdc3:d7ee:58f9::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	option ipv6 '0'
	list ports 'eth0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.2.1'
	option gateway '192.168.1.1'

config interface 'wan1'
	option proto 'dhcp'
	option device 'eth1'
	option metric '10'
	option peerdns '0'

config interface 'wan2'
	option proto 'dhcp'
	option device 'wwan0'
	option metric '20'
	option peerdns '0'

config interface 'tethering'
	option proto 'dhcp'
	option device 'usb0'

config device
	option name 'eth0'
	option ipv6 '0'

config interface 'libernet'
	option proto 'none'
	option device 'tun1'

config interface 'xderm'
	option proto 'none'
	option device 'tun0'

config interface 'SoftEtherVPN'
	option proto 'dhcp'
	option device 'vpn_softether'
	option delegate '0'
	option defaultroute '0'

config device
	option name 'vpn_softether'
	option ipv6 '0'

Internet is coming from eth1

Enable the default gateway on the SoftEtherVPN interface.