Socat doesn't compile

No additional info.

Build failed on socat.

I even set IGNORE_ERRORS=1 so it should bypass the error but it doesn't.

anyway, should be fixed.

Well, you did not give any additional info by yourself...

Socat compiles ok by both Openwrt and LEDE buildbots. E.g. ar71xx platform:
https://downloads.lede-project.org/snapshots/packages/mips_24kc/packages/socat_1.7.3.0-2_mips_24kc.ipk
https://downloads.openwrt.org/snapshots/trunk/ar71xx/generic/packages/packages/socat_1.7.3.0-2_ar71xx.ipk

You should do make package/socat/{clean,compile} V=s to see details clearly.

right, i'll compile with the V=s flag.

anyway, happens on the compilation for wrt3200acm and any other wrt1900acs or wrt1200 as well.

Error reads:

arm-openwrt-linux-muslgnueabi-gcc -Os -pipe -mcpu=cortex-a9 -mfpu=vfpv3-d16 -fno-caller-saves -fno-plt -fhonour-copts -Wno-error=unused-but-set-variable -Wno-error=unused-result -mfloat-abi=hard -iremap /home/user/lede/source/build_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/socat-1.7.3.0:socat-1.7.3.0 -Wformat -Werror=format-security -fstack-protector -D_FORTIFY_SOURCE=1 -Wl,-z,now -Wl,-z,relro -D_GNU_SOURCE -Wall -Wno-parentheses -DHAVE_CONFIG_H -I. -I/home/user/lede/source/staging_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/usr/include -I/home/user/lede/source/staging_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/include -I/home/user/lede/source/staging_dir/toolchain-arm_cortex-a9+vfpv3_gcc-5.4.0_musl-1.1.15_eabi/usr/include -I/home/user/lede/source/staging_dir/toolchain-arm_cortex-a9+vfpv3_gcc-5.4.0_musl-1.1.15_eabi/include/fortify -I/home/user/lede/source/staging_dir/toolchain-arm_cortex-a9+vfpv3_gcc-5.4.0_musl-1.1.15_eabi/include -L/home/user/lede/source/staging_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/usr/lib -L/home/user/lede/source/staging_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/lib -L/home/user/lede/source/staging_dir/toolchain-arm_cortex-a9+vfpv3_gcc-5.4.0_musl-1.1.15_eabi/usr/lib -L/home/user/lede/source/staging_dir/toolchain-arm_cortex-a9+vfpv3_gcc-5.4.0_musl-1.1.15_eabi/lib -znow -zrelro -o socat socat.o libxio.a -lrt -lutil -lssl -lcrypto
/home/user/lede/source/staging_dir/toolchain-arm_cortex-a9+vfpv3_gcc-5.4.0_musl-1.1.15_eabi/lib/gcc/arm-openwrt-linux-muslgnueabi/5.4.0/../../../../arm-openwrt-linux-muslgnueabi/bin/ld: copy reloc against protected __stack_chk_guard' is dangerous libxio.a(sslcls.o): In functionsycSSLv3_client_method':
sslcls.c:(.text+0x90): undefined reference to SSLv3_client_method' libxio.a(sslcls.o): In functionsycSSLv3_server_method':
sslcls.c:(.text+0xd0): undefined reference to `SSLv3_server_method'
collect2: error: ld returned 1 exit status
Makefile:115: recipe for target 'socat' failed
make[4]: *** [socat] Error 1
make[4]: Leaving directory '/home/user/lede/source/build_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/socat-1.7.3.0'
Makefile:81: recipe for target '/home/user/lede/source/build_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/socat-1.7.3.0/.built' failed
make[3]: *** [/home/user/lede/source/build_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/socat-1.7.3.0/.built] Error 2
make[3]: Leaving directory '/home/user/lede/source/feeds/packages/net/socat'
package/Makefile:127: recipe for target 'package/feeds/packages/socat/compile' failed
make[2]: *** [package/feeds/packages/socat/compile] Error 2
make[2]: Leaving directory '/home/user/lede/source'
package/Makefile:124: recipe for target '/home/user/lede/source/staging_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/stamp/.package_compile' failed
make[1]: *** [/home/user/lede/source/staging_dir/target-arm_cortex-a9+vfpv3_musl-1.1.15_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/user/lede/source'
/home/user/lede/source/include/toplevel.mk:194: recipe for target 'world' failed
make: *** [world] Error 2

So, it is mvebu platform.

Again, both buildbots build it ok for mvebu (cortex-a9), so it is something related to your config, build host or something.

EDIT: you just posted the error log that reveal the reason:

libxio.a(sslcls.o): In functionsycSSLv3_client_method':
sslcls.c:(.text+0x90): undefined reference to SSLv3_client_method'

In LEDE the openssl support for SSLv3 is disabled by default. You need to turn it on in openssl menuconfig, if I remember it right. (Although I wonder a bit why buildbot does not run into that.) Or alternatively, you might look for configure script options in socat, if you can turn off SSLv3 need in it.

Moved to "For Developers" category...

Hi Richb, thank you very much! now it compiles :smile:

If moving an item from one category to another causes the compilation bug to go away, I'm happy to oblige :slight_smile: But I bet it was hnyman's suggestion that helped...

oops.. yes..
Thank you hnyman!!!

But thank you richb as well, for moving this to developers section. Because it would be nice if the make menuconfig would automatically check the dependency and add it to the makefile.

Thank you the LEDE community together! :slight_smile:

It's probably better to kill SSLv3 support like OpenBSD does in the long run?
http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/net/socat/patches/#dirlist