SNR-CPE-ME2-Lite installation troubles

  1. I have got OpenWRT from here:
  2. Installed openwrt-ramips-mt7621-snr_snr-cpe-me2-lite-initramfs-kernel.bin in normal way with u-boot help and reset button... It works normally, except there is no any possibility to save settings...
  3. But... I could not help it to load openwrt-ramips-mt7621-snr_snr-cpe-me2-lite-squashfs-sysupgrade.bin (I have tried with web interface, ssh, console). I got boot loop after install.

Did I do something wrong?

P.S. Also I have console TTL-connection and I can see everything inside of that stuff.

It does sound like you don't have enough flash space to create an overlay. Your device would be running from RAM which explains being unable to store settings.

Do check df -h to see if you have an overlay.

Edit: nevermind, normal behaviour with an initramfs image.

1 Like

now I see this:

root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                    58.9M     14.6M     44.3M  25% /
tmpfs                    58.9M     72.0K     58.8M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

and this:

root@OpenWrt:/# cat /proc/mtd 
dev:    size   erasesize  name
mtd0: 00030000 00010000 "u-boot"
mtd1: 00010000 00010000 "config"
mtd2: 00010000 00010000 "factory"
mtd3: 00fb0000 00010000 "firmware"

There is 16 megabyte SPI-NOR flash:

MediaTek SPI flash driver, SPI clock: 31MHz
find flash: EN25QH128A

An "initramfs" image is expected to run entirely on RAM, and not save anything to flash.
Perhaps your device does not have enough memory to run OpenWrt?

according to;a=commit;h=a664d39c5bb4a77ffc90a6fdfdca3606292b650d, you shouldn't use the initramfs, and def not the sysupgrade image.

Is 128MB not enough? Not precisely, but actually...

              total        used        free      shared  buff/cache   available
Mem:         120548       21732       82148       14976       16668       58420
Swap:             0           0           0

In that way I have got this:

[    2.817438] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x604fffff pref]
[    2.838856] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    2.857063] Freeing unused kernel memory: 1256K
[    2.866124] This architecture does not have kernel memory protection.
[    2.878974] Run /sbin/init as init process
[    2.887653] mt7530 mdio-bus:1f: Link is Up - 1Gbps/Full - flow control rx/tx
[    2.903798] SQUASHFS error: xz decompression failed, data probably corrupt
[    2.917591] SQUASHFS error: Failed to read block 0x3d4a66: -5
[    2.929040] SQUASHFS error: Unable to read metadata cache entry [3d4a64]
[    2.942384] SQUASHFS error: Unable to read directory block [3d4a64:186a]
[    2.955848] Starting init: /sbin/init exists but couldn't execute it (error -5)
[    2.970401] Run /etc/init as init process
[    2.978598] SQUASHFS error: Unable to read metadata cache entry [3d4a64]
[    2.991968] SQUASHFS error: Unable to read directory block [3d4a64:186a]
[    3.005442] Starting init: /etc/init exists but couldn't execute it (error -5)
[    3.019825] Run /bin/init as init process
[    3.027951] SQUASHFS error: Unable to read metadata cache entry [3d4a64]
[    3.041323] SQUASHFS error: Unable to read directory block [3d4a64:186a]
[    3.054734] Starting init: /bin/init exists but couldn't execute it (error -5)
[    3.069114] Run /bin/sh as init process
[    3.076871] SQUASHFS error: Unable to read metadata cache entry [3d4a64]
[    3.090232] SQUASHFS error: Unable to read directory block [3d4a64:186a]
[    3.103649] Starting init: /bin/sh exists but couldn't execute it (error -5)
[    3.117704] Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance.
[    3.145920] Rebooting in 1 seconds..

... and eternal bootloop...

install stock fw again, then redo the whole thing.


Did it, no way out :slight_smile:

Provide more details, please.

Excellent. If you successfully reverted to stock, just proceed to install from Step 1 (with the correct files, of course).

[   67.805335] SQUASHFS error: Unable to read fragment cache entry [2c3e6]
[   67.818584] SQUASHFS error: Unable to read page, block 2c3e6, size 14e20

and so on...

Provide more information. You provided no clue when/where that log entry appears.

It appears after installing OpenWRT factory version for SNR-CPE-ME2-Lite...
The whole log is here:

  • The log shows you got a Kernel panic...that wasn't remarkable?
  • So this occurs after doing what?
  • Did you flash using TFTP or web GUI?

(Please provide more details if you want asssitance.)

  1. Yes, I understand that.
  2. Just doing migration from stock firmware to OpenWRT (
  3. Yes, I did through TFTP upload with this:
    tftp -4 -m binary -c put openwrt-ramips-mt7621-snr_snr-cpe-me2-lite-squashfs-sysupgrade.bin

Still don't think you're supposed to use the sysupgrade.

question is why the factory image isn't built ....

1 Like

Did you sysupgrade from the LuCI web GUI after this???

(It's not clear if that's what you meant in Step 3.)

Yes, I tried that, it does not work too.

It's common not to have a factory image, look at a lot of the Realtek switches. Boot a ramdisk, flash a sysupgrade image. Same for my MikroTik RB5009UG, e.g..

git commit says factory, at least for stock UI install, for TFTP there's no image specified, but I'd expect factory there too.