Snapshot samba error

Trying to install samba on the latest snapshot I get the following error

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-samba4:
 *      samba4-server
 * opkg_install_cmd: Cannot install package luci-app-samba4.

Its because snapshots are broken for a lot of packages atm, including samba4.

See the faillogs: https://downloads.openwrt.org/snapshots/faillogs/arm_cortex-a8_vfpv3/packages/

PS: Seems libintl is broken atm, which results in a lot of failed packages, which in turn lets samba4 fail, because gnutls fails.

It's back online again. I guess that to be expected when using snapshots.