Snapshot (r25773-766ec55966) connected but no internet for dap x1860 (mt7621 + mt7915)

I Tried recent releases and snapshots all with similar config. Here are the results:

  • OpenWrt version 23.05.02 r23630-842932a63d (2024-11-15) works
  • OpenWrt version 23.05.03 r23809-234f1a2efa (2024-03-25) works, but latency is often 5 - 30 ms higher as compared to 23.05.02.
  • Snapshot r25706-362e7103c6 (2024-03-29) Disaster: connected, but no internet
  • Snapshot r25773-766ec55966 (2024-04-04) Disaster: connected, but no internet

Setup:

  • Router: --> wifi 6 --> DAP x1860 (with following relayd config --> wifi --> clients.
  • Connecting my PC with the DAP x1860 via cable and basically turning it into an AP yields similar results: connected, but not internet.

Additional info:

I upgraded to snapshots keeping existing configuration/settings.
Downgrading to older openwrt release makes the internet work again.

Anybody having similar issues? To me, it clearly looks like a regression. Anything I missed?

You clearly took the time to investigate and compare, but you need to share logs. Without, you're just sharing the symptoms, not the underlying issue.

Post a dmesg output from a snapshot build. Look specifically for mtk_soc_eth lines.

Thank you Borromini :slight_smile:
I was in a hurry in the morning. Had more time in the afternoon. I used putty to ssh into the router repeater and used some debugging commands, including dmesg. See here:

23.05.2 - dmesg

BusyBox v1.36.1 (2024-01-29 09:41:19 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 23.05.2, r23630-842932a63d
 -----------------------------------------------------
root@209-Repeater:~# dmesg
[    0.000000] Linux version 5.15.137 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 12.3.0 r23630-842932a63d) 12.3.0, GNU ld (GNU Binutils) 2.40.0) #0 SMP Tue Nov 14 13:38:11 2023
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is D-Link DAP-X1860 A1
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] percpu: Embedded 11 pages/cpu s14736 r8192 d22128 u45056
[    0.000000] pcpu-alloc: s14736 r8192 d22128 u45056 alloc=11*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 64960
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes, linear)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Writing ErrCtl register=00000020
[    0.000000] Readback ErrCtl register=00000020
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 249108K/262144K available (7300K kernel code, 624K rwdata, 880K rodata, 1232K init, 226K bss, 13036K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000]  Tracing variant of Tasks RCU enabled.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000004] sched_clock: 64 bits at 880MHz, resolution 1ns, wraps every 4398046511103ns
[    0.008070] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.066213] pid_max: default: 32768 minimum: 301
[    0.071636] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.078852] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.090690] rcu: Hierarchical SRCU implementation.
[    0.096220] smp: Bringing up secondary CPUs ...
[    0.101702] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.101734] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.101749] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.101797] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.160992] Synchronize counters for CPU 1: done.
[    0.193225] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.193252] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.193264] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.193296] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.252416] Synchronize counters for CPU 2: done.
[    0.283221] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.283248] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.283260] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.283297] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.337634] Synchronize counters for CPU 3: done.
[    0.367521] smp: Brought up 1 node, 4 CPUs
[    0.376954] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.386762] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.393852] pinctrl core: initialized pinctrl subsystem
[    0.400842] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.407549] thermal_sys: Registered thermal governor 'step_wise'
[    0.413974] FPU Affinity set after 11720 emulations
[    0.434189] clocksource: Switched to clocksource GIC
[    0.440771] NET: Registered PF_INET protocol family
[    0.445851] IP idents hash table entries: 4096 (order: 3, 32768 bytes, linear)
[    0.454122] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 6144 bytes, linear)
[    0.462471] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.470210] TCP established hash table entries: 2048 (order: 1, 8192 bytes, linear)
[    0.477873] TCP bind hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.484998] TCP: Hash tables configured (established 2048 bind 2048)
[    0.491470] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.498016] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.505389] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.511012] PCI: CLS 0 bytes, default 32
[    0.518381] workingset: timestamp_bits=14 max_order=16 bucket_order=2
[    0.530308] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.536181] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.547637] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.559526] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.565595] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.571606] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.577760] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[    0.584448] mt7621-pci 1e140000.pcie:   No bus range found for /pcie@1e140000, using [bus 00-ff]
[    0.593181] mt7621-pci 1e140000.pcie:      MEM 0x0060000000..0x006fffffff -> 0x0060000000
[    0.601318] mt7621-pci 1e140000.pcie:       IO 0x001e160000..0x001e16ffff -> 0x0000000000
[    0.964206] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    0.971101] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    0.975992] mt7621-pci 1e140000.pcie: PCIE1 enabled
[    0.980799] PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    0.987981] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    0.994297] pci_bus 0000:00: root bus resource [bus 00-ff]
[    0.999721] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.006583] pci_bus 0000:00: root bus resource [io  0x0000-0xffff]
[    1.012732] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    1.018691] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.024924] pci 0000:00:00.0: reg 0x14: [mem 0x60600000-0x6060ffff]
[    1.031162] pci 0000:00:00.0: supports D1
[    1.035101] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.041668] pci 0000:00:01.0: [0e8d:0801] type 01 class 0x060400
[    1.047708] pci 0000:00:01.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.053914] pci 0000:00:01.0: reg 0x14: [mem 0x60610000-0x6061ffff]
[    1.060239] pci 0000:00:01.0: supports D1
[    1.064206] pci 0000:00:01.0: PME# supported from D0 D1 D3hot
[    1.072311] pci 0000:01:00.0: [14c3:7916] type 00 class 0x000280
[    1.078348] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    1.085556] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    1.092693] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    1.100018] pci 0000:01:00.0: supports D1 D2
[    1.104231] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    1.110811] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.127083] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    1.132249] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.138347] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.145084] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x602fffff pref]
[    1.152220] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.159101] pci 0000:02:00.0: [14c3:7915] type 00 class 0x000280
[    1.165118] pci 0000:02:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    1.172315] pci 0000:02:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    1.179523] pci 0000:02:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    1.186814] pci 0000:02:00.0: supports D1 D2
[    1.190995] pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    1.197641] pci 0000:02:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:01.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.214002] pci 0000:00:01.0: PCI bridge to [bus 02-ff]
[    1.219227] pci 0000:00:01.0:   bridge window [io  0x0000-0x0fff]
[    1.225273] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff]
[    1.231969] pci 0000:00:01.0:   bridge window [mem 0x60400000-0x605fffff pref]
[    1.239184] pci_bus 0000:02: busn_res: [bus 02-ff] end is updated to 02
[    1.245783] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    1.252300] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.259254] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    1.265817] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.272695] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    1.279469] pci 0000:00:00.0: BAR 9: assigned [mem 0x60100000-0x602fffff pref]
[    1.286633] pci 0000:00:01.0: BAR 8: assigned [mem 0x60300000-0x603fffff]
[    1.293342] pci 0000:00:01.0: BAR 9: assigned [mem 0x60400000-0x605fffff pref]
[    1.300550] pci 0000:00:00.0: BAR 1: assigned [mem 0x60600000-0x6060ffff]
[    1.307288] pci 0000:00:01.0: BAR 1: assigned [mem 0x60610000-0x6061ffff]
[    1.313993] pci 0000:00:00.0: BAR 7: assigned [io  0x0000-0x0fff]
[    1.320076] pci 0000:00:01.0: BAR 7: assigned [io  0x1000-0x1fff]
[    1.326134] pci 0000:01:00.0: BAR 0: assigned [mem 0x60100000-0x601fffff 64bit pref]
[    1.333792] pci 0000:01:00.0: BAR 2: assigned [mem 0x60200000-0x60203fff 64bit pref]
[    1.341518] pci 0000:01:00.0: BAR 4: assigned [mem 0x60204000-0x60204fff 64bit pref]
[    1.349202] pci 0000:00:00.0: PCI bridge to [bus 01]
[    1.354085] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.360169] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.366900] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x602fffff pref]
[    1.374053] pci 0000:02:00.0: BAR 0: assigned [mem 0x60400000-0x604fffff 64bit pref]
[    1.381783] pci 0000:02:00.0: BAR 2: assigned [mem 0x60500000-0x60503fff 64bit pref]
[    1.389478] pci 0000:02:00.0: BAR 4: assigned [mem 0x60504000-0x60504fff 64bit pref]
[    1.397167] pci 0000:00:01.0: PCI bridge to [bus 02]
[    1.402043] pci 0000:00:01.0:   bridge window [io  0x1000-0x1fff]
[    1.408120] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff]
[    1.414867] pci 0000:00:01.0:   bridge window [mem 0x60400000-0x605fffff pref]
[    1.425074] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    1.437062] printk: console [ttyS0] disabled
[    1.441412] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 19, base_baud = 3125000) is a 16550A
[    1.450502] printk: console [ttyS0] enabled
[    1.458806] printk: bootconsole [early0] disabled
[    1.472590] nand: device found, Manufacturer ID: 0xc2, Chip ID: 0xf1
[    1.479016] nand: Macronix MX30LF1G18AC
[    1.482848] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    1.490421] mt7621-nand 1e003000.nand: ECC strength adjusted to 4 bits
[    1.498961] Signature found at block 1023 [0x07fe0000]
[    1.504092] NMBM management region starts at block 960 [0x07800000]
[    1.514306] First info table with writecount 1 found in block 960
[    1.531831] Second info table with writecount 1 found in block 963
[    1.538117] NMBM has been successfully attached
[    1.542767] 8 fixed-partitions partitions found on MTD device mt7621-nand
[    1.550135] Creating 8 MTD partitions on "mt7621-nand":
[    1.555428] 0x000000000000-0x000000080000 : "bootloader"
[    1.567231] 0x000000080000-0x000000100000 : "config"
[    1.578410] 0x000000100000-0x000000180000 : "factory"
[    1.589804] 0x000000180000-0x000000980000 : "kernel"
[    1.676443] 0x000000980000-0x000003580000 : "fwconcat0"
[    2.126239] 0x000003580000-0x000003980000 : "manufacture"
[    2.173393] 0x000003980000-0x000004000000 : "storage"
[    2.245305] 0x000004000000-0x000007800000 : "fwconcat1"
[    2.822238] Concatenating MTD devices:
[    2.826119] (0): "fwconcat0"
[    2.829026] (1): "fwconcat1"
[    2.831907] into device "virtual_flash"
[    2.835811] 1 fixed-partitions partitions found on MTD device virtual_flash
[    2.842763] Creating 1 MTD partitions on "virtual_flash":
[    2.848170] 0x000000000000-0x000006400000 : "ubi"
[    3.997840] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    4.011092] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 21
[    4.021646] i2c_dev: i2c /dev entries driver
[    4.029754] NET: Registered PF_INET6 protocol family
[    4.037518] Segment Routing with IPv6
[    4.041266] In-situ OAM (IOAM) with IPv6
[    4.045388] NET: Registered PF_PACKET protocol family
[    4.050543] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    4.064423] 8021q: 802.1Q VLAN Support v1.8
[    4.074932] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    4.099743] mt7530-mdio mdio-bus:1f: configuring for fixed/rgmii link mode
[    4.107557] mt7530-mdio mdio-bus:1f: Link is Up - 1Gbps/Full - flow control rx/tx
[    4.115083] mt7530-mdio mdio-bus:1f lan (uninitialized): PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=23)
[    4.129068] DSA: tree 0 setup
[    4.135575] UBI: auto-attach mtd8
[    4.138926] ubi0: attaching mtd8
[    6.157929] ubi0: scanning is finished
[    6.179288] ubi0: attached mtd8 (name "ubi", size 100 MiB)
[    6.184836] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    6.191699] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    6.198482] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    6.205443] ubi0: good PEBs: 800, bad PEBs: 0, corrupted PEBs: 0
[    6.211430] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
[    6.218646] ubi0: max/mean erase counter: 7/3, WL threshold: 4096, image sequence number: 1673110570
[    6.227768] ubi0: available PEBs: 0, total reserved PEBs: 800, PEBs reserved for bad PEB handling: 16
[    6.237008] ubi0: background thread "ubi_bgt0d" started, PID 289
[    6.239526] block ubiblock0_0: created from ubi0:0(rootfs)
[    6.248528] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
[    6.263601] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    6.275143] Freeing unused kernel image (initmem) memory: 1232K
[    6.281084] This architecture does not have kernel memory protection.
[    6.287554] Run /sbin/init as init process
[    6.291646]   with arguments:
[    6.291650]     /sbin/init
[    6.291656]   with environment:
[    6.291661]     HOME=/
[    6.291666]     TERM=linux
[    6.775981] init: Console is alive
[    6.779887] init: - watchdog -
[    7.473646] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    7.537376] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    7.552214] init: - preinit -
[    8.382109] random: jshn: uninitialized urandom read (4 bytes read)
[    8.511748] random: jshn: uninitialized urandom read (4 bytes read)
[    8.571723] random: jshn: uninitialized urandom read (4 bytes read)
[    8.988470] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[    9.001371] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[    9.004665] mt7530-mdio mdio-bus:1f lan: configuring for phy/gmii link mode
[    9.017377] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   11.215060] UBIFS (ubi0:1): Mounting in unauthenticated mode
[   11.221092] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 415
[   11.421075] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[   11.428950] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[   11.438869] UBIFS (ubi0:1): FS size: 93073408 bytes (88 MiB, 733 LEBs), max 744 LEBs, journal size 4698112 bytes (4 MiB, 37 LEBs)
[   11.450514] UBIFS (ubi0:1): reserved for root: 4396086 bytes (4293 KiB)
[   11.457141] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID 001CB5AC-DCF0-4B08-A533-F5D47A690C39, small LPT model
[   11.470991] mount_root: overlay filesystem has not been fully initialized yet
[   11.479255] mount_root: switching to ubifs overlay
[   11.829560] urandom-seed: Seed file not found (/etc/urandom.seed)
[   11.930239] procd: - early -
[   11.933426] procd: - watchdog -
[   12.573630] procd: - watchdog -
[   12.577396] procd: - ubus -
[   12.643528] random: ubusd: uninitialized urandom read (4 bytes read)
[   12.652627] random: ubusd: uninitialized urandom read (4 bytes read)
[   12.659776] random: ubusd: uninitialized urandom read (4 bytes read)
[   12.673644] procd: - init -
[   13.292566] kmodloader: loading kernel modules from /etc/modules.d/*
[   13.537896] Loading modules backported from Linux version v6.1.24-0-g0102425ac76b
[   13.545434] Backport generated by backports.git v5.15.92-1-44-gd6ea70fafd36
[   13.733761] pci 0000:00:00.0: enabling device (0006 -> 0007)
[   13.739527] mt7915e_hif 0000:01:00.0: enabling device (0000 -> 0002)
[   13.746638] pci 0000:00:01.0: enabling device (0006 -> 0007)
[   13.752376] mt7915e 0000:02:00.0: enabling device (0000 -> 0002)
[   14.025648] mt7915e 0000:02:00.0: HW/SW Version: 0x8a108a10, Build Time: 20220929104113a
[   14.025648]
[   14.358622] mt7915e 0000:02:00.0: WM Firmware Version: ____000000, Build Time: 20220929104145
[   14.392804] mt7915e 0000:02:00.0: WA Firmware Version: DEV_000000, Build Time: 20220929104205
[   14.538561] urngd: v1.0.2 started.
[   14.641825] PPP generic driver version 2.4.2
[   14.649653] NET: Registered PF_PPPOX protocol family
[   14.667169] kmodloader: done loading kernel modules from /etc/modules.d/*
[   14.964473] random: jshn: uninitialized urandom read (4 bytes read)
[   15.084392] random: jshn: uninitialized urandom read (4 bytes read)
[   15.168568] random: jshn: uninitialized urandom read (4 bytes read)
[   15.768968] random: crng init done
[   15.772410] random: 36 urandom warning(s) missed due to ratelimiting
[   16.163285] mtdblock: MTD device 'factory' is NAND, please consider using UBI block devices instead.
[   17.359521] mtdblock: MTD device 'factory' is NAND, please consider using UBI block devices instead.
[   24.833638] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
[   24.859009] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   24.867378] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   24.876313] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   24.885972] mt7530-mdio mdio-bus:1f lan: configuring for phy/gmii link mode
[   24.895371] br-lan: port 1(lan) entered blocking state
[   24.900563] br-lan: port 1(lan) entered disabled state
[   24.908430] device lan entered promiscuous mode
[   24.912992] device eth0 entered promiscuous mode
[   27.603497] mt7530-mdio mdio-bus:1f lan: Link is Up - 1Gbps/Full - flow control rx/tx
[   27.611506] br-lan: port 1(lan) entered blocking state
[   27.616792] br-lan: port 1(lan) entered forwarding state
[   27.631626] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   28.497769] br-lan: port 2(phy0-ap0) entered blocking state
[   28.503384] br-lan: port 2(phy0-ap0) entered disabled state
[   28.509629] device phy0-ap0 entered promiscuous mode
[   28.515183] br-lan: port 2(phy0-ap0) entered blocking state
[   28.520814] br-lan: port 2(phy0-ap0) entered forwarding state
[   28.614394] br-lan: port 2(phy0-ap0) entered disabled state
[   28.690801] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[   28.697982] br-lan: port 2(phy0-ap0) entered blocking state
[   28.703614] br-lan: port 2(phy0-ap0) entered forwarding state
[   29.191467] br-lan: port 3(phy1-ap0) entered blocking state
[   29.197129] br-lan: port 3(phy1-ap0) entered disabled state
[   29.203098] device phy1-ap0 entered promiscuous mode
[   29.208430] br-lan: port 3(phy1-ap0) entered blocking state
[   29.214027] br-lan: port 3(phy1-ap0) entered forwarding state
[   29.388509] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-ap0: link becomes ready
[   30.674490] br-lan: port 3(phy1-ap0) entered disabled state
[   32.915158] phy1-sta0: authenticate with redacted
[   33.023313] phy1-sta0: send auth to redacted (try 1/3)
[   33.030259] phy1-sta0: authenticated
[   33.054283] phy1-sta0: associate with redacted (try 1/3)
[   33.062208] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=32)
[   33.072873] phy1-sta0: associated
[   33.165821] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[   33.256091] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-sta0: link becomes ready
[   33.331203] br-lan: port 3(phy1-ap0) entered blocking state
[   33.336911] br-lan: port 3(phy1-ap0) entered forwarding state
[  817.776184] mt7530-mdio mdio-bus:1f lan: Link is Down
[  817.781760] br-lan: port 1(lan) entered disabled state
[  880.978137] br-lan: port 3(phy1-ap0) entered disabled state
[  887.565724] phy1-sta0: authenticate with redacted
[  887.672938] phy1-sta0: send auth to redacted (try 1/3)
[  887.688185] phy1-sta0: authenticated
[  887.697229] phy1-sta0: associate with redacted (try 1/3)
[  887.705020] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=16)
[  887.715093] phy1-sta0: associated
[  887.808060] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[  887.898322] br-lan: port 3(phy1-ap0) entered blocking state
[  887.903934] br-lan: port 3(phy1-ap0) entered forwarding state
[ 4624.009889] br-lan: port 3(phy1-ap0) entered disabled state
[ 4630.577226] phy1-sta0: authenticate with redacted
[ 4630.684067] phy1-sta0: send auth to redacted (try 1/3)
[ 4630.699198] phy1-sta0: authenticated
[ 4630.708857] phy1-sta0: associate with redacted (try 1/3)
[ 4630.716685] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=18)
[ 4630.726829] phy1-sta0: associated
[ 4630.799949] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[ 4630.914741] br-lan: port 3(phy1-ap0) entered blocking state
[ 4630.920434] br-lan: port 3(phy1-ap0) entered forwarding state
[ 9632.851678] br-lan: port 3(phy1-ap0) entered disabled state
[ 9639.429562] phy1-sta0: authenticate with redacted
[ 9639.534378] phy1-sta0: send auth to redacted (try 1/3)
[ 9639.549364] phy1-sta0: authenticated
[ 9639.560891] phy1-sta0: associate with redacted (try 1/3)
[ 9639.568678] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=20)
[ 9639.578613] phy1-sta0: associated
[ 9639.691494] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[ 9639.733850] br-lan: port 3(phy1-ap0) entered blocking state
[ 9639.739484] br-lan: port 3(phy1-ap0) entered forwarding state
[55988.311658] phy1-sta0: deauthenticated from redacted (Reason: 3=DEAUTH_LEAVING)
[55989.389076] br-lan: port 3(phy1-ap0) entered disabled state
[55995.958506] phy1-sta0: authenticate with redacted
[55996.066472] phy1-sta0: send auth to redacted (try 1/3)
[55996.075888] phy1-sta0: send auth to redacted (try 2/3)
[55996.085678] phy1-sta0: send auth to redacted (try 3/3)
[55996.095500] phy1-sta0: authentication with redacted timed out
[56044.776955] phy1-sta0: authenticate with redacted
[56044.884137] phy1-sta0: send auth to redacted (try 1/3)
[56044.891245] phy1-sta0: authenticated
[56044.897224] phy1-sta0: associate with redacted (try 1/3)
[56044.905154] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=16)
[56044.915292] phy1-sta0: associated
[56044.997902] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[56045.093223] br-lan: port 3(phy1-ap0) entered blocking state
[56045.098867] br-lan: port 3(phy1-ap0) entered forwarding state
[64563.580535] br-lan: port 3(phy1-ap0) entered disabled state
[64574.028122] phy1-sta0: authenticate with redacted
[64574.134954] phy1-sta0: send auth to redacted (try 1/3)
[64574.150260] phy1-sta0: authenticated
[64574.160021] phy1-sta0: associate with redacted (try 1/3)
[64574.167842] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=20)
[64574.177847] phy1-sta0: associated
[64574.251050] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[64574.337131] br-lan: port 3(phy1-ap0) entered blocking state
[64574.342800] br-lan: port 3(phy1-ap0) entered forwarding state
[66440.414885] br-lan: port 3(phy1-ap0) entered disabled state
[66442.732324] phy1-sta0: authenticate with redacted
[66442.838946] phy1-sta0: send auth to redacted (try 1/3)
[66442.854852] phy1-sta0: authenticated
[66442.864306] phy1-sta0: associate with redacted (try 1/3)
[66442.872181] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=21)
[66442.882388] phy1-sta0: associated
[66442.886104] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[66443.051249] br-lan: port 3(phy1-ap0) entered blocking state
[66443.056918] br-lan: port 3(phy1-ap0) entered forwarding state
[69575.458156] br-lan: port 3(phy1-ap0) entered disabled state
[69585.977340] phy1-sta0: authenticate with redacted
[69586.083814] phy1-sta0: send auth to redacted (try 1/3)
[69586.099111] phy1-sta0: authenticated
[69586.107821] phy1-sta0: associate with redacted (try 1/3)
[69586.115669] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=23)
[69586.125737] phy1-sta0: associated
[69586.130606] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[69586.320337] br-lan: port 3(phy1-ap0) entered blocking state
[69586.325935] br-lan: port 3(phy1-ap0) entered forwarding state
[73325.207723] br-lan: port 3(phy1-ap0) entered disabled state
[73335.727016] phy1-sta0: authenticate with redacted
[73335.833244] phy1-sta0: send auth to redacted (try 1/3)
[73335.848525] phy1-sta0: authenticated
[73335.856954] phy1-sta0: associate with redacted (try 1/3)
[73335.864774] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=24)
[73335.874818] phy1-sta0: associated
[73335.938006] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[73336.044456] br-lan: port 3(phy1-ap0) entered blocking state
[73336.050102] br-lan: port 3(phy1-ap0) entered forwarding state
[75201.162174] br-lan: port 3(phy1-ap0) entered disabled state
[75211.631679] phy1-sta0: authenticate with redacted
[75211.737243] phy1-sta0: send auth to redacted (try 1/3)
[75211.752625] phy1-sta0: authenticated
[75211.761513] phy1-sta0: associate with redacted (try 1/3)
[75211.769275] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=25)
[75211.779387] phy1-sta0: associated
[75211.902969] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[75211.953203] br-lan: port 3(phy1-ap0) entered blocking state
[75211.958801] br-lan: port 3(phy1-ap0) entered forwarding state
[77080.156642] br-lan: port 3(phy1-ap0) entered disabled state
[77086.556045] phy1-sta0: authenticate with redacted
[77086.662930] phy1-sta0: send auth to redacted (try 1/3)
[77086.678187] phy1-sta0: authenticated
[77086.686070] phy1-sta0: associate with redacted (try 1/3)
[77086.693937] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=26)
[77086.704130] phy1-sta0: associated
[77086.846791] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[77086.890415] br-lan: port 3(phy1-ap0) entered blocking state
[77086.896087] br-lan: port 3(phy1-ap0) entered forwarding state
[88375.964589] br-lan: port 3(phy1-ap0) entered disabled state
[88382.333796] phy1-sta0: authenticate with redacted
[88382.441181] phy1-sta0: send auth to redacted (try 1/3)
[88382.456576] phy1-sta0: authenticated
[88382.463991] phy1-sta0: associate with redacted (try 1/3)
[88382.471810] phy1-sta0: RX AssocResp from redacted (capab=0x1011 status=0 aid=27)
[88382.482035] phy1-sta0: associated
[88382.574760] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by redacted
[88382.685740] br-lan: port 3(phy1-ap0) entered blocking state
[88382.691339] br-lan: port 3(phy1-ap0) entered forwarding state
[89249.843142] mt7530-mdio mdio-bus:1f lan: Link is Up - 1Gbps/Full - flow control rx/tx
[89249.851032] br-lan: port 1(lan) entered blocking state
[89249.856231] br-lan: port 1(lan) entered forwarding state

23.05.02 - config

root@209-Repeater:~# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "209-Repeater",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "D-Link DAP-X1860 A1",
        "board_name": "dlink,dap-x1860-a1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
root@209-Repeater:~#
root@209-Repeater:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'redacted::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'dhcp'
        option ipaddr '192.168.50.180'
        option netmask '255.255.255.0'
        option gateway '192.168.50.1'
        list dns '192.168.1.1'

config interface 'repeater_bridge'
        option proto 'relay'
        option ipaddr '192.168.1.30'
        list network 'lan'
        list network 'wwan'

root@209-Repeater:~#
root@209-Repeater:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '7'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'
        option txpower '20'
        option country 'DE'
        option noscan '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '209-Repeater-2.4Ghz'
        option encryption 'psk2'
        option key 'redacted'
        option macaddr 'random'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel '36'
        option band '5g'
        option htmode 'HE80'
        option txpower '20'
        option country 'DE'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '209-Repeater-5G'
        option encryption 'psk2'
        option key 'redacted'
        option macaddr 'random'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'LinBeTaiwanLan'
        option encryption 'psk2'
        option key 'redacted'
        option disabled '1'

config wifi-iface 'wifinet5'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'LinBeTaiwanLan'
        option encryption 'psk2'
        option key 'redacted'

root@209-Repeater:~#
root@209-Repeater:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

snapshot - dmesg


BusyBox v1.36.1 (2024-04-03 20:42:46 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r25773-766ec55966
 -----------------------------------------------------
root@209-Repeater:~# dmesg
[    0.000000] Linux version 6.1.82 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 13.2.0 r25773-766ec55966) 13.2.0, GNU ld (GNU Binutils) 2.40.0) #0 SMP Wed Apr  3 20:42:46 2024
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is D-Link DAP-X1860 A1
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] percpu: Embedded 12 pages/cpu s18240 r8192 d22720 u49152
[    0.000000] pcpu-alloc: s18240 r8192 d22720 u49152 alloc=12*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 64960
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes, linear)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Writing ErrCtl register=00000020
[    0.000000] Readback ErrCtl register=00000020
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 247868K/262144K available (7715K kernel code, 635K rwdata, 1660K rodata, 1240K init, 232K bss, 14276K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000]  Tracing variant of Tasks RCU enabled.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] rcu: srcu_init: Setting srcu_struct sizes based on contention.
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000004] sched_clock: 64 bits at 880MHz, resolution 1ns, wraps every 4398046511103ns
[    0.008056] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.066232] pid_max: default: 32768 minimum: 301
[    0.071712] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.078930] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.090284] cblist_init_generic: Setting adjustable number of callback queues.
[    0.097514] cblist_init_generic: Setting shift to 2 and lim to 1.
[    0.104134] rcu: Hierarchical SRCU implementation.
[    0.108898] rcu:     Max phase no-delay instances is 1000.
[    0.114927] smp: Bringing up secondary CPUs ...
[    0.120457] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.120489] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.120504] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.120559] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.179736] Synchronize counters for CPU 1: done.
[    0.212495] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.212522] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.212535] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.212570] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.271462] Synchronize counters for CPU 2: done.
[    0.302268] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.302295] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.302308] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.302349] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.356690] Synchronize counters for CPU 3: done.
[    0.386576] smp: Brought up 1 node, 4 CPUs
[    0.396396] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.406223] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.413279] pinctrl core: initialized pinctrl subsystem
[    0.420322] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.426975] thermal_sys: Registered thermal governor 'step_wise'
[    0.432759] FPU Affinity set after 11720 emulations
[    0.452113] clocksource: Switched to clocksource GIC
[    0.458747] NET: Registered PF_INET protocol family
[    0.463996] IP idents hash table entries: 4096 (order: 3, 32768 bytes, linear)
[    0.472583] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.480883] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.488628] TCP established hash table entries: 2048 (order: 1, 8192 bytes, linear)
[    0.496345] TCP bind hash table entries: 2048 (order: 3, 32768 bytes, linear)
[    0.503584] TCP: Hash tables configured (established 2048 bind 2048)
[    0.510087] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.516642] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.524042] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.529689] PCI: CLS 0 bytes, default 32
[    0.537373] workingset: timestamp_bits=14 max_order=16 bucket_order=2
[    0.549794] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.555682] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.567150] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.578458] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.584520] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.590481] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.596738] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[    0.603432] mt7621-pci 1e140000.pcie:   No bus range found for /pcie@1e140000, using [bus 00-ff]
[    0.612207] mt7621-pci 1e140000.pcie:      MEM 0x0060000000..0x006fffffff -> 0x0060000000
[    0.620310] mt7621-pci 1e140000.pcie:       IO 0x001e160000..0x001e16ffff -> 0x0000000000
[    0.982101] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    0.989010] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    0.993902] mt7621-pci 1e140000.pcie: PCIE1 enabled
[    0.998718] PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    1.005905] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    1.012222] pci_bus 0000:00: root bus resource [bus 00-ff]
[    1.017643] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.024507] pci_bus 0000:00: root bus resource [io  0x0000-0xffff]
[    1.030652] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    1.036610] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.042840] pci 0000:00:00.0: reg 0x14: [mem 0x60600000-0x6060ffff]
[    1.049079] pci 0000:00:00.0: supports D1
[    1.053018] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.059432] pci 0000:00:01.0: [0e8d:0801] type 01 class 0x060400
[    1.065477] pci 0000:00:01.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.071674] pci 0000:00:01.0: reg 0x14: [mem 0x60610000-0x6061ffff]
[    1.077996] pci 0000:00:01.0: supports D1
[    1.081917] pci 0000:00:01.0: PME# supported from D0 D1 D3hot
[    1.090035] pci 0000:01:00.0: [14c3:7916] type 00 class 0x000280
[    1.096081] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    1.103301] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    1.110442] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    1.117758] pci 0000:01:00.0: supports D1 D2
[    1.121938] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    1.128581] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.143686] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    1.148861] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.154948] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.161643] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x602fffff pref]
[    1.168931] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.175817] pci 0000:02:00.0: [14c3:7915] type 00 class 0x000280
[    1.181793] pci 0000:02:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    1.189012] pci 0000:02:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    1.196214] pci 0000:02:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    1.203521] pci 0000:02:00.0: supports D1 D2
[    1.207702] pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    1.214358] pci 0000:02:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:01.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.229570] pci 0000:00:01.0: PCI bridge to [bus 02-ff]
[    1.234801] pci 0000:00:01.0:   bridge window [io  0x0000-0x0fff]
[    1.240829] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff]
[    1.247605] pci 0000:00:01.0:   bridge window [mem 0x60400000-0x605fffff pref]
[    1.254789] pci_bus 0000:02: busn_res: [bus 02-ff] end is updated to 02
[    1.261375] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    1.267929] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.274852] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    1.281379] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.288349] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    1.295092] pci 0000:00:00.0: BAR 9: assigned [mem 0x60100000-0x602fffff pref]
[    1.302266] pci 0000:00:01.0: BAR 8: assigned [mem 0x60300000-0x603fffff]
[    1.308970] pci 0000:00:01.0: BAR 9: assigned [mem 0x60400000-0x605fffff pref]
[    1.316185] pci 0000:00:00.0: BAR 1: assigned [mem 0x60600000-0x6060ffff]
[    1.322931] pci 0000:00:01.0: BAR 1: assigned [mem 0x60610000-0x6061ffff]
[    1.329636] pci 0000:00:00.0: BAR 7: assigned [io  0x0000-0x0fff]
[    1.335726] pci 0000:00:01.0: BAR 7: assigned [io  0x1000-0x1fff]
[    1.341751] pci 0000:01:00.0: BAR 0: assigned [mem 0x60100000-0x601fffff 64bit pref]
[    1.349496] pci 0000:01:00.0: BAR 2: assigned [mem 0x60200000-0x60203fff 64bit pref]
[    1.357201] pci 0000:01:00.0: BAR 4: assigned [mem 0x60204000-0x60204fff 64bit pref]
[    1.364902] pci 0000:00:00.0: PCI bridge to [bus 01]
[    1.369785] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.375876] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.382613] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x602fffff pref]
[    1.389764] pci 0000:02:00.0: BAR 0: assigned [mem 0x60400000-0x604fffff 64bit pref]
[    1.397500] pci 0000:02:00.0: BAR 2: assigned [mem 0x60500000-0x60503fff 64bit pref]
[    1.405220] pci 0000:02:00.0: BAR 4: assigned [mem 0x60504000-0x60504fff 64bit pref]
[    1.412921] pci 0000:00:01.0: PCI bridge to [bus 02]
[    1.417804] pci 0000:00:01.0:   bridge window [io  0x1000-0x1fff]
[    1.423886] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff]
[    1.430592] pci 0000:00:01.0:   bridge window [mem 0x60400000-0x605fffff pref]
[    1.439813] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    1.451924] printk: console [ttyS0] disabled
[    1.456338] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 18, base_baud = 3125000) is a 16550A
[    1.465399] printk: console [ttyS0] enabled
[    1.473692] printk: bootconsole [early0] disabled
[    1.486964] nand: device found, Manufacturer ID: 0xc2, Chip ID: 0xf1
[    1.493406] nand: Macronix MX30LF1G18AC
[    1.497249] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    1.504835] mt7621-nand 1e003000.nand: ECC strength adjusted to 4 bits
[    1.513466] Signature found at block 1023 [0x07fe0000]
[    1.518603] NMBM management region starts at block 960 [0x07800000]
[    1.528777] First info table with writecount 1 found in block 960
[    1.546331] Second info table with writecount 1 found in block 963
[    1.552627] NMBM has been successfully attached
[    1.557376] 8 fixed-partitions partitions found on MTD device mt7621-nand
[    1.564200] Creating 8 MTD partitions on "mt7621-nand":
[    1.569416] 0x000000000000-0x000000080000 : "bootloader"
[    1.581606] 0x000000080000-0x000000100000 : "config"
[    1.593074] 0x000000100000-0x000000180000 : "factory"
[    1.605096] 0x000000180000-0x000000980000 : "kernel"
[    1.691877] 0x000000980000-0x000003580000 : "fwconcat0"
[    2.141341] 0x000003580000-0x000003980000 : "manufacture"
[    2.188905] 0x000003980000-0x000004000000 : "storage"
[    2.260865] 0x000004000000-0x000007800000 : "fwconcat1"
[    2.838322] Concatenating MTD devices:
[    2.842269] (0): "fwconcat0"
[    2.845165] (1): "fwconcat1"
[    2.848029] into device "virtual_flash"
[    2.851895] 1 fixed-partitions partitions found on MTD device virtual_flash
[    2.858859] Creating 1 MTD partitions on "virtual_flash":
[    2.864273] 0x000000000000-0x000006400000 : "ubi"
[    4.016062] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    4.029694] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 19
[    4.040125] i2c_dev: i2c /dev entries driver
[    4.048003] NET: Registered PF_INET6 protocol family
[    4.055904] Segment Routing with IPv6
[    4.059660] In-situ OAM (IOAM) with IPv6
[    4.063769] NET: Registered PF_PACKET protocol family
[    4.068927] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    4.082844] 8021q: 802.1Q VLAN Support v1.8
[    4.097130] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    4.122880] mt7530-mdio mdio-bus:1f: configuring for fixed/rgmii link mode
[    4.130707] mt7530-mdio mdio-bus:1f: Link is Up - 1Gbps/Full - flow control rx/tx
[    4.133016] mt7530-mdio mdio-bus:1f lan (uninitialized): PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=21)
[    4.152478] device eth0 entered promiscuous mode
[    4.157259] DSA: tree 0 setup
[    4.163287] UBI: auto-attach mtd8
[    4.166646] ubi0: attaching mtd8
[    6.187408] ubi0: scanning is finished
[    6.208857] ubi0: attached mtd8 (name "ubi", size 100 MiB)
[    6.214465] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    6.221339] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    6.228132] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    6.235102] ubi0: good PEBs: 800, bad PEBs: 0, corrupted PEBs: 0
[    6.241091] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
[    6.248304] ubi0: max/mean erase counter: 7/3, WL threshold: 4096, image sequence number: 1673110570
[    6.257441] ubi0: available PEBs: 0, total reserved PEBs: 800, PEBs reserved for bad PEB handling: 16
[    6.266698] ubi0: background thread "ubi_bgt0d" started, PID 284
[    6.269485] block ubiblock0_0: created from ubi0:0(rootfs)
[    6.278322] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
[    6.293961] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    6.305386] Freeing unused kernel image (initmem) memory: 1240K
[    6.311333] This architecture does not have kernel memory protection.
[    6.317842] Run /sbin/init as init process
[    6.321927]   with arguments:
[    6.321932]     /sbin/init
[    6.321938]   with environment:
[    6.321944]     HOME=/
[    6.321949]     TERM=linux
[    6.858143] init: Console is alive
[    6.862216] init: - watchdog -
[    7.632527] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    7.702173] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    7.711487] init: - preinit -
[   11.212087] random: crng init done
[   11.775826] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   11.788532] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   11.792570] mt7530-mdio mdio-bus:1f lan: configuring for phy/gmii link mode
[   11.804471] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   14.048639] UBIFS (ubi0:1): Mounting in unauthenticated mode
[   14.054716] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 426
[   14.255934] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[   14.263813] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[   14.273766] UBIFS (ubi0:1): FS size: 92946432 bytes (88 MiB, 732 LEBs), max 743 LEBs, journal size 4698112 bytes (4 MiB, 37 LEBs)
[   14.285419] UBIFS (ubi0:1): reserved for root: 4390089 bytes (4287 KiB)
[   14.292022] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID AF79C9F3-2310-469B-AE4A-E8387AEC5FB8, small LPT model
[   14.306044] mount_root: overlay filesystem has not been fully initialized yet
[   14.314455] mount_root: switching to ubifs overlay
[   14.678225] urandom-seed: Seed file not found (/etc/urandom.seed)
[   14.790462] procd: - early -
[   14.793881] procd: - watchdog -
[   15.438685] procd: - watchdog -
[   15.442638] procd: - ubus -
[   15.606751] procd: - init -
[   16.324848] kmodloader: loading kernel modules from /etc/modules.d/*
[   16.404540] mtk-eip93 1e004000.crypto: EIP93 Crypto Engine Initialized.
[   16.615733] Loading modules backported from Linux version v6.6.15-0-g51f354b815c4
[   16.623397] Backport generated by backports.git 193becf2
[   16.818576] pci 0000:00:00.0: enabling device (0006 -> 0007)
[   16.824307] mt7915e_hif 0000:01:00.0: enabling device (0000 -> 0002)
[   16.831362] pci 0000:00:01.0: enabling device (0006 -> 0007)
[   16.837104] mt7915e 0000:02:00.0: enabling device (0000 -> 0002)
[   17.114328] mt7915e 0000:02:00.0: HW/SW Version: 0x8a108a10, Build Time: 20220929104113a
[   17.114328]
[   17.358321] urngd: v1.0.2 started.
[   17.571121] mt7915e 0000:02:00.0: WM Firmware Version: ____000000, Build Time: 20220929104145
[   17.611277] mt7915e 0000:02:00.0: WA Firmware Version: DEV_000000, Build Time: 20220929104205
[   17.770138] mt7915e 0000:02:00.0: registering led 'mt76-phy0'
[   17.781193] mt7915e 0000:02:00.0: registering led 'mt76-phy1'
[   17.869631] PPP generic driver version 2.4.2
[   17.878002] NET: Registered PF_PPPOX protocol family
[   17.893619] kmodloader: done loading kernel modules from /etc/modules.d/*
[   18.319636] mtdblock: MTD device 'factory' is NAND, please consider using UBI block devices instead.
[   18.544881] mtdblock: MTD device 'factory' is NAND, please consider using UBI block devices instead.
[   29.594443] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
[   29.626303] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   29.634923] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   29.643994] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   29.655267] mt7530-mdio mdio-bus:1f lan: configuring for phy/gmii link mode
[   29.664830] br-lan: port 1(lan) entered blocking state
[   29.670084] br-lan: port 1(lan) entered disabled state
[   29.680443] device lan entered promiscuous mode
[   32.398922] mt7530-mdio mdio-bus:1f lan: Link is Up - 1Gbps/Full - flow control rx/tx
[   32.407291] br-lan: port 1(lan) entered blocking state
[   32.412633] br-lan: port 1(lan) entered forwarding state
[   32.452695] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   33.829568] br-lan: port 2(phy0-ap0) entered blocking state
[   33.835507] br-lan: port 2(phy0-ap0) entered disabled state
[   33.841966] device phy0-ap0 entered promiscuous mode
[   33.955547] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[   33.962663] br-lan: port 2(phy0-ap0) entered blocking state
[   33.968284] br-lan: port 2(phy0-ap0) entered forwarding state
[   35.367353] br-lan: port 3(phy1-ap0) entered blocking state
[   35.373022] br-lan: port 3(phy1-ap0) entered disabled state
[   35.379057] device phy1-ap0 entered promiscuous mode
[   35.384543] br-lan: port 3(phy1-ap0) entered blocking state
[   35.390148] br-lan: port 3(phy1-ap0) entered forwarding state
[   35.476217] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-ap0: link becomes ready
[   36.922276] br-lan: port 3(phy1-ap0) entered disabled state
[   39.618256] phy1-sta0: authenticate with [redacted]
[   39.635855] phy1-sta0: send auth to [redacted] (try 1/3)
[   39.642925] phy1-sta0: authenticated
[   39.652215] phy1-sta0: associate with [redacted] (try 1/3)
[   39.660067] phy1-sta0: RX AssocResp from [redacted] (capab=0x1011 status=0 aid=28)
[   39.670327] phy1-sta0: associated
[   39.743079] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by [redacted]
[   39.823542] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-sta0: link becomes ready
[   39.873039] br-lan: port 3(phy1-ap0) entered blocking state
[   39.878640] br-lan: port 3(phy1-ap0) entered forwarding state

snapshot - iwinfo & iwdev

root@209-Repeater:~# iwinfo
phy0-ap0  ESSID: "209-Repeater-2.4Ghz"
          Access Point: redacted
          Mode: Master  Channel: 7 (2.442 GHz)  HT Mode: HE40
          Center Channel 1: 5 2: unknown
          Tx-Power: 20 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ax/b/g/n
          Hardware: 14C3:7915 14C3:7915 [MediaTek MT7915E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

phy1-ap0  ESSID: "209-Repeater-5G"
          Access Point: redacted
          Mode: Master  Channel: 36 (5.180 GHz)  HT Mode: HE80
          Center Channel 1: 42 2: unknown
          Tx-Power: 20 dBm  Link Quality: 61/70
          Signal: -49 dBm  Noise: unknown
          Bit Rate: 6.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/ax/n
          Hardware: 14C3:7915 14C3:7915 [MediaTek MT7915E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1

phy1-sta0 ESSID: "LinBeTaiwanLan"
          Access Point: redacted
          Mode: Client  Channel: 36 (5.180 GHz)  HT Mode: HE80
          Center Channel 1: 42 2: unknown
          Tx-Power: 20 dBm  Link Quality: 52/70
          Signal: -58 dBm  Noise: unknown
          Bit Rate: 6.0 MBit/s
          Encryption: WPA2 PSK (CCMP)
          Type: nl80211  HW Mode(s): 802.11ac/ax/n
          Hardware: 14C3:7915 14C3:7915 [MediaTek MT7915E]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy1


root@209-Repeater:~# iw dev
phy#1
        Interface phy1-sta0
                ifindex 8
                wdev 0x100000003
                addr redacted
                ssid LinBeTaiwanLan
                type managed
                channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcolt                                                                                                                                                 x-bytes tx-packets
                        0       0       0       0       0       0       0      0                                                                                                                                                 0
        Interface phy1-ap0
                ifindex 6
                wdev 0x100000001
                addr redacted
                ssid 209-Repeater-5G
                type AP
                channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcolt                                                                                                                                                 x-bytes tx-packets
                        0       0       339     0       0       0       0      4                                                                                                                                                 2953            350
phy#0
        Interface phy0-ap0
                ifindex 5
                wdev 0x1
                addr redacted
                ssid 209-Repeater-2.4Ghz
                type AP
                channel 7 (2442 MHz), width: 40 MHz, center1: 2432 MHz
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcolt                                                                                                                                                 x-bytes tx-packets
                        0       0       0       0       0       0       0      0                                                                                                                                                 0

I can see in wireless that radios are set up simultaneously as AP and STA: is this allowed and working ?

Dmesg from the main image looks clean, no errors from what I can see.

Can you expand on this? Since this sounds like your typical DNS issue. You can probably reach IP addresses, but not resolve hostnames?

1 Like

Maybe not the best setup for low latency and throughput, but yes setting up both radios simultaneously as AP and STA clearly works in 23.05.02. My idea was to ideally have my roomneighbours legacy wifi 4 capable phone connected on 2.4 GHz, as the distance seems too much for 5GHz and let the faster devices that are closer to the router/repeater run on the 5GHz network.

1 Like

My PC, which is connected to the repeater as client and that runs Windows 10 gives the notification that the network is connected, but it says "no internet".
Please advice with commands to execute.
I know how to do a ping, but not sure how to "resolve hostnames"?

Can you ping repeater and main router with IP, than with hostnames? Do it from the diagnostics in LuCI, and from your computer.

For what it's worth ... I have used relayd for a year, before switching to WDS. I found it easier to configure and having better performance. I'm also using a mt7621 device as repeater.

2 Likes

Then you know how you can ping both a hostname/domain or IP address, right? The former will fail if your DNS is broken.

There's also the nslookup command on Windows:

2 Likes

Unfortunately, I don't have control over the main router right now, so I am forced to use relayd for the time being.

You were right. nslookup failed to receive dns hostnames, but ping is gone too.

snapshot - within repeater LuCI - ping, arp and nslookup

ping :x:

PING 192.168.50.1 (192.168.50.1): 56 data bytes
ping: sendto: Network unreachable

nslookup for 192.168.50.1 :x:

Server:		127.0.0.1
Address:	127.0.0.1:53
** server can't find 1.50.168.192.in-addr.arpa: NXDOMAIN

ARP scan for 192.168.50.1 :x:

Interface: phy1-ap0, type: EN10MB, MAC: [Redacted], IPv4: (none)
WARNING: Could not obtain IP address for interface phy1-ap0. Using 0.0.0.0 for
the source address, which may not be what you want.
Either configure phy1-ap0 with an IP address, or manually specify the address
with the --arpspa option.
ERROR: Could not obtain interface IP address and netmask
ERROR: pcap_lookupnet: phy1-ap0: no IPv4 address assigned

23.05.02 ping and nslookup on Linux client :white_check_mark::

thilo@thilo-Aspire-ES1-311 ~ $ nslookup 192.168.50.1
1.50.168.192.in-addr.arpa	name = TUF-AX3000_V2-F9B8.

Authoritative answers can be found from:

thilo@thilo-Aspire-ES1-311 ~ $ nslookup 192.168.50.180
180.50.168.192.in-addr.arpa	name = 209-Repeater.

There is also this:

Here is the kernel log from Repeater Snapshot

In particular this line seems suspicious: [ 4.058463] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this. Is this simply a warning or relevant? Here the rest:

[    0.000000] Linux version 6.1.82 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 13.2.0 r25773-766ec55966) 13.2.0, GNU ld (GNU Binutils) 2.40.0) #0 SMP Wed Apr  3 20:42:46 2024
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is D-Link DAP-X1860 A1
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000] percpu: Embedded 12 pages/cpu s18240 r8192 d22720 u49152
[    0.000000] pcpu-alloc: s18240 r8192 d22720 u49152 alloc=12*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 64960
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes, linear)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Writing ErrCtl register=00000020
[    0.000000] Readback ErrCtl register=00000020
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 247868K/262144K available (7715K kernel code, 635K rwdata, 1660K rodata, 1240K init, 232K bss, 14276K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] 	Tracing variant of Tasks RCU enabled.
[    0.000000] rcu: RCU calculated value of scheduler-enlistment delay is 10 jiffies.
[    0.000000] NR_IRQS: 256
[    0.000000] rcu: srcu_init: Setting srcu_struct sizes based on contention.
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000004] sched_clock: 64 bits at 880MHz, resolution 1ns, wraps every 4398046511103ns
[    0.008055] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.066233] pid_max: default: 32768 minimum: 301
[    0.071714] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.078932] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.090277] cblist_init_generic: Setting adjustable number of callback queues.
[    0.097511] cblist_init_generic: Setting shift to 2 and lim to 1.
[    0.104122] rcu: Hierarchical SRCU implementation.
[    0.108886] rcu: 	Max phase no-delay instances is 1000.
[    0.114901] smp: Bringing up secondary CPUs ...
[    0.120421] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.120453] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.120468] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.120524] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.179705] Synchronize counters for CPU 1: done.
[    0.212439] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.212466] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.212479] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.212515] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.271405] Synchronize counters for CPU 2: done.
[    0.302205] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.302231] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.302245] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.302284] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.356633] Synchronize counters for CPU 3: done.
[    0.386520] smp: Brought up 1 node, 4 CPUs
[    0.396338] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.406165] futex hash table entries: 1024 (order: 3, 32768 bytes, linear)
[    0.413222] pinctrl core: initialized pinctrl subsystem
[    0.420270] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.426927] thermal_sys: Registered thermal governor 'step_wise'
[    0.432697] FPU Affinity set after 11720 emulations
[    0.452016] clocksource: Switched to clocksource GIC
[    0.458653] NET: Registered PF_INET protocol family
[    0.463870] IP idents hash table entries: 4096 (order: 3, 32768 bytes, linear)
[    0.472485] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.480786] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.488531] TCP established hash table entries: 2048 (order: 1, 8192 bytes, linear)
[    0.496243] TCP bind hash table entries: 2048 (order: 3, 32768 bytes, linear)
[    0.503481] TCP: Hash tables configured (established 2048 bind 2048)
[    0.509984] UDP hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.516538] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes, linear)
[    0.523934] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.529581] PCI: CLS 0 bytes, default 32
[    0.537381] workingset: timestamp_bits=14 max_order=16 bucket_order=2
[    0.549781] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.555666] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.567258] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.578638] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.584754] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.590710] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    0.596916] mt7621-pci 1e140000.pcie: host bridge /pcie@1e140000 ranges:
[    0.603613] mt7621-pci 1e140000.pcie:   No bus range found for /pcie@1e140000, using [bus 00-ff]
[    0.612380] mt7621-pci 1e140000.pcie:      MEM 0x0060000000..0x006fffffff -> 0x0060000000
[    0.620468] mt7621-pci 1e140000.pcie:       IO 0x001e160000..0x001e16ffff -> 0x0000000000
[    0.982000] mt7621-pci 1e140000.pcie: pcie2 no card, disable it (RST & CLK)
[    0.988909] mt7621-pci 1e140000.pcie: PCIE0 enabled
[    0.993790] mt7621-pci 1e140000.pcie: PCIE1 enabled
[    0.998600] PCI coherence region base: 0x60000000, mask/settings: 0xf0000002
[    1.005785] mt7621-pci 1e140000.pcie: PCI host bridge to bus 0000:00
[    1.012105] pci_bus 0000:00: root bus resource [bus 00-ff]
[    1.017529] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.024393] pci_bus 0000:00: root bus resource [io  0x0000-0xffff]
[    1.030538] pci 0000:00:00.0: [0e8d:0801] type 01 class 0x060400
[    1.036496] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.042725] pci 0000:00:00.0: reg 0x14: [mem 0x60600000-0x6060ffff]
[    1.048965] pci 0000:00:00.0: supports D1
[    1.052905] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.059441] pci 0000:00:01.0: [0e8d:0801] type 01 class 0x060400
[    1.065483] pci 0000:00:01.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    1.071675] pci 0000:00:01.0: reg 0x14: [mem 0x60610000-0x6061ffff]
[    1.077998] pci 0000:00:01.0: supports D1
[    1.081918] pci 0000:00:01.0: PME# supported from D0 D1 D3hot
[    1.089878] pci 0000:01:00.0: [14c3:7916] type 00 class 0x000280
[    1.095915] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    1.103128] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    1.110270] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    1.117587] pci 0000:01:00.0: supports D1 D2
[    1.121767] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    1.128410] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.143507] pci 0000:00:00.0: PCI bridge to [bus 01-ff]
[    1.148665] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.154769] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.161475] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x602fffff pref]
[    1.168743] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    1.175651] pci 0000:02:00.0: [14c3:7915] type 00 class 0x000280
[    1.181607] pci 0000:02:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    1.188828] pci 0000:02:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    1.196024] pci 0000:02:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    1.203314] pci 0000:02:00.0: supports D1 D2
[    1.207494] pci 0000:02:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    1.214151] pci 0000:02:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:01.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    1.229311] pci 0000:00:01.0: PCI bridge to [bus 02-ff]
[    1.234533] pci 0000:00:01.0:   bridge window [io  0x0000-0x0fff]
[    1.240547] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff]
[    1.247325] pci 0000:00:01.0:   bridge window [mem 0x60400000-0x605fffff pref]
[    1.254503] pci_bus 0000:02: busn_res: [bus 02-ff] end is updated to 02
[    1.261078] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    1.267626] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.274547] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    1.281067] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    1.288031] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    1.294767] pci 0000:00:00.0: BAR 9: assigned [mem 0x60100000-0x602fffff pref]
[    1.301893] pci 0000:00:01.0: BAR 8: assigned [mem 0x60300000-0x603fffff]
[    1.308669] pci 0000:00:01.0: BAR 9: assigned [mem 0x60400000-0x605fffff pref]
[    1.315847] pci 0000:00:00.0: BAR 1: assigned [mem 0x60600000-0x6060ffff]
[    1.322584] pci 0000:00:01.0: BAR 1: assigned [mem 0x60610000-0x6061ffff]
[    1.329283] pci 0000:00:00.0: BAR 7: assigned [io  0x0000-0x0fff]
[    1.335374] pci 0000:00:01.0: BAR 7: assigned [io  0x1000-0x1fff]
[    1.341392] pci 0000:01:00.0: BAR 0: assigned [mem 0x60100000-0x601fffff 64bit pref]
[    1.349128] pci 0000:01:00.0: BAR 2: assigned [mem 0x60200000-0x60203fff 64bit pref]
[    1.356826] pci 0000:01:00.0: BAR 4: assigned [mem 0x60204000-0x60204fff 64bit pref]
[    1.364516] pci 0000:00:00.0: PCI bridge to [bus 01]
[    1.369394] pci 0000:00:00.0:   bridge window [io  0x0000-0x0fff]
[    1.375484] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    1.382217] pci 0000:00:00.0:   bridge window [mem 0x60100000-0x602fffff pref]
[    1.389366] pci 0000:02:00.0: BAR 0: assigned [mem 0x60400000-0x604fffff 64bit pref]
[    1.397098] pci 0000:02:00.0: BAR 2: assigned [mem 0x60500000-0x60503fff 64bit pref]
[    1.404799] pci 0000:02:00.0: BAR 4: assigned [mem 0x60504000-0x60504fff 64bit pref]
[    1.412503] pci 0000:00:01.0: PCI bridge to [bus 02]
[    1.417377] pci 0000:00:01.0:   bridge window [io  0x1000-0x1fff]
[    1.423459] pci 0000:00:01.0:   bridge window [mem 0x60300000-0x603fffff]
[    1.430163] pci 0000:00:01.0:   bridge window [mem 0x60400000-0x605fffff pref]
[    1.439388] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    1.450669] printk: console [ttyS0] disabled
[    1.455145] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 18, base_baud = 3125000) is a 16550A
[    1.464214] printk: console [ttyS0] enabled
[    1.472504] printk: bootconsole [early0] disabled
[    1.485861] nand: device found, Manufacturer ID: 0xc2, Chip ID: 0xf1
[    1.492306] nand: Macronix MX30LF1G18AC
[    1.496150] nand: 128 MiB, SLC, erase size: 128 KiB, page size: 2048, OOB size: 64
[    1.503722] mt7621-nand 1e003000.nand: ECC strength adjusted to 4 bits
[    1.512347] Signature found at block 1023 [0x07fe0000]
[    1.517483] NMBM management region starts at block 960 [0x07800000]
[    1.527643] First info table with writecount 1 found in block 960
[    1.545181] Second info table with writecount 1 found in block 963
[    1.551445] NMBM has been successfully attached
[    1.556121] 8 fixed-partitions partitions found on MTD device mt7621-nand
[    1.562920] Creating 8 MTD partitions on "mt7621-nand":
[    1.568134] 0x000000000000-0x000000080000 : "bootloader"
[    1.580026] 0x000000080000-0x000000100000 : "config"
[    1.591354] 0x000000100000-0x000000180000 : "factory"
[    1.603393] 0x000000180000-0x000000980000 : "kernel"
[    1.690339] 0x000000980000-0x000003580000 : "fwconcat0"
[    2.140196] 0x000003580000-0x000003980000 : "manufacture"
[    2.187757] 0x000003980000-0x000004000000 : "storage"
[    2.259804] 0x000004000000-0x000007800000 : "fwconcat1"
[    2.837285] Concatenating MTD devices:
[    2.841085] (0): "fwconcat0"
[    2.844057] (1): "fwconcat1"
[    2.846935] into device "virtual_flash"
[    2.850802] 1 fixed-partitions partitions found on MTD device virtual_flash
[    2.857776] Creating 1 MTD partitions on "virtual_flash":
[    2.863194] 0x000000000000-0x000006400000 : "ubi"
[    4.005806] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    4.019358] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 19
[    4.029659] i2c_dev: i2c /dev entries driver
[    4.037538] NET: Registered PF_INET6 protocol family
[    4.045439] Segment Routing with IPv6
[    4.049196] In-situ OAM (IOAM) with IPv6
[    4.053308] NET: Registered PF_PACKET protocol family
[    4.058463] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    4.072183] 8021q: 802.1Q VLAN Support v1.8
[    4.086778] mt7530-mdio mdio-bus:1f: MT7530 adapts as multi-chip module
[    4.112528] mt7530-mdio mdio-bus:1f: configuring for fixed/rgmii link mode
[    4.120362] mt7530-mdio mdio-bus:1f: Link is Up - 1Gbps/Full - flow control rx/tx
[    4.122950] mt7530-mdio mdio-bus:1f lan (uninitialized): PHY [mt7530-0:00] driver [MediaTek MT7530 PHY] (irq=21)
[    4.142441] device eth0 entered promiscuous mode
[    4.147219] DSA: tree 0 setup
[    4.153176] UBI: auto-attach mtd8
[    4.156533] ubi0: attaching mtd8
[    6.177332] ubi0: scanning is finished
[    6.198953] ubi0: attached mtd8 (name "ubi", size 100 MiB)
[    6.204547] ubi0: PEB size: 131072 bytes (128 KiB), LEB size: 126976 bytes
[    6.211416] ubi0: min./max. I/O unit sizes: 2048/2048, sub-page size 2048
[    6.218206] ubi0: VID header offset: 2048 (aligned 2048), data offset: 4096
[    6.225188] ubi0: good PEBs: 800, bad PEBs: 0, corrupted PEBs: 0
[    6.231176] ubi0: user volume: 2, internal volumes: 1, max. volumes count: 128
[    6.238389] ubi0: max/mean erase counter: 7/3, WL threshold: 4096, image sequence number: 1673110570
[    6.247521] ubi0: available PEBs: 0, total reserved PEBs: 800, PEBs reserved for bad PEB handling: 16
[    6.256775] ubi0: background thread "ubi_bgt0d" started, PID 284
[    6.259667] block ubiblock0_0: created from ubi0:0(rootfs)
[    6.268391] ubiblock: device ubiblock0_0 (rootfs) set to be root filesystem
[    6.283903] VFS: Mounted root (squashfs filesystem) readonly on device 254:0.
[    6.295297] Freeing unused kernel image (initmem) memory: 1240K
[    6.301244] This architecture does not have kernel memory protection.
[    6.307750] Run /sbin/init as init process
[    6.311837]   with arguments:
[    6.311842]     /sbin/init
[    6.311848]   with environment:
[    6.311853]     HOME=/
[    6.311859]     TERM=linux
[    6.848100] init: Console is alive
[    6.852157] init: - watchdog -
[    7.617421] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    7.686438] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    7.697481] init: - preinit -
[   11.211985] random: crng init done
[   11.774482] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   11.787225] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   11.792608] mt7530-mdio mdio-bus:1f lan: configuring for phy/gmii link mode
[   11.803188] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   14.048962] UBIFS (ubi0:1): Mounting in unauthenticated mode
[   14.055000] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 426
[   14.255275] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[   14.263153] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[   14.273077] UBIFS (ubi0:1): FS size: 92946432 bytes (88 MiB, 732 LEBs), max 743 LEBs, journal size 4698112 bytes (4 MiB, 37 LEBs)
[   14.284712] UBIFS (ubi0:1): reserved for root: 4390089 bytes (4287 KiB)
[   14.291309] UBIFS (ubi0:1): media format: w5/r0 (latest is w5/r0), UUID E99A8B43-B79A-449E-ADB5-A77AD0744FBA, small LPT model
[   14.305198] mount_root: overlay filesystem has not been fully initialized yet
[   14.313488] mount_root: switching to ubifs overlay
[   14.678220] urandom-seed: Seed file not found (/etc/urandom.seed)
[   14.790698] procd: - early -
[   14.794076] procd: - watchdog -
[   15.439500] procd: - watchdog -
[   15.443366] procd: - ubus -
[   15.550778] procd: - init -
[   16.268882] kmodloader: loading kernel modules from /etc/modules.d/*
[   16.347938] mtk-eip93 1e004000.crypto: EIP93 Crypto Engine Initialized.
[   16.555317] Loading modules backported from Linux version v6.6.15-0-g51f354b815c4
[   16.562910] Backport generated by backports.git 193becf2
[   16.758242] pci 0000:00:00.0: enabling device (0006 -> 0007)
[   16.764001] mt7915e_hif 0000:01:00.0: enabling device (0000 -> 0002)
[   16.771067] pci 0000:00:01.0: enabling device (0006 -> 0007)
[   16.776818] mt7915e 0000:02:00.0: enabling device (0000 -> 0002)
[   17.054051] mt7915e 0000:02:00.0: HW/SW Version: 0x8a108a10, Build Time: 20220929104113a
[   17.054051] 
[   17.378577] mt7915e 0000:02:00.0: WM Firmware Version: ____000000, Build Time: 20220929104145
[   17.418974] mt7915e 0000:02:00.0: WA Firmware Version: DEV_000000, Build Time: 20220929104205
[   17.469159] urngd: v1.0.2 started.
[   17.578694] mt7915e 0000:02:00.0: registering led 'mt76-phy0'
[   17.589312] mt7915e 0000:02:00.0: registering led 'mt76-phy1'
[   17.675553] PPP generic driver version 2.4.2
[   17.683282] NET: Registered PF_PPPOX protocol family
[   17.697213] kmodloader: done loading kernel modules from /etc/modules.d/*
[   18.162668] mtdblock: MTD device 'factory' is NAND, please consider using UBI block devices instead.
[   18.499506] mtdblock: MTD device 'factory' is NAND, please consider using UBI block devices instead.
[   29.498277] mtk_soc_eth 1e100000.ethernet eth0: Link is Down
[   29.533023] mtk_soc_eth 1e100000.ethernet eth0: configuring for fixed/rgmii link mode
[   29.541322] mtk_soc_eth 1e100000.ethernet eth0: Link is Up - 1Gbps/Full - flow control rx/tx
[   29.547497] mt7530-mdio mdio-bus:1f lan: configuring for phy/gmii link mode
[   29.560642] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   29.568135] br-lan: port 1(lan) entered blocking state
[   29.573523] br-lan: port 1(lan) entered disabled state
[   29.583156] device lan entered promiscuous mode
[   32.254561] mt7530-mdio mdio-bus:1f lan: Link is Up - 1Gbps/Full - flow control rx/tx
[   32.264624] br-lan: port 1(lan) entered blocking state
[   32.269882] br-lan: port 1(lan) entered forwarding state
[   32.281453] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
[   33.549174] br-lan: port 2(phy0-ap0) entered blocking state
[   33.555002] br-lan: port 2(phy0-ap0) entered disabled state
[   33.561456] device phy0-ap0 entered promiscuous mode
[   33.697975] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
[   33.705354] br-lan: port 2(phy0-ap0) entered blocking state
[   33.711042] br-lan: port 2(phy0-ap0) entered forwarding state
[   35.121165] br-lan: port 3(phy1-ap0) entered blocking state
[   35.126958] br-lan: port 3(phy1-ap0) entered disabled state
[   35.133333] device phy1-ap0 entered promiscuous mode
[   35.138771] br-lan: port 3(phy1-ap0) entered blocking state
[   35.144480] br-lan: port 3(phy1-ap0) entered forwarding state
[   35.232072] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-ap0: link becomes ready
[   36.662351] br-lan: port 3(phy1-ap0) entered disabled state
[   39.397563] phy1-sta0: authenticate with [MAC-redacted]
[   39.415253] phy1-sta0: send auth to [MAC-redacted] (try 1/3)
[   39.422312] phy1-sta0: authenticated
[   39.432081] phy1-sta0: associate with [MAC-redacted] (try 1/3)
[   39.439902] phy1-sta0: RX AssocResp from [MAC-redacted] (capab=0x1011 status=0 aid=31)
[   39.450490] phy1-sta0: associated
[   39.553055] phy1-sta0: Limiting TX power to 23 (23 - 0) dBm as advertised by [MAC-redacted]
[   39.593415] IPv6: ADDRCONF(NETDEV_CHANGE): phy1-sta0: link becomes ready
[   39.642448] br-lan: port 3(phy1-ap0) entered blocking state
[   39.648052] br-lan: port 3(phy1-ap0) entered forwarding state

@RolandoMagico @s_2 Can you reproduce? Am I the only one with this problem?

Sorry, I don't have Relayd running here

I guess you use WDS, or what is your modus operandi?

I just use the DAP-X1860 on demand as an AP

1 Like

I found the culprit. Snapshot works!

@Borromini was right. Was a DNS related issue. I had wrong dns settings in etc/config/network.

This one was the one line: list dns '192.168.1.1', which was a leftover from my old configuration. I recently moved to a different flat, so simply used my old config and changed a few things and forgot to change that part. Within the context of my new home, the correct line would have to be list dns '192.168.50.1'.

Here the full config that works for me:

v1.36.1 (2024-04-16 17:41:58 UTC) built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r25959-3908b77c9e
 -----------------------------------------------------
root@209-Repeater:~# ubus call system board
{
        "kernel": "6.1.86",
        "hostname": "209-Repeater",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "D-Link DAP-X1860 A1",
        "board_name": "dlink,dap-x1860-a1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "SNAPSHOT",
                "revision": "r25959-3908b77c9e",
                "target": "ramips/mt7621",
                "description": "OpenWrt SNAPSHOT r25959-3908b77c9e"
        }
}
root@209-Repeater:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd62:c696:6321::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.50.1'

config interface 'wwan'
        option proto 'static'
        option ipaddr '192.168.50.180'
        option netmask '255.255.255.0'
        option gateway '192.168.50.1'
        list dns '192.168.50.1'

config interface 'Bridge'
        option proto 'relay'
        option ipaddr '192.168.1.30'
        list network 'lan'
        list network 'wwan'

root@209-Repeater:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '11'
        option band '2g'
        option htmode 'HE40'
        option cell_density '0'
        option txpower '20'
        option country 'DE'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '209-Repeater-2.4Ghz'
        option encryption 'psk2'
        option key 'not-my-password-as-well'
        option macaddr 'random'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel '44'
        option band '5g'
        option htmode 'HE80'
        option txpower '20'
        option country 'DE'
        option cell_density '0'
        option beacon_int '101'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '209-Repeater-5G'
        option encryption 'psk2'
        option key 'not-my-password'
        option macaddr 'random'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'sta'
        option ssid 'LinBeTaiwanLan-2.4G'
        option encryption 'psk2'
        option key 'not-my-password-either'
        option network 'wwan'
        option disabled '1'

config wifi-iface 'wifinet5'
        option device 'radio1'
        option mode 'sta'
        option ssid 'LinBeTaiwanLan-5G'
        option encryption 'psk2'
        option key 'not-my-password-either'
        option network 'wwan'

root@209-Repeater:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option authoritative '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

I have to say, latency is terrible. Snapshot also (just like 23.05.03) yields average (mean) latency of 60ms when doing a bufferbloat test. With 23.05.02 it is more often around 30ms. But maybe I am just having unlucky timing with the tests and my roomneighbours are downloading a lot currently.

Anyway, Issue should be resolved. Thanks a lot for the help! Closing.

Weirdly enough, since 23.05.02 and 23.05.02 worked with the old config, I assume snapshot introduced more strict rules or changed "something" that would make my "incorrect" config to not work anymore.