Snapshot package feeds not updated

I ran into an issue using the snapshot imagebuilder for ramips/mt7621 (see below).
From what I can tell the package feeds were not updated with the latest build.
mipsel_24kc is one day old and x86_64 is even 3 days old as of writing this post.

Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency libubox20220927 for mtd
 * pkg_hash_fetch_best_installation_candidate: Packages for mtd found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package mtd.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for mtd:
 * 	libubox20220927
 * opkg_install_cmd: Cannot install package mtd.
make[2]: *** [Makefile:169: package_install] Error 255
make[1]: *** [Makefile:134: _call_manifest] Error 2
make: *** [Makefile:253: manifest] Error 2

They get updated just fine, but due to the two-step buildbot infra, the ABI versioned packages may take 1-3 days to be fully in sync. (Ubox was updated 29 hours ago, so the build artefacts are possibly still not yet fully synced.)

@hnyman thanks for your advice. I didn't know about the two phase process. I'll be watching buildbot package builds from now on.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.