Snapshot opkg problems mipsel_24kc: luci-lib-jsonc, luci-mod-admin-full

Tried installing LUCI on Linksys EA7500 V2 ( ramips, mt7621, mipsel_24kc) and had problems with certain packages from SSH terminal.


# opkg install luci-lib-jsonc
Collected errors:
 * opkg_download_pkg: Package luci-lib-jsonc is not available from any configured src.
 * opkg_download_cmd: Failed to download luci-lib-jsonc.

It is in Packages list:

Package: luci-lib-jsonc
Version: git-19.317.29469-8da8f38
Depends: libc, liblua5.1.5, libjson-c5
Source: feeds/luci/libs/luci-lib-jsonc
SourceName: luci-lib-jsonc
Section: luci
SourceDateEpoch: 1573632669
Architecture: mipsel_24kc
Installed-Size: 4333
Filename: luci-lib-jsonc_git-19.317.29469-8da8f38_mipsel_24kc.ipk
Size: 5129
SHA256sum: 6e4ac6322c198d3eefb4fc80fb884217701aa45a8b918a6d009088a7c076825e
Description:  Lua binding for JSON-C

And does exist as file:

Able to install manually:

opkg install luci-lib-jsonc_git-19.317.29469-8da8f38_mipsel_24kc.ipk


# opkg install luci-mod-admin-full
Installing luci-mod-admin-full (git-20.113.70804-9d02ef1) to root...
Collected errors:
 * opkg_download_pkg: Package luci-mod-admin-full is not available from any configured src.
 * opkg_install_pkg: Failed to download luci-mod-admin-full. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package luci-mod-admin-full.

In Packages list with different version: git-19.253.48496-3f93650
Version 19.... file exist and can install manually.

opkg install luci-mod-admin-full_git-19.253.48496-3f93650_all.ipk

Interestingly both files, with correct versions, are listed in Luci->Software->Available but says they are not installed. CLI opkg shows they are installed:

# opkg list-installed
luci-app-firewall - git-20.351.42931-972096b
luci-app-opkg - git-20.332.74200-03c77da
luci-base - git-21.002.46765-ab01040
luci-lib-base - git-20.232.39649-1f6dc29
luci-lib-ip - git-20.250.76529-62505bd
luci-lib-jsonc - git-19.317.29469-8da8f38
luci-lib-nixio - git-20.234.06894-c4a4e43
luci-mod-admin-full - git-19.253.48496-3f93650
luci-mod-network - git-21.002.48018-e609ef0
luci-mod-status - git-20.340.80217-277ffef
luci-mod-system - git-20.358.52388-846b89c
luci-proto-ipv6 - git-20.247.70930-f94958e
luci-theme-bootstrap - git-20.363.32570-6ffd159

Have you done so?

Sorry forgot to mention that I ran opkg update multiple times. The update completes successfully but the packages still cannot be installed using opkg install.