Smbclient connects to Samba share but mount -t cifs does not

I am trying to mount a samba share that is in OpenWrt to a directory on another Pi in the same LAN.

I am running this command from the Terminal of a Pi running OSMC (Kodi):
smbclient \\\\openwrt\\4TB2 -U root

It prompts for my password and lets me list the files in the 4TB2 share.

However when I try this command from OSMC terminal:
mount -t cifs //openwrt/4TB2 /mnt/4tb2

I get a password prompt but the same pwd does not authenticate me and I get the error:
mount error(95): Operation not supported
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

This command gives the same error(95)
mount -t cifs //openwrt/4TB2 /mnt/4tb2 -o username=root,password=pwd,vers=3.0

The /mnt/4tb2 directory exists. Do I need to make changes to my smb.conf or what is going wrong?

Cheers,

Flex

What's the output of mount -t cifs //openwrt/4TB2 /mnt/4tb2 --verbose -o username=root,password=pwd,vers=3.0 ?

1 Like

Help with Samba36 and Windows 10 - #6 by Andy2244 suggests that samba36-server supports only up to SMB 2.1.

1 Like

When I add in the verbose parameter I get the same error.
Also, I am trying to mount a Samba share from one Linux OS onto another Linux OS. I would like to see the mounted share from Windows 10 file explorer but I don't think the reason why it's not working is anything to do with Windows 10?

I tried this command and also get the same mount error(95)
mount -t cifs //openwrt/4TB2 /mnt/4tb2 --verbose -o username=root,password=pwd,vers=2.1

Interestingly, if I try it the other way around... and try to mount a share that is on the Pi running OSMC Pi to a directory on the Pi running OpenWrt... it does work.

So I run this command from OpenWrt and it mounts that share:
mount -t cifs //osmc/4TB1 /mnt/4tb1 -o username=osmc,password=pwd,vers=3.0

But I prefer to mount the OpenWrt share in OSMC.

Maybe this is a firewall issue with OpenWrt?

Flex

What happens if you omit the version option from the command?

What happens if you force the version to 1.0?

What happens if you include the option sec=ntlm?

2 Likes

@iplaywithtoys
Thanks for your help with this.

In OpenWrt I ran the command smbstatus and the Protocol version is SMB3_11.
So then from the OSMC Pi I tried the command:
mount -t cifs //openwrt/4TB2 /mnt/4tb2 -o username=root,password=pwd,vers=3.11

And now it works!

Flex

2 Likes

Excellent! Glad you got there.

mhh should the vers not be auto-negotiated? So omitting it should work as well and still connect with the highest possible version?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.