Smb + wsdd cross-subnet with smcroute not working

Hello!

I set up a samba share in subnet "infra" 192.168.0.0/24. I use wsdd to anounce the server, so it's visible in windows explorer.

My windows client is in 192.168.1.0/24. When I move the samba server to the same subnet, it is visible in windows explorer. When it is in 192.168.0.0/24 it is not.

I installed and configured smcroute for this use case. With wireshark I can see the UDP multicasts from 192.168.0.6/24 (smb server) to 239.255.255.250 on my windows client (192.168.1.50/24). I compared this package with the one when the samba server was in the same subnet and I can't spot any obvious differences other than the source ip.

Firewall is no issue, as the packages arrive at the windows client. TTL is also high enough as it gets picked up. Relevant config:

br-infra is 192.168.0.0/24 and br-user is 192.168.1.0/24.

/etc/smcroute.conf:

phyint br-infra enable
phyint br-user enable

mgroup from br-infra group 239.255.255.250
mroute from br-infra group 239.255.255.250 to br-user

mgroup from br-user  group 239.255.255.250
mroute from br-user  group 239.255.255.250 to br-infra

include /etc/smcroute.d/*.conf

/etc/wsdd.conf (on smb server)

WSDD_PARAMS="-v -s -w WORKGROUP -H 4"

/etc/samba/smb.conf (on smb server)

[global]
domain master = yes
local master = yes
preferred master = yes
os level = 65

workgroup = WORKGROUP
server string = %h server
log level = 0
log file = /var/log/samba/log.%m
max log size = 50

guest account = xyz
unix extensions = yes
map to guest = Bad User

time server = no
wins support = yes

disable netbios = no
multicast dns register = yes
remote announce = 192.168.0.255/WORKGROUP 192.168.1.255/WORKGROUP

[share1]
...

Does anyone know what I'm doing wrong? According to other posts this is how it should work :confused: