SmartTV and Sonos across different networks

I have setup a new Glinet Flint2 router with Openwrt 21.2.
I have created 3 wireless networks for

  • lan - Trusted devices
  • iot_online - IoT devices with access to internet
  • iot_offline - IoT with no access to internet

I've placed the smart TV and the Sonos speakers in the "iot_online" network.

network configuration

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'
	option igmp_snooping '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.8.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option isolate '0'

config interface 'iot_offline'
	option proto 'static'
	option ipaddr '192.168.20.1'
	option netmask '255.255.255.0'
	option device 'br-iot-offline'

config interface 'iot_online'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.10.1'
	option device 'br-iot-online'

config device
	option bridge_empty '1'
	option type 'bridge'
	option name 'br-iot-online'
	option igmp_snooping '1'

config device
	option bridge_empty '1'
	option type 'bridge'
	option name 'br-iot-offline'

Relevant firewall rules


config defaults
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option synflood_protect '1'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'iot_offline'
	option forward 'REJECT'
	list network 'iot_offline'
	option input 'ACCEPT'
	option output 'ACCEPT'

config zone
	option name 'iot_online'
	option forward 'REJECT'
	list network 'iot_online'
	option output 'ACCEPT'
	option input 'ACCEPT'

config forwarding
	option dest 'wan'
	option src 'iot_online'

config rule
	option dest_port '67-68'
	option src 'iot_online'
	option name 'Allow_DHCP_iot_online'
	option target 'ACCEPT'
	list proto 'udp'

config rule
	option dest_port '53'
	option src 'iot_online'
	option target 'ACCEPT'
	option name 'Allow_DNS_iot_online'

config rule
	option dest_port '67-68'
	option src 'iot_offline'
	option name 'Allow_DHCP_iot_offline'
	option target 'ACCEPT'
	list proto 'udp'

config forwarding
	option dest 'iot_offline'
	option src 'lan'

config forwarding
	option dest 'iot_online'
	option src 'lan'

The problem that my phone with the Sonos app, or accessing the TV, doesn't seem to work anymore. In the Sonos App I cannot discover the speakers in "iot_online" anymore. Also streaming an app to the TV doesn't seem to work anymore.
I suspect it may have to do with IGMP not being forwarded as expected but I'm not familiar enough with it.
Does anyone know if it is possible to get this work?

Seems like you're running GL-Inet's vendor firmware which is a heavily modified fork of OpenWrt. If you want to use their firmware, you need to ask for help on the gl-inet forums because the changes they have made mean that their firmware no longer behaves like the official OpenWrt firmware.

Alternatively, you can install the official version from here:
https://firmware-selector.openwrt.org/?version=23.05.3&target=mediatek%2Ffilogic&id=glinet_gl-mt6000

Thanks, I shall do that

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.