Smartlife app problem

Trying to connect a smart kettle on Smartlife app. I have tried both EZ and slow connection - no loy. On the "Slow connection, I get the slow blink but also a message - "Smartlife connected - but no internet."
I have virgin media. Other smart devices connected (3 in total) Have no idea how to fix this, can anyone help please?

Which router are you using? Which version of OpenWrt is installed? How is it configured?

I use SmartLife app too and I solved my issues disabling WMM (802.11e) support setting option wmm '0' during the pairing in /etc/config/wireless (you'd bettere reenabling it after pairing cause disabling it reduces the performaces).
Hope this will help.

Regards.
Pino

config wifi-iface
        option device 'radio1'
....
        option wmm '0'