Smart Life network problem


#1

Help !
I have a network problem when I try to install two iGenix panel heaters on my home network. Other smart devices have connected and function correctly, albeit with some initial problems.

In short, the configuration sequence between device and app running on mobile phone does not complete. It starts fine, but times out with an error.
In detail, the sequence is :-

  1. Installed app on mobile phone
  2. Switched iGenix heater to config mode (WiFi LED flashing quickly)
  3. Started app
  4. On app, switched to SSID of nearby Draytek hub
  5. On app, entered WiFi password
  6. On app, started configuration. (WiFi LED still flashing quickly)
  7. Spinner gets to 10% and panel heater's WiFi LED goes out.
  8. Spinner gets to 20% and panel heater's WiFi LED comes on, no flashing.
  9. At this point, the heater appears in the DHCP table and pings fine.
  10. Spinner goes all the way round to 100% and shows error.

I've repeated the sequence on both heaters.
I've used TWO apps - iGenix and SmartLife - both have the same behaviour.
I've used another phone - same problem.
There's plenty bandwidth - I switched off three security cameras.
I switched the WiFi hub to 2.4 GHz and disabled 5 GHz.
WPA/WPA2-PSK enabled.
Tried AP mode - same problem. I note that the 'private' SSID of the heater appears - "SmartLife_D7F1".
In the DHCP table, the devices appear as "EPS_DED7F1" and "EPS_DB69B7". I see that the last six digits are the same as the last six digits in the MAC address. They have IP addresses assigned and they ping fine.

Now then, I tried to break down the problem by getting another mobile phone and switched it to a hotspot. I went through the configuration sequence and it worked !!! This indicates that the phone works fine, the heater worked fine.

Can anyone help ?

Many thanks,
Jim Burke


#2

Often IoT devices require direct connectivity for initial discovery and configuration. They sometimes use link-local connectivity, or depend on the device getting its IP from the IoT device's DHCP.

If you've still got connectivity problems after configuration of the devices to connect to your AP (preferably on an isolated SSID/VLAN), then I'd look to see if "client isolation" is causing a problem. The next steps past that would, for me, be to understand the protocol and use tcpdump and/or wireshark to "see" what is or isn't happening.


#3

Is the the SSID name "EPS..." or "ESP..."?
Which router do you own?


#4

Jeff,

Yeah - a TCP monitor is my last option, but even what that discovers may not help.

It does seem that the initial negotiation (via UDP as far as I know) works fine, as the heater defo gets the SSID and p/w of the WiFi hub and then gets assigned an IP address. It's the next part of the negotiation that seems to fail.

It'd be nice to see the protocol specification.

Jim


#5

Eduperez,

It's "ESP_...".

I have a Virgin SuperHub 2ac.

Jim


#6

Perhaps some hints on protocol to follow on https://github.com/codetheweb/tuyapi/issues/22


#7

How is this related to OpenWrt?


#8

Is OpenWrt installed on that router? I assumed it is, or you would not be asking this question here, but it does not seem to be supported... Most "smart devices" use ESP3286 / ESP32 chips, that are notable for having trouble connecting to some APs.


#9

As far as I know, OpenWRT is not used here. Apologies if I have inadvertently posted on an inappropriate site. However I am having difficulty in locating a suitable forum and thought that I had hit a site where some users would have knowledge of this networking problem and would be able to help.

Jim


#10

If I were you, I would check with the manufacturer of the heaters. As long as you are not doing something unusual, then the manufacturer or other users of he heaters should be able to help.


#11

Thanks for this link. Interesting, but I still don't think it helps me as the negotiation starts fine but doesn't complete properly.


#12

@JimBurke This forum focuses on OpenWrt.
Since your problem is not related to OpenWrt, you might be better off searching for a solution in a different forum, or at the manufacturer of your devices.

Thanks for your understanding.


closed #13

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.