Slower speed after update from 15.05.1 to 17.01.4 with Intel Intel Centrino Ultimate-N 6300

Hi,

After upgrading to the last version my wireless speed has dropped from about 40-45 MB/s to 20-25 MB/s
Any suggestions?

I am using Linux mint 18.3 on dell lattitude e 6420

Thank you :slight_smile:

cat /etc/config/wireless

Note: Make sure to obscure the "option key" value(s) in the wireless config results before posting.

%D0%A1%D0%BD%D0%B8%D0%BC%D0%BA%D0%B0%20%D0%BD%D0%B0%202018-03-20%2022-52-45

Hi,
I wasn'r able to find any other wireless configuration except this - cat /etc/config/wireless gave me a message for missing file

I hope this is helping you - the upper part is with 15.05, and the bottom one is with 17.01

/etc/config/wireless on your router, not on pc. what your router model ?

I just went through this issue with an HP 8570w notebook with the same wireless adapter. I was getting speeds ranging from 100 mpbs down to 40 mbps and couldn't figure out why. The issue turned out to be a combination of the driver version and the power management settings for the wireless adapter.

First, the driver. I ended up trying different driver versions from Intel one by one until I found the one that gave the best results. For me, that was version 15.2.0.19 for Windows 7.

Second, the power saving mode for the wireless adapter has a large impact on the speed. I just tested this on a TP-Link Archer C7 v2 with 17.0.1.4. When I set the "wireless adapter power saving mode" to "maximum performance" I get 114 mpbs down (2.4 ghz). If I change the power saving mode to "low/med/high power saving" my speeds drop to 40-50 mpbs down.

Does Linux have the same power management settings? I've never used Linux.

@leeandy sorry, i haven't figured that - here they are-
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/ar934x_wmac'
option country 'DE'
option htmode 'HT40'
option txpower '16'
option channel 'auto

@chadneufeld at linux we have only on and off, speed is about 10-15 MB/s more, i.e. about 30-35, however with 15.05 even with powersave on the speed is about 40-45 MB/s

I just tested the speed with my Lenovo Thinkpad T470s ( Win 10pro) and i've got 70 MB/s ( which is the maximum of the speed I'm paying for) Maybe it is something to do with combination of the buggy linux driver for centrino wifi 6300 and how the router is doing in noisy environement..

I don't know if that's relevant, but there must be some update, which made LEDE much slower :frowning: I have slower the whole router with just wifi enabled, see Wan->lan 25mbit speed drop with wifi enabled on QCA9531/QCA9533

have you tried over cable with wifi disabled? Maybe it's the same.

@nozombian hi, on cable i am getting 70 MB/s, no any slowdown here, just while using it with my linux setup on wifi my router is tp-link 841 v8

Hi, just for the sake of testing have you tried your laptop with windows? I like mint too, but I also found to get half the speed with it on wifi compared to windows with some wifi cards - tried several notebooks.

@nozombian up in the comments a guy said that it is working good with certain driver on windows 7 :slight_smile:

Yeah, right, oops, I missed that :blush: Probably not a lede problem then, maybe mint forum could be better place to ask.

@nozombian it is a lede problem, because as i said with 15.05 i was able to get 50 Mb/s with intel centrino on linux - maybe devs has change someting which affected only this combination however it is still an issue which should be solved

Then report it...

https://bugs.openwrt.org/

@neycho I wonder if there is something different in the configuration between your 15.05.1 setup and your 17.01.4 setup.

Do you have a backup file from your 15.05.1 install? If so, you could try creating a backup of your 17.01.4 setup. Extract both archives. Do a text file compare for all of the files in the backup directories. That might show if there is some setting different between the two setups.

Hi,

I've done some additional settings on my wifi setting like turning off the power management and explicitly setting that my wifi card must use channel aggregation ( still LEDE refuses to set more 20 MHz to a channel, even testing to a place when there is no wifi signals at all ) and i've been able to see speeds like on 15.05.

Possibly there is something to be fixed at how ath_htc driver is working in congested environment with lot of noise and allowing 40 Mhz channels when there is no congestion. I am seeing some other users complaining from the last, but not sure if there is ticket opened though. cc @jwoods

fwiw, I've also witnessed unstable wifi with certain Intel Centrino wifi cards running Windows 10 and Mint Linux 17.3 when connecting to 2.4 GHz wifi in 20 MHz mode on Home Hub 5A running r796 (June 2016), 17.01.2, 17.01.4 & 18.06.0 snapshot configured as an access point.

Most of the testing done with Windows 10 and 6205 or 6300 cards on a number of Dell laptops. When performing a speed test, the downstream side of the test is usually (but not always) completed, speeds sometimes may be a bit on the lower side than expected. But when performing the upstream test, the traffic usually comes to an abrupt halt, and the router can't be pinged from the test laptop. The laptop eventually disconnects wifi after a minute and seeks out another AP. I tried a multitude of drivers including v15.18.0.1 which I believe is the latest and is a Windows 8.1 driver. Mint Linux 17.3 with 6300 card also exhibits same symptoms.

I also have the same problem with Centrino 7260-AN N600/BT4 card with very latest Windows 10 driver.

If I run stock BT firmware on the same HH5A, all the above Intel wifi cards work fine.

If I use older 5300 or 6200 wifi card, all seems to work just fine connecting to the HH5A with above mentioned versions of LEDE. The 6200 card using v15.17.0.1 windows 8 driver running in windows 10.

I've also tested AR5B22 (AR9462) N600/BT4 cards using latest v10.0.3.456 windows 10 driver (Jan 2018) in the same laptops, and it seems seems to work well with the AR9227 wifi chip in the HH5A on 2.4 Hz. (Any AR5B22 card not from Lenovo or HP, should work in a Dell. I used Acer AR5B22 cards. Dell's AR5B22 is the DW1901)