Slower speed after installing (testing) multiple versions

I've been a huge fan of OpenWRT. I recently posted about a similar issue but got no solution. Currently, on any version of OpenWRT I use, I experience 60–100 Mbps less speed on a wired connection, resulting in around 850 Mbps, even though I have a gigabit internet plan. Whenever I use the stock OS, I get the full speed from my router, around 980–986 Mbps.

Back when I installed OpenWRT (23.05.03) for the first time, I had no issues, and I was getting the same speeds as the stock OS. I tried different versions to check for any benefits and found that version 22.03.6/7 uses less RAM and feels much snappier. From there, I noticed my speeds have dropped. No matter how many times I re-install 23.05.3/4/5, nothing seems to work for me.

I’ve tried many settings, but they didn’t help. I also used irqbalance, but it didn’t help either.

Please help me with this problem. I find OpenWRT much safer to use and appreciate its additional functionality.

Please add output of (cleaning passkeys) of:

ubus call system board
cat /etc/config/network
cat /etc/config/firewall
cat /etc/config/wireless # if used

And a link to result of this test:
https://www.waveform.com/tools/bufferbloat
(not screenshot)

This is done with v22.03.7 it uses less ram than the latest version uses around 50% memory
https://www.waveform.com/tools/bufferbloat?test-id=68ed8888-6c7f-47c8-b7a1-438335cde721

root@OpenWrt:~# ubus call system board
{
        "kernel": "5.10.221",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link Archer C6 v3",
        "board_name": "tplink,archer-c6-v3",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.7",
                "revision": "r20341-591b7e93d3",
                "target": "ramips/mt7621",
                "description": "OpenWrt 22.03.7 r20341-591b7e93d3"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc3:95c8:672e::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.1.1.1'
        list dns '10.100.100.10'
        list dns '8.8.8.8'
        option delegate '0'

config interface 'wan'
        option device 'wan'
        option proto 'pppoe'
        option username 'abafsan'
        option password '01769971615'
        option ipv6 '0'
        option peerdns '0'
        list dns '10.100.100.10'
        list dns '8.8.8.8'
        option sourcefilter '0'
        option delegate '0'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'
        option auto '0'
        option reqaddress 'none'
        option reqprefix 'no'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option flow_offloading '1'
        option flow_offloading_hw '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '2g'
        option htmode 'HT40'
        option channel 'auto'
        option country 'BD'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid ':D'
        option encryption 'psk2'
        option key '#ULRY8JGV'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option band '5g'
        option htmode 'VHT80'
        option country 'BD'
        option cell_density '0'
        option channel '161'
        option txpower '24'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid ':D_5G'
        option encryption 'psk2'
        option key '#ULRY8JGV'

root@OpenWrt:~#

I have also checked out 23.05.5/3 the speeds are the same as 22.03.7, and here are the stock firmware performance
https://www.waveform.com/tools/bufferbloat?test-id=b9055896-296d-4fd2-89da-3c898831a7c1


Mentionable that only the download speed is less on openwrt otherwise the upload speeds are the same.

Slow download speeds was a misfeature of 23.05.4.

1 Like

Is there any option to optimize v22.03.7 for the maximum speed/performance. Internet prices are high in my area that's why I'm concerned also I used to get maximum speed when I first installed the os but now it's performing slightly worse, I wonder if the hardware degraded it would have also effected the speeds on the stock os aint it ?? If eveythings working fine on stock os it means nothing with hardware something to do with the os. please help out on this problem

Get 24.10? 22.07 is EOL

Unfourtunately 24.10 is not avaible on firmware selector for my router

Wait for 24.10rc4 to be announced - it is still building. Firmware selector may provide an image for some targets now, but not all targets until it's done. Give it a day or two.

24.0-SNAPSHOT seems to be already fixed.

it is even worse on 24.10

Try speed.cloudflare.com and fast.com too - might be some temporary issue with your provider throttling speedtest.

It looks you need to disable network pauses (ethtool -a/-A/-r , check with ethtool ethX)

I checked it on other sites also the results are same, it's honestly upsetting me, I mean what's wrong with it why does it give me less speeds on openwrt

How do I do that ?? I'm not quite good at ssh

@Unvariable were you able to solve the speed issue.

I have some what similiar issue. I got a 1 Gbps WAN connection and with stock firmware I used to get around 400-450 Mbps on devices connected to the 5GHz band but after installing openwrt the speed on my laptop is capped around 200-250 Mbps. I have already done all the things that are mentioned in this post, nothing worked. One thing that I have noticed is the link speed of my laptop is 433 Mbps but link speed of my phone is 866 Mbps.

Tetrofit second antenna in your laptop and dont steal unrelated thr#ads.

That didn't work.

Make a new thread, sharing fcc id of your laptop. No pictures.