Slow upload speed

Thanks replaced the username and password, I don't think leaving the IP addresses will be of any use or do any halm so have left them in

config queue 'eth1'
        option qdisc 'fq_codel'
        option script 'simple.qos'
        option qdisc_advanced '0'
        option linklayer 'none'
        option debug_logging '0'
        option verbosity '5'
        option download '20000'
        option upload '20000'
        option enabled '1'
        option interface 'dsl0.101'

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9e:9367:f5ee::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'a'
        option tone 'a'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'
        option ds_snr_offset '0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.61.254'
        option dns '212.159.96.43 212.159.96.44'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '54:64:d9:12:e2:d4'

config device 'wan_dev'
        option name 'dsl0'
        option macaddr '54:64:d9:12:e2:d5'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'
        option auto '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 6t'

config interface 'DSL'
        option proto 'pppoe'
        option ipv6 '1'
        option ifname 'dsl0.101'
        option username 'user@plusdsl.net'
        option password 'password'

Which one?

I know how to upload the firmware to the router and flash it... But how do I know which one to chose

A viable option, but nowadays I would always recommend to at least also try:

        option qdisc 'cake'
        option script 'piece_of_cake.qos'

This is almost always the wrong thing to do as this simply defaults to the 14 bytes that the kernel traditionally reserves for src and dst MAC addresses and ethertype. Instead of going though this line by line, here is a proposal for a sqm config:

config queue 'eth1'
        option ingress_ecn 'ECN'
        option egress_ecn 'ECN'
        option itarget 'auto'
        option etarget 'auto'
        option verbosity '5'
        option qdisc 'cake'
        option script 'piece_of_cake.qos'
        option qdisc_advanced '1'
        option squash_dscp '1'
        option squash_ingress '1'
        option qdisc_really_really_advanced '1'
        option eqdisc_opts 'nat dual-srchost'
        option linklayer 'ethernet'
        option linklayer_advanced '1'
        option tcMTU '2047'
        option tcTSIZE '128'
        option linklayer_adaptation_mechanism 'default'
        option debug_logging '1'
        option iqdisc_opts 'nat dual-dsthost ingress'
        option interface 'pppoe-wan'
        option tcMPU '88'
        option enabled '1'
        option overhead '34'
        option download '33000'
        option upload '570'

Please note the upload is tailored for your current too low upload, you will need to change that once you get your upload fixed.

That indicates, that pppoe-wan is the better interface for the shaper than dsl0.101 and that 34 bytes of overhead are a reasonable assumption.

Sorry missed this one

 tc -s qdisc
qdisc noqueue 0: dev lo root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc fq_codel 0: dev eth0 root refcnt 2 limit 10240p flows 1024 quantum 1514 target 5.0ms interval 100.0ms memory_limit 4Mb ecn
 Sent 5522766 bytes 34522 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
  maxpacket 1123 drop_overlimit 0 new_flow_count 90 ecn_mark 0
  new_flows_len 0 old_flows_len 0
qdisc noqueue 0: dev br-lan root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc noqueue 0: dev eth0.1 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc noqueue 0: dev wlan1 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc noqueue 0: dev wlan0 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc fq_codel 0: dev dsl0 root refcnt 2 limit 10240p flows 1024 quantum 1514 target 5.0ms interval 100.0ms memory_limit 4Mb ecn
 Sent 19455291 bytes 72868 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
  maxpacket 0 drop_overlimit 0 new_flow_count 0 ecn_mark 0
  new_flows_len 0 old_flows_len 0
qdisc noqueue 0: dev dsl0.101 root refcnt 2
 Sent 0 bytes 0 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
qdisc fq_codel 0: dev pppoe-DSL root refcnt 2 limit 10240p flows 1024 quantum 1518 target 5.0ms interval 100.0ms memory_limit 4Mb ecn
 Sent 17846181 bytes 72569 pkt (dropped 0, overlimits 0 requeues 0)
 backlog 0b 0p requeues 0
  maxpacket 1492 drop_overlimit 0 new_flow_count 382 ecn_mark 0
  new_flows_len 0 old_flows_len 3

You need to try this out, because if this is about compatibility with your DSLAM's firmware there is no way figuring out from a different DSLAM (and I am not even in the UK so really could not tell you). That said, I would try with the latest release version "VDSL over ISDN incl. vectoring support" where the ADSL part is labeled as "ADSL Annex A".

No flashing required, just copy the extracted blob to a known location on the router, e.g. to:

/etc/config/vr9-B-dsl.fb7490-07.28-5.9.1.4.0.7.bin

and then add the following to the "config dsl 'dsl'" section in /etc/config/network

        option firmware '/etc/config/vr9-B-dsl.fb7490-07.28-5.9.1.4.0.7.bin'

just replace with the correct file name. There is no need to reflash the router's whole firmware to upload a different firmware blob for the dsl modem (think of the modem as its own little comnputer and the blob being the OS, driver, and DSL application code to run on that computer).

Good luck.

Ah, for simple.qos, I also need the output of tc -d qdisc, but realistically this is not going to fix your low level DSL sync issue, so maybe post-pone this until the DSL issue is addressed?

I cannot seem to extract the blob tried downloading from site and getting 404 error. I also tried wget and getting
"wget: SSL support not available, please install one of the libustream-.*[ssl|tls] packages as well as the ca-bundle and ca-certificates packages."

I don't know how to resolve this issue

Never mind I got it

No I didn't ... still cannot get the file

I really think you need to use a different machine to download and extract firmware blobs as that requires a number of tools that seem tricky to get working on OpenWrt.

Seems like great advice above and how about also posting on the Plusnet forum? They are pretty responsive there too. See, for example, this thread:

I don't suppose you are able to get onto one of the BT 'full fibre' packages? My mother is getting one of those and I feel rather envious!

I used to use Plusnet myself for a 25Mbit fibre line and helped my mother with hers. My experience is that their service deteriorated rapidly a couple of years or so ago. They advertise rate X but provide rate X - Y, where Y is significant, and glitches and downtime all over the shop. It took lots and lots of complaining to get things fixed.

Then I moved house to the middle of nowhere in the Scottish Highlands (I don't really like people very much). Now we only have copper ADSL here up to around 6Mbit/s download. Happily our new house is rather close to a Vodafone cell tower so just use a 4G router and get circa 25-70Mbit/s download and 30Mbit/s upload. With a little help from OpenWrt SQM it's fine for all our business and personal needs. These days 4G/5G connections can give some of the weaker ADSL/fibre services a run for their money, albeit a good fixed line fibre is still of course superior. Our local farmer complained a lot about lack of fibre but didn't know about 4G - I told him to try and now he is very happy with it like me.

1 Like

Great idea, maybe we can "summon" @bill888 here to the thread as well. He might actually know how to resolve this issue.

These links might help:
https://openwrt.ebilan.co.uk/viewtopic.php?f=7&t=1088
https://forum.openwrt.org/t/lantiq-vrx200-xdsl-firmware-recommendation-thread/52937

However, your maximum attainable is 42.791 Mb/s down...and 663.476 Kb/s up.

Could be a line, or provisioning issue.

I would contact your ISP.

Which model of old BT router did you use?

I note from your first post, the Vendor ID is reported as Infineon (not Broadcom). It looks like you may be connected to a dreaded and rare ECI made FTTC cabinet (not Huawei/Broadcom). There was talk of trying to enable G.INP last year, but it may have been abandoned again.

I agree with @moeller0 with regards to trying a different firmware blob to see if it helps. The upload speed is abnormally low and it looks like a compatibility issue. As far as I'm aware, the firmware blob has not changed since LEDE 17.01.

I don't think any firmware blob will make a difference.

The VDSL line stats are coming directly from the DSLAM.

The firmware can't go any faster than the line data rate.

well it depends on what modulation scheme is in use. The firmware will negotiate that scheme. a different firmware blob can potentially negotiate a different modulation which could enable the higher upload speed.

I don't think that can exceed the maximum attainable rate of the VDSL line (screen shot in the first post).

That's the max attainable with the firmware blob currently in use. The max attainable with a different modulation would be different (kinda like the difference between 802.11n and 802.11ac)

So for the upload at 24 dB attenuation DSLAM and CPE negotiated a transmit power of only -4.5 dB, which effortlessly explains the low sync, but the question is why the low transpit power setting. And that might be related to a mismatch between dslam and cpe firmware versions. I still think trying a few different firmware blobs to be easy enough to try. But I also agree that it is not guaranteed to help.

Regarding modulations there is not much slack in VDSL2 as far as I can tell, for each subcarrier 0 to 15 bits per dsl clock can be used but at the OP's low transmit power not much SNR margin exists and hence subcarriers will only get a low bitloading....

1 Like

Also never underestimate the influence of half-broken cabling (in-house and patch cables, as well as the splitters and sockets; try the main service socket) - and yes, this individual bthub5 might also be a potential cause of problems (be is hardware damage of this particular devices, no vectoring blob loaded and being forced into a fallback profile or suboptimal compatibility between the DSLAM and this vr9 lantiq modem chipset).

One time my ADSL micro filter broke and I got weird stuff happening. Replaced that and that fixed the issue. Should definitely be checking results at the master socket too. Another time my extension cable got loose from master socket and had to just fiddle with that.