Slow speed on the smartphone

Hi guys,

I am writing here, because I need some imput for debugging a problem.

Until recently I was using a certain provider. I changed to another provider, because he offers static a IPv4 and v6 address, is cheaper, faster and I can make use to my FTTH connection.

The change went mostly smooth, but DHCPv6 on my wan6 interface didn't work, so I wiped my router (Netgear R7800), took the opportunity to update OpenWrt to 23.05.0 and reconfigured everything. Now, everything including DHCPv6 works.

The only thing I am experiencing, is that some particular internet-using apps on my smartphone are quite very slow. Certain refresh and loading activities take several seconds compared to maybe half a second using the LTE connection or the router wifi my old providers line (which is still active for a couple two weeks) connected to the router. This only seems to happen after some hours since the router has connected to the internet.

I already figured out that I can get rid of it (or at least improve it considerably, hard to tell) just by restarting the wan interfaces. I now have connected the router to the old provider again and leave it for a couple of hours, to see if the same happens there too. Then I will try to see, if deactivating IPv6 makes a difference, since I had deactivated everything related to it on my old OpenWrt installation.

Do you guys have an idea what could be the reason for that? I am hesitant to contact my provider yet. Also I changed too many variables at the same time to confidently say, what acutally might be wrong here. For the beginning I leave my network and my wifi config here. Let me know what else you need. Thank you for your help.

/etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid ':-D'
        option encryption 'sae-mixed'
        option key 'redacted'
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid ':-)'
        option encryption 'sae-mixed'
        option key 'redacted'
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'ap'
        option ssid ':-|'
        option encryption 'psk-mixed'
        option key 'redacted'
        option wpa_disable_eapol_key_retries '1'
        option network 'lan'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'guest'
        option encryption 'psk-mixed'
        option key 'redacted'
        option wpa_disable_eapol_key_retries '1'
        option network 'guest'

/etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd2b:8114:bd31::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config device
        option type 'bridge'
        option name 'br-guest'
        option bridge_empty '1'

config interface 'guest'
        option proto 'static'
        option device 'br-guest'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'

If only some apps fail, I would first check that your DNSs are working right, and the IPv6 connection is also working as expected.

Ok, had some time to do some more testing over the weekend. I tried using the old provider and the problem never reappeard. I tried the new provider (IPv4 only) and it worked fine for the whole day.

I now activated the wan6 interface again and I am now seeing these problems again. So they are tied to IPv6. I will try to figure out if DNS also causes problems. Thanks for the tip.

Still not sure if it is a router or provider problem tho. But I would guess the latter.

IPv6 tends to be poorly implemented / maintained on many ISPs, I would not be surprised if the fault is on their side.

I now also changed the DNS of both WANs to Google/Cloudflare and it behaves the same. Are there any other common things I can try before contacting my ISP?

Thank you

I think I found out what was causing the issue (still not why tho).

I've set 'DHCPv6-Service' to deactivated in the LAN interface settings in DHCP Settings/IPv6 Settings. Now everything seems to behave normal, even when the wan6 interface is up.

Kinda weird though. Does someone have an explanation for this?

I would guess that somethings are not reachable via IPv6... your devices likely default to trying IPv6 first and only after some timeout 'grudgingly' retry with IPv4...

1 Like