Slow download but fast upload on Mac Pro 2013

Hey all,

Just installed OpenWrt 21.02.3 on a Netgear R6700 v2. I have a late Mac Pro 2013 that has 20 mbps TX and 243 mbps RX to the router (on the 5Ghz band) via iPerf3 (Consistent with any online speed test I run).

However, since I have AT&T fiber, I also have the ARRIS BGW210-700 in the same closet -- when I connect to that with the Mac Pro 2013, I get around 137 mbps down and 125 mbps up. I also have a MacBook Pro 2018 that gets 260 mbps up and 281 mbps down on the R6700 v2.

(Edit: It's all worth noting that this is an issue with the wireless interface; when I hardwire the MacBook Pro 2013 to the R6700 v2 I receive full speeds through iperf3 and speed tests)

So, I've narrowed it down that:

  • Mac Pro 2013 gets poor download but near max upload on R6700v2 -- The BGW210-700 sees substantially better downloads.
  • MacBook Pro 2018 gets good speeds on either router.
  • For the 5Ghz band (which both machines are connecting to), the R6700v2 is operating in AC mode, auto channel, 80 MHz channel width. The BGW210-700 is operating in AC/N, auto channel, 80 MHZ channel width.

Here's the current OpenWRT WLAN config (I've disabled the 2.4 band for consistency in testing):

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option country 'US'
	option channel '11'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid ***********
	option key ***********
	option encryption 'psk2'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '5g'
	option cell_density '0'
	option country 'US'
	option channel 'auto'
	option htmode 'VHT80'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid ***********
	option key ***********
	option encryption 'psk2'
	option network 'lan'

Any ideas on what I can do so that the wifi download speed of the Mac Pro 2013 matches that of the MacBook Pro 2018 on the R6700v2? Thanks!

Edit: Here are the iperf3 tests:

root@iter:~# iperf3 -c 10.0.0.156
Connecting to host 10.0.0.156, port 5201
[  5] local 10.0.0.1 port 47728 connected to 10.0.0.156 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  2.25 MBytes  18.8 Mbits/sec   12   38.2 KBytes
[  5]   1.00-2.00   sec  1.99 MBytes  16.7 Mbits/sec   10   29.7 KBytes
[  5]   2.00-3.00   sec  2.19 MBytes  18.4 Mbits/sec   15   39.6 KBytes
[  5]   3.00-4.00   sec  2.03 MBytes  17.0 Mbits/sec    0   67.9 KBytes
[  5]   4.00-5.00   sec  2.92 MBytes  24.5 Mbits/sec    0   91.9 KBytes
[  5]   5.00-6.00   sec  2.24 MBytes  18.8 Mbits/sec    2   60.8 KBytes
[  5]   6.00-7.00   sec  2.49 MBytes  20.9 Mbits/sec    6   72.1 KBytes
[  5]   7.00-8.00   sec  2.30 MBytes  19.3 Mbits/sec    2   65.0 KBytes
[  5]   8.00-9.00   sec  2.73 MBytes  22.9 Mbits/sec    0   89.1 KBytes
[  5]   9.00-10.00  sec  2.36 MBytes  19.8 Mbits/sec    0    107 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  23.5 MBytes  19.7 Mbits/sec   47             sender
[  5]   0.00-10.01  sec  23.3 MBytes  19.6 Mbits/sec                  receiver

Interestingly, the TX rate really drop when performing bidirectional tests:

root@iter:~# iperf3 -c 10.0.0.156 --bidir
Connecting to host 10.0.0.156, port 5201
[  5] local 10.0.0.1 port 47722 connected to 10.0.0.156 port 5201
[  7] local 10.0.0.1 port 47724 connected to 10.0.0.156 port 5201
[ ID][Role] Interval           Transfer     Bitrate         Retr  Cwnd
[  5][TX-C]   0.00-1.00   sec   283 KBytes  2.32 Mbits/sec   10   7.07 KBytes
[  7][RX-C]   0.00-1.00   sec  23.7 MBytes   198 Mbits/sec
[  5][TX-C]   1.00-2.00   sec  93.3 KBytes   762 Kbits/sec    9   11.3 KBytes
[  7][RX-C]   1.00-2.00   sec  27.4 MBytes   229 Mbits/sec
[  5][TX-C]   2.00-3.00   sec   238 KBytes  1.95 Mbits/sec    0   18.4 KBytes
[  7][RX-C]   2.00-3.00   sec  25.1 MBytes   211 Mbits/sec
[  5][TX-C]   3.00-4.00   sec   198 KBytes  1.62 Mbits/sec   12   8.48 KBytes
[  7][RX-C]   3.00-4.00   sec  25.2 MBytes   211 Mbits/sec
[  5][TX-C]   4.00-5.00   sec   109 KBytes   893 Kbits/sec   12   4.24 KBytes
[  7][RX-C]   4.00-5.00   sec  25.2 MBytes   212 Mbits/sec
[  5][TX-C]   5.00-6.00   sec  99.0 KBytes   811 Kbits/sec   10   5.66 KBytes
[  7][RX-C]   5.00-6.00   sec  26.2 MBytes   220 Mbits/sec
[  5][TX-C]   6.00-7.01   sec  26.9 KBytes   220 Kbits/sec   11   5.66 KBytes
[  7][RX-C]   6.00-7.01   sec  27.1 MBytes   227 Mbits/sec
[  5][TX-C]   7.01-8.00   sec  93.3 KBytes   768 Kbits/sec    7   9.90 KBytes
[  7][RX-C]   7.01-8.00   sec  29.2 MBytes   246 Mbits/sec
[  5][TX-C]   8.00-9.00   sec   148 KBytes  1.22 Mbits/sec   10   7.07 KBytes
[  7][RX-C]   8.00-9.00   sec  22.3 MBytes   187 Mbits/sec
[  5][TX-C]   9.00-10.00  sec   286 KBytes  2.34 Mbits/sec    5   11.3 KBytes
[  7][RX-C]   9.00-10.00  sec  20.4 MBytes   171 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID][Role] Interval           Transfer     Bitrate         Retr
[  5][TX-C]   0.00-10.00  sec  1.54 MBytes  1.29 Mbits/sec   86             sender
[  5][TX-C]   0.00-10.04  sec  1.50 MBytes  1.25 Mbits/sec                  receiver
[  7][RX-C]   0.00-10.00  sec   253 MBytes   212 Mbits/sec                  sender
[  7][RX-C]   0.00-10.04  sec   252 MBytes   210 Mbits/sec                  receiver

To be sure, disable Location Services on your laptop running the test. And bring down the awdl0 interface too.

Thanks for the suggestions. I just redid the test on my MacBook 2018 with both awdl0 down and Location Services disabled---I still am getting around 250 mbps to the R6700v2.

I also just tried a speed test with my iPhone 8s, which is getting around 170 mbps.