Slow 5g connection in mt7621a board

hello

i have this problem I thought it was related to rooter forum but it's turned out it is openwrt settings and config... I willl past my story here maybe someone can help me..

regarding my post
whrl.pl/RgyHbv

I am posting now after a few hours of searching and trying many possible solutions, but first I would like to thank jhend for your reply

To make my story short I have 5g connection but I couldn't get my full 5g speed only 130-160 I thought its a module problem but after many builds and updates to the module I found the problem was related to the network firewall

so the solution, is you need to activate the "Software flow offloading" and " hardware flow offloading" from the firewall, you will find them under the firewall page and general settings, after that I'm getting 250mbps now

now i can get max 260 and sometimes spikes to 320.. but my tower is more capable on my phone from 400 to 600
p. s I don't use wifi. I test in openwrt same problem
I think there is something with settings

what else should I modify or add any help plz

  • Is this OpenWrt-related?
    • If so, please explain how?
  • Are you asking for help with an issue?
  • How is your cellular tower related to OpenWrt with no WiFi?

Have you looked at CPU utilization with top or htop? The MT7621 probably isn't enough CPU for those speeds.

Additional info that would help for debugging:

  1. What version of OpenWRT is this?

  2. What is your network topology and the name of the device with OpenWRT

  3. Your configuration: Please copy the output of the following commands and post it here using the "Preformatted text </> " button.

    Remember to redact passwords, MAC addresses and any public IP addresses you may have:

    cat /etc/config/network
    cat /etc/config/wireless
    cat /etc/config/dhcp
    cat /etc/config/firewall

1 Like

thank you for reply

im useing OpenWrt 19.07.6


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd77:fed0:d53f::/48'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ifname 'eth0.1 tap0 tap-server'

config device 'lan_eth0_1_dev'
        option name 'eth0.1'
        option macaddr '40:d6:3c:80:01:49'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option metric '1'

config device 'wan_eth0_2_dev'
        option name 'eth0.2'
        option macaddr '40:d6:3c:80:01:4a'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface 'VPN'
        option proto 'none'
        option ifname 'tun0'
        option auto '0'

config interface 'VPNS'
        option proto 'none'
        option ifname 'tun-server'
        option auto '0'

config interface 'TAP'
        option proto 'none'
        option ifname 'tap0'
        option auto '1'

config interface 'TAPS'
        option proto 'none'
        option ifname 'tap-server'
        option auto '0'

config interface 'wwan2'
        option proto 'dhcp'
        option metric '2'

config interface 'wwan26'
        option proto 'dhcpv6'
        option metric '2'

config interface 'wwan5'
        option proto 'dhcp'
        option metric '2'

config interface 'wwan56'
        option proto 'dhcpv6'
        option metric '2'

config interface 'wan2'
        option proto 'dhcp'
        option metric '20'
        option ifname 'wan2'

config interface 'wg0'
        option proto 'wireguard'
        option auto '0'
        list addresses ''

config interface 'wg1'
        option proto 'wireguard'
        option auto '0'
        list addresses ''

config interface 'wan1'
        option proto 'mbim'
        option device '/dev/cdc-wdm0'
        option metric '10'
        option currmodem '1'


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '0'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
        option flow_offloading_hw '1'
        option drop_invalid '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        option network 'wan wan6 wwan2 wwan5 wan1 wan2'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config zone 'vpnzone'
        option name 'VPN'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'VPN'
        option input 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding 'vpnforward'
        option dest 'VPN'
        option src 'lan'

config zone 'vpnzones'
        option name 'VPNS'
        option forward 'REJECT'
        option output 'ACCEPT'
        option network 'VPNS'
        option input 'ACCEPT'
        option masq '1'
        option mtu_fix '1'

config forwarding 'vpnforwards'
        option dest 'VPNS'
        option src 'lan'

config zone 'wgzone'
        option name 'wg'
        option forward 'ACCEPT'
        option output 'ACCEPT'
        option network 'wg0 wg1'
        option input 'ACCEPT'
        option masq '1'
        option mtu_fix '1'

  1. OpenWRT 19.07.6 is old and not supported anymore. If and when you upgrade to a newer version, you will have to re-configure. Do not keep your old configuration, as it will be incompatible.

  2. Are you using Wireguard VPN? Could VPN be the cause to slow things down? Try testing without VPN activated.

config interface 'wg0'
        option proto 'wireguard'
        option auto '0'
        list addresses ''

config interface 'wg1'
        option proto 'wireguard'
        option auto '0'
        list addresses ''

VPN not active, i tried latest build same problem ,its feel like CPU cant handle the speed , idk
I saw package online called turbo ACC but cant find it

And can you explain how the cellular modem is involved?

(That's still missing from the information.)