SkyQ VDSL setup

Hi all

I have just switched broadband providers.

I have a billion 8800nl and a Linksys 3200WRT running LEDE

My previous setup was Billion WAN in bridged mode and the Linksys in PPPoE with username and password

This didn’t work for SKY

I had to set the billion to PTM DSL = IPOE (IP over Ethernet) '802.1P Priority' = 0, 802.1Q VLAN ID = 101 Option 61 Client ID = your username and password with a '|' in between eg username@skydsl|password

With the Linksys in DHCP mode to get a local Ip of the lan side of the billion, not ideal, as for port forwards, I had to put a rule in the billion and the Linksys.

Is there a way in LEDE to have the billion in bridged mode and the Linksys pass option 61 over dhcp to the isp?

If you are in UK, I think you can just put the Billion in bridge mode like you did with your previous FTTC provider. (Annex B, tone A, VLAN 101).
Then on your 3200WRT, configure the WAN port as 'DHCP client' and filling in the 'Client ID' and 'Vendor class' fields.

It didnt work - put billion to bridged mode linksys left as dhcp (WAN to WAN port)

I just ended up getting a local address from my Billion and not a WAN address

Then my Linksys crashed and I had to failsafe it to stop the memory running out from failed connection attempts :frowning:

Discovered the crazy linksys router has 2 partitions though!

A bit strange your linksys obtained a local address from Billion which may suggest it may not be in bridge mode?

Only other thought is what version of OpenWRT is on the linksys given its behaviour?

I presume your Bipac 8800NL is configured as follows:

  1. PTM >> Bridging
  2. '802.1P Priority' to '0' and the ' 802.1Q VLAN ID' to '101'

And you filled in the Client ID and Vendor Class boxes on linksys.

Yep exactly like that

Infact that’s how I had it with my previous FTTC provider

I’m wondering if the billion used to receive a special type of pppoe packet from the Linksys previously and now it just gets a dhcp request.

With your previous ISP, the PPPoE and any other packets from the linksys are simply passed through the bridge modem to the ISP.
Sky uses MAC Encapsulated Routing, a form of DHCP. Any packets sent by linksys should be passing straight through the billion. It is not clear where the linksys is getting that local IP from.
I presume you don't have a spare bridge modem (openreach) or another openwrt router to test different equipment combinations to try and determine where the problem lies (it is probably openwrt linksys issue or may be wrong sky username/password)?

Thanks for the help

I think I need to reset my Billion and start from scratch.

I’ll back up the working config and try again.

This old post on thinkbroadband forum may be worth a read if you suspect username/password issues.
It also mentions having to clone the WAN MAC address of a working sky box. Also Vendor ID perhaps not required.

So interestingly the Billion connects to sky fine when using IPoE with option 61

No need to clone mac addresses or specify correct username and password.

I was hoping LEDE would have IPoE and use the Billion as a bridge

Ok something screwy must happened the first time I tried this.

I upgraded the firmware on the billion 8800nl r2 and reset it.

Then I did exactly as the first guide you posted. And boom it worked.

Billion in bridged and Linksys in dhcp

Thanks man

Last question.

If my Billion is in bridged mode (LEDE router connected to the WAN port) is the LAN switch ports secure?

If you are referring to the billion, do the unused lan ports still give you access to billion's web admin interface is only other function billion might offer when in bridge mode.

Yes I am and it does if it’s on the same IP range as the lan connected to it.

But I just wanted to check if it was secure, as in the default lan port grouping the wan port was in the same group. I have isolated them now( the wan and port 2,3,4 are in a different group to port 1 (I’m guessing this is vlan’in in billion world)

So port 2.3.4 and wan are

And port 1 is

My understanding on bridged mode is poor

best ask billion if you are worried about security.

I don't recommend it, but you could always fill the spare LAN ports with epoxy resin :smile:

1 Like

haha! :smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.