SkyQ IP Address Rejection DNSMasq loop

Hi. I have openWRT installed on a Mercusys MX90 but have been having trouble getting my SkyQ (TV box) connected via wired ethernet. Every time I try to connect the box I get IP address assignment error and checking the logs it seems to be stuck in a loop.

Sun Feb 11 14:56:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPDISCOVER(br-lan) 192.168.1.110 [MAC address redacted]
Sun Feb 11 14:56:40 2024 daemon.info dnsmasq-dhcp[1]: DHCPOFFER(br-lan) 192.168.1.110 [MAC address redacted]

The MAC address is differnt (1 incrimental digit) to the advertised mac address.

It connects fine to the openwrt router via wireless. What could be causing this issue?

Thanks,

Could you explain this with a mac scrambled?
Also:

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp

Hi trendy,

Sorry I 'm not sure, what do you mean with a mac scrambled? The final digit is +1 (everything else is the same).

If I get you right then if the advertised MAC is 8F:B8:7F:32:AB:B2 the connected device is 8F:B8:7F:32:AB:B3

This entry still shows in the devices list even when connected via wireless (i.e. the ethernet MAC (+1) shows as connected and no other MAC address [there are 3 macs according to the sky firmware all different, one for 2.4ghz, one for 5ghz and one for ethernet).

I tried to go and edit the log output but I don't have that auto format button but it's invisible, how strange, I thought this was a spacing hopefully this is fixed now.

Screenshot 2024-02-11 174950

I have never seen DNSMASQ do this, and I cannot figure out any option that could be related... Can you post your "dhcp" config file?

1 Like

The icon isn't rendering, but the button still seems to function. I'm not sure how to fix this, but looking into it.

1 Like

Just change a few chars in the address, but change them consistently, e.g all 1s to 9s.

I have it, try to force reload on your browser. But in any case you can use the 3 backquotes to enclose the console output.
```

"Preformatted text" button should be OK once again on touch devices. :slight_smile:

4 Likes
confmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option force '1'

config dhcp 'wan'
        option interface 'wan'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'
g dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
I dhcp [Modified] 41/80 51%

I have read that this is somehow generated by the SKY box (https://helpforum.sky.com/t5/Sky-Q/Extra-MAC-addresses/m-p/4525297) but not sure of the purpose or whether this is the cause but the box has connected (and received an IP) wired before.

The output is not clear. It seems to be repeated and you used the blockquote instead of preformatted text.
Run the uci export network; uci export dhcp to get the file contents and copy-paste them here.
From a first glance I see no ignore in wan interface, but this might as well be the result of bad copy-paste.

1 Like

Sorry hopefully more use:

package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd49:4be9:6202::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan0'
        list ports 'lan1'
        list ports 'lan2'

config device
        option name 'lan0'
        option macaddr '00:eb:d8:a2:73:38'

config device
        option name 'lan1'
        option macaddr '00:eb:d8:a2:73:38'

config device
        option name 'lan2'
        option macaddr '00:eb:d8:a2:73:38'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '61'

config interface 'wan'
        option device 'eth1'
        option proto 'dhcp'
        option broadcast '1'
        option clientid '736b7964736c40736b7964736c7c736b7964736c'

config interface 'wan6'
        option device 'eth1'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '56'
        option ip6assign '60'

and uci export dhcp

package dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option force '1'

config dhcp 'wan'
        option interface 'wan'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'

You are definitely missing the ignore option in wan and wan6, but I don't think this is connected to your problem with the box in the lan.
From the OpenWrt dnsmasq perspective, it is offering an IP to the box. The box should send the next packet, which is the DHCP request, but we don't see it. Can you setup a packet capture to verify that packets are not blocked anywhere?

opkg update; opkg install tcpdump; tcpdump -i br-lan -vn port 67

Then restart the box and when you capture some packets till the error shows on the box, stop with Ctrl-c and post here.

2 Likes

Thanks, might have to try this tomorrow since the other half is working right now. Will report back.

Hi.
You cannot have one IP address with two MAC addresses.
Every MAC address has to have its own unique IP address.
Say SkyQ wifi MAC address is xxxxx.10
SkyQ ethernet MAC address is xxxxx.11
For example, if the SkyQ previous used WiFI to connect.
The DHCP server would associate xxxxx.10 with 192.168.1.110
WHen the SkyQ requests an IP address on the ethernet, the DHCP server should give it a different IP address.
The DHCP server would associate xxxxx.11 with 192.168.1.111
So, there is something wrong with the configuration of the DHCP server making it give the same IP address to two different MAC addresses, and failing as a result.
A quick fix is to power cycle openWRT, then the SkyQ should connect via ethernet correctly.