SKY SR102 unable to connect via serial

Hi guys I'm trying to connect via serial to Sky SR102. The guide it's really good but I'm having trouble. I'm sure the cables are connected correctly (I've tried every possible combination) and I get RX and TX to light. Unfortunately I can't get any output in the terminal and I don't know why. When I run "screen /dev/tty.SLAB_USBtoUART 115200,-parenb,-cstopb,cs8" it just hangs and nothing happens. I've tried using different baud rates but still same problem. I've also installed Windows 10 and Putty appears to act the same as my Mac terminal. If I use a jumper on the device to connect TX and RX together and open a serial connection it works fine so I'm sure the problem is not the device itself. Also I've tried with another one but no luck. Any help would be much appreciated, cheers.

Firstly, have a look at unsupported functions here:

The serial connection seems simple because you only need to solder the pins if not available before also make sure that you are connecting 3 pins, GND to GND, RX and TX. You may need a usb to ttl adapter to make it work.

Hi, thanks for the reply but I don't think you've read my post fully.

@solver, hi and welcome to the community!

I believe @ahmar16 did read fully. In addition to noting that you should verify you have a 3.3 Volt TTL Serial adapter, also:

  • Ensure
    • GND-to-GND
    • RX-to-TX; and
    • TX-to-RX

You jumpered the TX/RX serial pins on the router; or on the TTL cable?

You tried another: router, computer/software or TTL cable?

At minimum please verify the correct cable, what you jumpered, what you tried, etc.

  • You found this at the general serial WIki? I found this nowhere else except in the OpenWrt Wiki...
  • Have you verified this is the actual path to your USB-to-TTL-Serial device?
1 Like

Thanks everyone for the help. I managed to solve the issue by buying a new device which connected on first try!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.