Sitecom WLR-8100 5GHz not working

So the old openwrt thread for this device is rather old, and I thought I'd make a new support thread here.

I installed the releases/17.01.2/targets/ar71xx/generic/lede-17.01.2-ar71xx-generic-wlr8100-squashfs-sysupgrade.bin release on my stock WLR-8100 today. Uploading the LEDE firmware via the factory's firmware update screen worked fine.

So far everything is working fine, except the 5GHz wlan adapter. It isn't showing up at all.

dmesg and syslog don't seem to have any mention of it.

lspci only shows the 2.4ghz adapter and the usb controller:

# lspci
00:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01)
01:00.0 Network controller: Qualcomm Atheros QCA986x/988x 802.11ac Wireless Network Adapter

Does anyone have any pointers on how to go about diagnosing and fixing this? Apparently it worked on older versions of openwrt (according to the openwrt forum and wiki)

1 Like

I managed to get 5Ghz working! :slight_smile:
I'll push it upstream soon. In the meantime i'll publish a working image here, if someone want it.

1 Like

I really would like to have it. Could you post it for me? Or how I could patch it myself?

I pushed the patch on github and blogic said the he merged the commit. However I don't see any changes in the source code... this is my first commit for Lede, so probably I miss something...

However this is the compiled images with my patches (USE AT YOUR OWN RISK):!zFpSAYoZ!UyFjChg-fdi3II8BtaFCkw

I never flashed the sysupgrade version on the router (AGAIN, USE AT YOUR OWN RISK), but I always tried the initramfs one loaded via tftpboot.

(Very) Quick guide to boot the initramfs version:

  1. Connect to the router via serial
  2. Stop the boot and press 1
  3. Configure the ip address and the TFTP software (I use tftpd) following the instruction on screen

The sysupgrade works like a charm! Thank you!

1 Like

I forgot to mention that the version you flashed, should also set the right MAC address for the 5Ghz wireless interface.
Can you check if it's working for you?

Thank you.

Any idea when/if this will make it into an official release? I'd like to upgrade my router using the normal method, as I don't have the tools to make a serial connection.

I really don't know.. :frowning:
However RHeijmann said that the sysupgrade version is working, so you could update using that version.

Under 17.01.04 doesn‘t work the 5ghz Wifi on Sitcom WLR 8100.
The Kernel load the QCA988x Firmware with errors.
A Great pity.

5ghz Works.
I change a Config in modules.d to:
cat /etc/modules.d/55-ath10k
ath10k_core skip_otp=y
ath10k_pci skip_otp=y
..I erase the Config wireles in /etc/config and reboot

5ghz works under 17.01.04 with this changes.

its terrible. At Work without encryption but with encryption its loses the contact after some time and the password is rejected.
A bad router. All my TP-Link router are better.

Did you try the build I made in the 4th post?
My commit isn't still merged, probabily in the next version it will be available.

i tryed the Build in 4th post, but i can't install luci-i18n-base-de and other package. Then i try the 170.01.04 after them and this image ist noct stable with 5ghz.

Sorry..not 170! I meen 17.01.04!
in the patch version I can not install certain packages.
I tried again. Midnight Comander (mc) is also missing,
so I wanted to try version 17.01.04.
There all possible packages are offered.
There are also all language packs available.

i give not up....
The Version (SNAPSHOT, r4951+1-c317af7) doesn't allow updates or install other package

root@LEDE:~# opkg install kmod-ath10k
Installing kmod-ath10k (4.9.58+2017-10-06-1) to root...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ath10k:
 *      kernel (= 4.9.58-1-eff5008ef5adbf8c89287067ddc446c0) * 
 * opkg_install_cmd: Cannot install package kmod-ath10k.

But 5ghz works fine with 80 MHz

In Version 17.04.01, works it with 20MHZ. With 40 MHZ or 80 MHZ the password ist rejected or lost the connection ..
I hope 17.05.01 are better...

I apologize for my absence but I was busy these days.
I spoke to blogic, but he seems to forgot again to include my patch. However i will compile a new version soon based on 17.01.04, so you'll be able to install every package! :wink:

@numero53 How do you install the sysupgrade instead of loading the initramfs via a serial connection?

I downloaded 17.01.4 and tried to upgrade it with the sysupgrade, but it fails

$ sysupgrade -v /tmp/lede-17.01.4-ar71xx-generic-wlr8100-squashfs-sysupgrade.bin
Image metadata not found
Sysupgrade is not yet supported on wlr8100.
Image check 'platform_check_image' failed.

In deed sysupgrade do not work with WLR-8100. I simply used mtd
mtd -r write /tmp/lede-17.01.4-ar71xx-generic-wlr8100-squashfs-sysupgrade.bin firmware
but have in mind that this will delete all your configuration / settings.

I've compiled LEDE 17.01.4 with 5GHz patch, so it should be compatible with every package currently available.
As always I didn't test the sysupgrade version, but only the initramfs one.
This is the link:!jRoDiCzR!QinvTvN-ssdYHJH1UlqG0A

Let me know if it's working.

1 Like

@numero53 The sysupgrade version worked! I used mtd to flash my device with success.

However I can't install kmods. Is this expected?

 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-storage:
 * 	kernel (= 4.4.92-1-45d282495a15974d60f8edb091d0e2a9) * 	kernel (= 4.4.92-1-45d282495a15974d60f8edb091d0e2a9) * 
 * opkg_install_cmd: Cannot install package kmod-usb-storage.

edit: the installed kernel package is kernel - 4.4.92-1-67330116fe3571490d39a39c471b22a5