Hello to all,
I want to connect my single port meraki mr18 acces point to the fibre modem as a pppoe client and I want to use it as an ethernet and wireless router, but it seems that some differences have emerged recently after DSA and this confused me. Meraki 18 has one ethernet port with the firmware 22.05.2. My ISP needs vlan tag 35 for pppoe connection. Can anybody help me for that?
Is the ethernet connected (or to be connected) directly to your ISP's modem?
Make sure you enable wifi first and then use that to connect to your device since we'll be re-assigning the ethernet port and we don't want to lose connectivity.
Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
cat /etc/config/network
Most devices with one port use the syntax eth0.N to create a VLAN on the port. This can be repeated in different networks with different VLAN numbers. Once you have started tagging VLANs, do not use plain eth0 anywhere in the configuration-- in other words don't try to mix tagged and untagged packets on the cable, the Linux kernel does not like that on direct ports.
Of course a VLAN-aware device such as a managed switch needs to be at the other end of the cable. That switch would be configured to send VLAN 35 tagged to the modem on one port, and other ports could be access mode on different VLAN for LAN devices.
Overall this concept is called a "one armed router" or "router on a stick."
Yes, ethernet connected directly to the ISP modem. Any my ISP need vlan 35 for the PPPOE connnection. Right now I am connected to the router wireless. Here is the output.
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd85b:65b3:41f3::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'
config device
option name 'eth0'
option macaddr '00:00:00:00:00:00'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
Ok... so this should be pretty easy.
Start by enabling wifi and connecting to the device via wifi instead of ethernet.
Once that is done, you can remove eth0 from br-lan
Now the ethernet port is no longer associated with the lan interface.
Create a new interface called wan
(lowercase) using device eth0.35
(that will be VLAN35 tagged on eth0). Set the protocol to PPPoE and then enter your credentials.
That's all you need to do. The ethernet port will be connected to the ISP modem, and you'll have a wifi network for your lan. Keep in mind that you will not have any ethernet connectivity for your local network -- if that is necessary, you will also need a VLAN aware (managed) switch.
Thanks for the reply but here is the result. It returns "Connection attempt failed"
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'faaaaaaaaaaaaaaaaaa'
config device
option name 'br-lan'
option type 'bridge'
config device
option name 'eth0'
option macaddr '00:00:00:00:00:00'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option type '8021q'
option ifname 'eth0'
option vid '35'
option name 'eth0.35'
config interface 'wan'
option proto 'pppoe'
option device 'eth0.35'
option username 'xxxxxxx@xxxxx'
option password '1234567'
option ipv6 'auto'
Read the log, I think that error means that there was some response from the ISP but they rejected your connection.
It is very strange,I remove vlan from wan interface and it get connected. But I am quite sure my pppoe connection need the vlan id 35. As @psherman mention, I remove eth0 from br-lan
. There is no vlan at eth port so I only get connection from wifi which meets my requirements for now. Last cat /etc/config/network
output is;
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'aaa:aa45:aaa0::/48'
config device
option name 'br-lan'
option type 'bridge'
config device
option name 'eth0'
option macaddr '00:00:00:00:00:00'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option proto 'pppoe'
option device 'eth0'
option username 'abcabc@xyznet'
option password '1234567'
option ipv6 'auto'
root@OpenWrt:~#
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.