Single Device (modem/router combo) faster than two (bridge+router) VRX200

Hello!

I have two VRX200 Devices (Fritz!Box 3370) and want to use them as a modem and router. Now I managed to get the whole deal working on a single device. But had trouble getting 100Mbit on a VDSL2 line with vectoring. I get about 65 regular and like twice 99 (no idea what changed). So now I tried to get this to work with two devices to "distribute" the usage. But I only got 35-40 Mbit and I got zero clue why. I tried to leech the information from this forum, but am just not smart enough.

Setup modem

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'this was pre filled'

config dsl 'dsl'
	option annex 'b'
	option line_mode 'vdsl'
	option ds_snr_offset '0'
	option tone 'bv'
	option firmware '/lib/firmware/vr9-B-dsl_5.7.5.5.1.7_3370-06-55.bin'
	option xfer_mode 'ptm'

config interface 'lan'
	option ifname 'eth0'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth0_dev'
	option name 'eth0'
	option macaddr '**'

config device 'wan_dsl0_dev'
	option name 'dsl0'
	option macaddr ':'

config interface 'wan_vdsl'
	option ifname 'dsl0.7 eth0.7'
    option type 'bridge'
	option proto 'none'
	option delegate '0'
	option force_link '1'
	option auto '1'

Setup router


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'this was pre filled'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0.7'
	option proto 'pppoe'
	option username 'myUsername'
	option password 'myPassword'
	option ipv6 'auto'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
    option device 'switch0'
	option vlan '7'
	option ports '4t 6t'
	option vid '7'

config interface 'dsl_modem'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option netmask '255.255.255.0'
	option ifname 'eth0.7'

What is wrong here? Why is this slower than a single device?
I have 100/40 Mbit line on 993.5 and i apparently need to tag the vlan with 7. I would appreciate your help.

Do these numbers refer to the VDSL2 sync rate, or did you measure the data throughput with a speed test?

Please run:

/etc/init.d/dsl_control status

on the device connected to VDSL2 and post the output.

Assuming eth0 is connected to the internal switch, you should add the switch and switch_vlan sections here as well. Currently, VLAN tags (eth0.7) are sent through an unconfigured switch, which is not recommended and will only work by chance.

2 Likes

Yes definitely check the layer 1 status as @mpa said.

You can add the tags within the modem box directly before the DSL interface, it is not necessary to run tagged on the Ethernet cable. If you do want two VLANs e.g. for administration and data, make them both tagged or just use two ports.

pppoe uses quite a bit of CPU so it is an interesting choice which box it should run on.

2 Likes

@mpa
These values came from a speed test. Today I ran that again and I got higher speeds. It feels so random.

ATU-C Vendor ID:                          Broadcom 194.105
ATU-C System Vendor ID:                   Broadcom
Chipset:                                  Lantiq-VRX200
Firmware Version:                         5.7.6.10.0.7
API Version:                              4.17.18.6
XTSE Capabilities:                        0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x2
Annex:                                    B
Line Mode:                                G.993.5 (VDSL2 with down- and upstream vectoring)
Profile:                                  17a
Line State:                               UP [0x801: showtime_tc_sync]
Forward Error Correction Seconds (FECS):  Near: 0 / Far: 3667
Errored seconds (ES):                     Near: 0 / Far: 948
Severely Errored Seconds (SES):           Near: 0 / Far: 287
Loss of Signal Seconds (LOSS):            Near: 0 / Far: 0
Unavailable Seconds (UAS):                Near: 45 / Far: 45
Header Error Code Errors (HEC):           Near: 0 / Far: 0
Non Pre-emtive CRC errors (CRC_P):        Near: 0 / Far: 0
Pre-emtive CRC errors (CRCP_P):           Near: 0 / Far: 0
Power Management Mode:                    L0 - Synchronized
Latency [Interleave Delay]:               0.13 ms [Fast]   0.0 ms [Fast]
Data Rate:                                Down: 89.799 Mb/s / Up: 42.510 Mb/s
Line Attenuation (LATN):                  Down: 15.4 dB / Up: 18.6 dB
Signal Attenuation (SATN):                Down: 15.4 dB / Up: 18.5 dB
Noise Margin (SNR):                       Down: 6.1 dB / Up: 6.5 dB
Aggregate Transmit Power (ACTATP):        Down: 6.0 dB / Up: 12.5 dB
Max. Attainable Data Rate (ATTNDR):       Down: 95.934 Mb/s / Up: 45.276 Mb/s
Line Uptime Seconds:                      259
Line Uptime:                              4m 19s

I posted the full configs for the two devices. I thought, the less on the modem, the better. But like @mk24 mentioned, the pppoe stuff on the router eats basically the same cpu as before.

I don't know, what 'before' means. Like dsl0.7 eth0 and no x.7 stuff on the router?

Would be adding a switch like below better? And would that be the whole tagging?

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 0 1 6t'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option ports '4 6t'

Thanks for taking the time to help me.

edit: I forgot to mention: I notice a huge speed increase after activating flow offloading in the firewall. the data rate was still high w/ or w/o.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.