Since 3 days, I have a Aria2 problem under 19.07.8 ..Aria not downloading anymore...and Help?

Hello everbody, since 3 days, my Aria2 isnt downloading anymore, I check out my log file, and it says this:

root@lede:~# cat /var/log/aria2.log 

2022-02-01 16:56:18.870036 [ERROR] [] Failed to load private key from /etc/ssl/mycert_luci_lede.key. Cause: error:0200100D:system library:fopen:Permission denied
2022-02-01 16:56:18.894801 [ERROR] [] Exception caught while loading DHT routing table from //.cache/aria2/dht.dat
Exception: [] errorCode=1 Failed to load DHT routing table from //.cache/aria2/dht.dat

Doesn anyone have a clue, what I can do, I havent changed my Aria2 configuration/setup.... so strange...

Thanks for help

use the </> button when posting code/errors.

well, permission denied is permission denied ....

what does ls -l /etc/ssl/mycert_luci_lede.key say ?

1 Like

Permission denied, when 4 days ago all still worked... what to do to fix it... I mean, I have created that for certificate for HTTPS Luci and it works all perfect, here is reply:

root@lede:~# ls -l /etc/ssl/mycert_luci_lede.key 
-rw-------    1 root     root          3268 Nov 18 19:56 /etc/ssl/mycert_luci_lede.key

Thanks for reply... maybe have tto install all new?

means it's only accessible for the user who created it, which user runs Aria ?

1 Like

I did it the way described here:

I need change chmod I run aria2 under another user of course not root... can you give me a hint how to fix please? and what is that " Exception caught while loading DHT routing table from //.cache/aria2/dht.dat" error comming from? maybe comes, cause wrong chmod too?

I changed chmod of key for its readble also by groups... will test... Thanks ..maybe the DHT error also disappears.. will let you know, again, Thank you!

is the aria user a member of the root group ?

you can't trust the errors coming after, they might be related to the 1st one, so fix one at a time.
it could be related to the unreadable cert, but also to wrong auths if you accidently ran the application using the wrong user (like root).

1 Like

the certificate permission error has gone away in log files, Thanks, I didnt knew I had to add user of aria2 into group root... what a idiot I am.. Thanks

but, this error remains in log file

root@lede:~# cat /var/log/aria2.log 

2022-02-01 22:16:40.663082 [ERROR] [] Exception caught while loading DHT routing table from //.cache/aria2/dht.dat
Exception: [] errorCode=1 Failed to load DHT routing table from //.cache/aria2/dht.dat

Several posts online about that particular error.

Not OpenWRT related.

1 Like

No must, you could have chmod:ed the file to
-rw-r--r-- instead.

1 Like

Thanks all for help, I deleted it (Aria2), it doesnt download anymore... will try to make new installation on second partition of my WRT3200ACM, all fresh.. and see, if then it works again... if not, well, as its NOT a OpenWRt problem as someone pointed out.... well.. nomore Aria2 then